elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Cifrar documentos-carpetas con GnuPG en Linux y Windows


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación General
| | |-+  ASM (Moderador: Eternal Idol)
| | | |-+  Como pasar de psudocodigo a mips.
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Como pasar de psudocodigo a mips.  (Leído 3,418 veces)
Hipeople

Desconectado Desconectado

Mensajes: 5


Ver Perfil
Como pasar de psudocodigo a mips.
« en: 10 Junio 2009, 20:14 »

Hola!!

bueno antes que nada pedir perdon por no presentarme antes y exigir ayuda sin más... en fin me llamo maria.

Necesito una ayudita, tengo algo de idea pero no se exactamente como hacerlo.

Tengo el pseudo de c que creo que esta bien:

var
max, min, num : entero

incio
num=0
escribir("dame el maximo");
leer (max)
escribir ("dame el minimo")
leer(min)
si max < min eentonces
   escribir error
sino
   mientras num<>-100
   escribir ("escribe numero")
   leer (num)
fin_mientras
fin_si
fin

si me decis como mas o menos hago para poder escribir por pantalla en mips pues creo que ya podria hacer algo, un saludooo y graciasss


« Última modificación: 10 Junio 2009, 20:16 por Hipeople » En línea

Eternal Idol
Moderador
***
Desconectado Desconectado

Mensajes: 5.512


La mano invisible del mercado me robo la billetera


Ver Perfil WWW
Re: Como pasar de psudocodigo a mips.
« Respuesta #1 en: 10 Junio 2009, 20:26 »

Aca tenes la referencia del simulador que dijiste usar:
http://en.wikipedia.org/wiki/SPIM

Un ejemplo muy simple:
Código:
li $v0, 11 #servicio 11, print char
la $a0, 'Z' #letra que queremos imprimir
syscall

Ahora consulta ese y los otros enlaces que te deje, ahi tenes TODO lo que necesitas para hacer el programa.


En línea

La economía nunca ha sido libre: o la controla el Estado en beneficio del Pueblo o lo hacen los grandes consorcios en perjuicio de éste.
Juan Domingo Perón
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
llevar del lenguaje C a MIPS
Dudas Generales
ISKRA 0 3,470 Último mensaje 20 Febrero 2011, 15:30
por ISKRA
Programacion MIPS ¿para que me serviria?
ASM
andres_5 3 3,949 Último mensaje 29 Marzo 2011, 11:08
por Eternal Idol
ENSABLADOR MIPS
ASM
SKaY9 1 1,248 Último mensaje 10 Mayo 2013, 14:24
por SKaY9
[APORTE] Videojuego TETRIS en MIPS
ASM
NullP0inter 3 2,103 Último mensaje 19 Diciembre 2014, 00:34
por cpu2
Pasar de C a mips
Ejercicios
elig 0 767 Último mensaje 14 Septiembre 2016, 15:06
por elig
Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines