elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Sigue las noticias más importantes de elhacker.net en ttwitter!


+  Foro de elhacker.net
|-+  Comunicaciones
| |-+  Dispositivos Móviles (PDA's, Smartphones, Tablets)
| | |-+  Hacking Mobile
| | | |-+  Problema BlueZScanner y problema de conexión
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema BlueZScanner y problema de conexión  (Leído 3,276 veces)
Kasswed
Moderador Global
***
Desconectado Desconectado

Mensajes: 5.269


Andalucía


Ver Perfil
Problema BlueZScanner y problema de conexión
« en: 6 Mayo 2006, 00:34 »

Vaya... mi primer tema en este foro...  :D :D

Tengo dos problemas. Lo primero decir que uso Motorola SLVR, y en este móvil tienes que poner una opción que se llama "Encuéntrame" para que, al hace run simple "hcitool scan" te lo detecte (igual pasa con bluezscanner).

Bien, pongo "Encuéntrame" y hago:

Código:
./bluezscanner -cp

Me devuelve:

Código:
+ BlueZScanner, por Gospel <gospel.endorasoft.es>

Detectando dispositivos ...

Dispositivo (1) encontrado:
        MAC: 00:17:00:CE:E1:E3          Nombre: Motorola SLVR
        Fabricante del Chip Bluetooth:
                · Motorola MDb
        Class: 0x522204 [010100100010001000000100]
         - Servicios soportados (Service Classes):
                · Telephony (Cordless telephony, Modem, Headset service, ...)
                · Object Transfer (v-Inbox, v-Folder, ...)
                · Networking (LAN, Ad hoc, ...)
         - Tipo de dispositivo (Device Class):
                · Phone > Cellular
        Perfiles Bluetooth disponibles:
Violación de segmento

Es decir, los perfile sno me los muestra...

Pero es que intento hacer esta otra cosa (después de modificar hcid.conf):

Código:
rfcomm connect 0 00:17:00:CE:E1:E3 1

Y en el móvil me dice:

Citar
¿Vinculado a bluek? Si o no.

Le digo qu si, y me salta la pantalla de meter el PIN, pongo el pin que tengo en /etc/bluetooth/pin (1234) y me dice el Motorola:

Citar
Pin no válido.

Y en la consola sale:

Código:
Can't connect RFCOMM socket: Connection refused

He probado con más canales, y lo mismo...

Si hago:

Código:
sdptool browse 00:17:00:CE:E1:E3

Me devuelve:

Código:
Browsing 00:17:00:CE:E1:E3 ...
Service Search failed: Connection timed out

Y nada, no sé qué hacer ni cómo hacer... Supuestamente me tendría que saltar una ventana para meter yo el pin en mi gnome, pero no me salta esa ventana. Tengo todos los paquetes BlueZ (creo que todos xD) instalados, y no entiendo qué puede estar pasando...

 :-\ :-\


En línea

"He who allows himself to be insulted, deserves to be."

Repórtame cualquier falta a las normas del foro por mensaje privado.
Gospel
Colaborador
***
Desconectado Desconectado

Mensajes: 1.586


Ver Perfil WWW
Re: Problema BlueZScanner y problema de conexión
« Respuesta #1 en: 6 Mayo 2006, 16:32 »

A ver, hay varias formas de emparejar el teléfono con linux.

1) De forma automática, indicando en la opción pin_helper la ruta /etc/bluetooth/pin y poniendo en el mismo fichero "123456" o "PIN : 123456". De esta forma, cuando al PC se le pide un PIN, entrega ese por defecto. No estoy muy seguro exactamente porque hay varias fuentes por internet y a mi no me ha funcionado 100% de las veces q he probado.

2) De forma manual, indicando en la opción pin_helper la ruta de un programa gestor de PIN, q lance en el escritorio un dialog en el q el usuario pueda meter el pin q quiera. Uno de estos gestores está en /usr/bin/bluepin. He probado varias veces y me ha funcionado siempre...

No sé porque a ti no te lanza esa ventana cuando el teléfono requiere q el PC le devuelva el PIN. Prueba a lanzar el programa llamándolo directamente desde una shell, a ver si se te abre... no sé q puede ser chico...

De todas formas, ya puedes ver q los Motorola son un poco "especialitos" porque parece ser q no permiten acceder al SDP si no estás emparejado. No puedes con Bluezscanner ni con sdptool browse...

Te comenté lo de conectarte a un perfil cualquiera del teléfono, forzar el emparejamiento y entonces probar si entonces si dejaba acceder al SDP y listar los perfiles. Pero claro, conectarte a un channel sin conocer el perfil q anda detrás... pues vete a saber... igual es el perfil de Sincronización del PIM...

Si en Linux ves q te da tantos problemas, prueba desde Windows. Utiliza Mis Sitios Bluetoooth para encontrar el Motorola, te emparejas con él y pruebas a ver si te detecta los perfiles entonces. Una vez q te saque los perfiles, intenta conectarte al perfil de Puerto Serie y abres una sesión al puerto COM especificado usando Hyperterminal, tal y como se comenta en http://gospel.endorasoft.es/seguridad/telefonos/bluebugwin.htm

Si Windows no te detecta los perfiles, ya estamos jodidos...


En línea

Kasswed
Moderador Global
***
Desconectado Desconectado

Mensajes: 5.269


Andalucía


Ver Perfil
Re: Problema BlueZScanner y problema de conexión
« Respuesta #2 en: 6 Mayo 2006, 20:16 »

Bien, con Windows he podido (gracias al Software que traía el USB Bluetooth) emparejarme con el Motorola.

Sólo dos cosillas.

Una, es que no encuentro eso de "Mis sitios de Bluetooth" y lo tengo que hacer con el software del USB Bluetooth  :-\

Otra es que al detectar perfiles, detecta tres, y entre ellos no está el del puerto de serie. Me detecta estos:

  • Servicio de acceso por marcación a la red de Bluetooth.
  • Servicio de envío de objetos de Bluetooth.

Y otro, que se llama igual xD:

  • Servicio de envío de objetos de Bluetooth.

Es curiosillo...

En línea

"He who allows himself to be insulted, deserves to be."

Repórtame cualquier falta a las normas del foro por mensaje privado.
Gospel
Colaborador
***
Desconectado Desconectado

Mensajes: 1.586


Ver Perfil WWW
Re: Problema BlueZScanner y problema de conexión
« Respuesta #3 en: 6 Mayo 2006, 22:04 »

Es posible q el teléfono móvil no soporte el perfil de Puerto Serie, lo que me extraña es q tampoco incorpore el perfil de Auriculares... en fin... estos de Motorola...

Mis Sitios Bluetooth te lo instala Windows automáticamente si tienes SP2 e instalas el software del USB Bluetooth, siempre q este no está basado en una pila q no utilice Mis Sitios Bluetooth, sino un gestor de conexiones propio, por ejemplo: los USBs Bluetooth basados en pila de protocolos Toshiba. Si está basado en pila Widcomm, entonces creo q Windows si te instala Mis Sitios Bluetooth...

En tu caso, no necesitas Mis Sitios Bluetooth pq el USB Bluetooth q compraste utiliza un gestor de conexiones propio. Da igual, es casi lo mismo...

Saludos
« Última modificación: 6 Mayo 2006, 22:06 por Gospel » En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problema con LogonUser() / ImpersonateLoggedOnUser()
Programación C/C++
APOKLIPTICO 0 405 Último mensaje 24 Julio 2012, 16:15
por APOKLIPTICO
Problema con TrackBar (Value y SmallChange)
.NET
Ikillnukes 4 387 Último mensaje 3 Julio 2013, 20:48
por Ikillnukes
Problema con Setter
Java
bemone 4 469 Último mensaje 4 Julio 2013, 15:19
por bemone
Problema con _itoa_s
Programación C/C++
C_1^N 4 351 Último mensaje 17 Julio 2013, 14:11
por C_1^N
Problema con SearchFilterHost.exe
Windows
ccrunch 2 2,282 Último mensaje 29 Septiembre 2013, 12:33
por ccrunch
Powered by SMF 1.1.19 | SMF © 2006-2008, Simple Machines