elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Security Series.XSS. [Cross Site Scripting]


+  Foro de elhacker.net
|-+  Seguridad Informática
| |-+  Hacking Wireless
| | |-+  Wireless en Linux
| | | |-+  Problema con aireplay-ng
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema con aireplay-ng  (Leído 3,515 veces)
lenchito_om

Desconectado Desconectado

Mensajes: 6



Ver Perfil WWW
Problema con aireplay-ng
« en: 3 Abril 2012, 09:36 am »

Me surge este problema a la hora de enviar paquetes y quisiera saber el motivo. Tengo entendido, por lo que he investigado en la web, que se necesita de un parche para evadir esto, pero no sé cómo hacerlo y quisiera que me ayudaran. Les dejo tal cual el resultado después de aplicar el aireplay-ng.

lenchito@lench-home:~$ sudo aireplay-ng -3 -b 00:00:00:00:00:00 -h 00:11:22:33:44:55 wlan0
02:00:18  Waiting for beacon frame (BSSID: 00:00:00:00:00:00) on channel -1
02:00:18  Couldn't determine current channel for wlan0, you should either force the operation with --ignore-negative-one or apply a kernel patch
Please specify an ESSID (-e).
lenchito@lench-home:~$


¡Ayuda por favor!
En línea

Debo respetar las opiniones de los demas inclusive si no estoy de acuerdo con ellas.
adastra
Endless Learner
Ex-Staff
*
Desconectado Desconectado

Mensajes: 885


http://thehackerway.com/


Ver Perfil WWW
Re: Problema con aireplay-ng
« Respuesta #1 en: 3 Abril 2012, 10:01 am »

Utiliza el búscador de este sitio, efectivamente necesitas aplicar un parche para que aircrack-ng ajuste correctamente el canal de la tarjeta en modo monitor y dicho problema se ha comentado con anterioridad en este foro.
En línea

ruben1980

Desconectado Desconectado

Mensajes: 86


El saber no ocupa lugar!!!


Ver Perfil
Re: Problema con aireplay-ng
« Respuesta #2 en: 3 Abril 2012, 10:47 am »


02:00:18  Couldn't determine current channel for wlan0, you should either force the operation with --ignore-negative-one or apply a kernel patch

Ahí esta tu respuesta:  aplica la opcion "--ignore-negative-one" o aplica los parches para no tener que ponerlo mas.
con el comando "uname -r" te da tu version de kernel, te bajas el parche para tu kernel y lo aplicas!!!!
En línea

Más grande que el AMOR a la libertad es el ODIO a quien te la quita.
ctcx

Desconectado Desconectado

Mensajes: 30


Ver Perfil
Re: Problema con aireplay-ng
« Respuesta #3 en: 3 Abril 2012, 19:26 pm »

Yo siempre tengo que usar la opción --ignore-negative-one para que me deje seguir, pero creo que esto sólo se salta el error, pero no lo corrige, y por ende creo que no filtra bien el canal.

Uso openSUSE 12.1 kernel 3.1.9-1.4, de driver uso b43 porque la tarjeta es Broadcom, driver que por cierto no he visto que haya sido actualizado en un buen tiempo.... Puede que sea una pregunta repetida, ¿pero cómo o dónde puedo buscar el parche para corregir el error del canal -1? ¿Y cómo lo instalaría?

Por su ayuda, gracias.
En línea

lenchito_om

Desconectado Desconectado

Mensajes: 6



Ver Perfil WWW
Re: Problema con aireplay-ng
« Respuesta #4 en: 3 Abril 2012, 22:15 pm »

Gracias por su pronta respuesta, ahora ya tengo solucionado el problema y efectivamente tenía que parchar mi kernel según su versión. En mi caso la versión del Kernel que tengo es la 3.0.0-17-generic-pae.

Ahora mismo les pondré como lo solucioné y explicaré paso a paso para quien tenga el mismo error le sea de su ayuda.

Lo primero que hice fue descargar el compat-wireless según la versión del Kernel que se tiene. Para saber la versión se aplica el siguiente comando en la consola.

uname -r

Aquí les dejo la dirección url de donde se puede descargar el compat-wireless.

http://linuxwireless.org/en/users/Download/stable

Ahí mismo buscan en el punto 4. compat-wireless stable releases la versión igual o mayor a la de su Kernel.

Se descarga el archivo, se extrae en la "carpeta personal" y se pasa a parchar aplicando los siguientes comandos. Todo se hará en la misma terminal.

cd compat-wireless-3.0.9-1

wget http://patches.aircrack-ng.org/channel-negative-one-maxim.patch

patch ./net/wireless/chan.c channel-negative-one-maxim.patch

gedit scripts/update-initramfs <---Este abrirá el editor de texto y ahí buscan la linea que dice KLIB=/lib/modules/$(uname -r)/build y se se reemplaza por KLIB=/lib/modules/3.0.9-1/build, donde 3.0.9-1 es la versión del compat-wireless que se descargo según el Kernel y misma que se tiene que cambiar por la que ustedes necesitaran. Guardan los cambios y regresamos a la terminal con los siguientes comandos.

make

sudo make install

sudo reboot

Y Listo, ya podrán aplicar el aireplay-ng sin ningún problema. Espero les haya sido de mucha ayuda.
« Última modificación: 6 Abril 2012, 03:47 am por lenchito_om » En línea

Debo respetar las opiniones de los demas inclusive si no estoy de acuerdo con ellas.
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problema aireplay-ng
Hacking Wireless
aninhill 5 2,418 Último mensaje 3 Octubre 2010, 19:17 pm
por Delacure Mihawk
Problema con aireplay-ng
Wireless en Linux
3rGh4L 4 2,413 Último mensaje 27 Marzo 2011, 20:33 pm
por ChimoC
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines