elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Introducción a Git (Primera Parte)


+  Foro de elhacker.net
|-+  Seguridad Informática
| |-+  Hacking Wireless
| | |-+  Wireless en Linux
| | | |-+  Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] 2 Ir Abajo Respuesta Imprimir
Autor Tema: Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...  (Leído 30,795 veces)
Ormuzd

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...
« en: 15 Febrero 2014, 23:14 pm »

No se si estoy haciendo algo mal.
Mi portatil tiene una Intel Pro/Wireless 2200BG integrada (un Samsung Q30) la cual esta soportada por Wifislax.

La cuestion es que la pongo en modo monitor y empiezo con el reaver

Código:
wifislax ~ # reaver-1.3 -i eth0 -b 88:03:55:xx:xx:xx -c 11 -e xxx -vv

Reaver v1.3 WiFi Protected Setup Attack Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>

[+] Waiting for beacon from 88:03:55:82:14:22
[+] Switching eth0 to channel 11
[!] WARNING: Failed to associate with 88:03:55:xx:xx:xx (ESSID: xxx)
[!] WARNING: Failed to associate with 88:03:55:xx:xx:xx (ESSID: xxx)
[!] WARNING: Failed to associate with 88:03:55:xx:xx:xx (ESSID: xxx)
[!] WARNING: Failed to associate with 88:03:55:xx:xx:xx (ESSID: xxx)
[!] WARNING: Failed to associate with 88:03:55:xx:xx:xx (ESSID: xxx)
[!] WARNING: Failed to associate with 88:03:55:xx:xx:xx (ESSID: xxx)
[!] WARNING: Failed to associate with 88:03:55:xx:xx:xx (ESSID: xxx)
[!] WARNING: Failed to associate with 88:03:55:xx:xx:xx (ESSID: xxx)
[!] WARNING: Failed to associate with 88:03:55:xx:xx:xx (ESSID: xxx)
[!] WARNING: Failed to associate with 88:03:55:xx:xx:xx (ESSID: xxx)
[!] WARNING: Failed to associate with 88:03:55:xx:xx:xx (ESSID: xxx)
^C
[+] Nothing done, nothing to save.
[+] Session saved.

La cuestion es que no acaba nunca por asociarse. El router es mio y el portatil esta como a 2 metros.

¿Hago algo mal?

Gracias.
En línea

noopynoob

Desconectado Desconectado

Mensajes: 104



Ver Perfil
Re: Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...
« Respuesta #1 en: 15 Febrero 2014, 23:23 pm »

cambia eth0 por mon0 o por la interfaz de red inalámbrica tuya.
« Última modificación: 15 Febrero 2014, 23:30 pm por noopynoob » En línea

Ormuzd

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Re: Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...
« Respuesta #2 en: 15 Febrero 2014, 23:39 pm »

cambia eth0 por mon0 o por la interfaz de red inalámbrica tuya.

eth0 es la tarjeta wireless.
Wifislax me pone en eth0 la tarjeta WiFi y en eth1 la tarjeta de red

Pongo la tarjeta en modo monitor con

Código:
iwconfig eth0 mode monitor

Ya que con airmon-ng start eth0 me da error, no me puede crear mon0
« Última modificación: 16 Febrero 2014, 00:06 am por Ormuzd » En línea

Stakewinner00


Desconectado Desconectado

Mensajes: 1.426



Ver Perfil WWW
Re: Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...
« Respuesta #3 en: 15 Febrero 2014, 23:48 pm »

Puedes pegar lo que te salga con ifconfig? me extraña mucho esto....
En línea

noopynoob

Desconectado Desconectado

Mensajes: 104



Ver Perfil
Re: Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...
« Respuesta #4 en: 15 Febrero 2014, 23:56 pm »

eth0 es la tarjeta wireless.
Wifislax me pone en eth0 la tarjeta WiFi y en eth1 la tarjeta de red

Pongo la tarjeta en modo monitor con

Código:
iwconfig eth0 modelo monitor

Ya que con airmon-ng start eth0 me da error, no me puede crear mon0

tengo entendido que eth0 es la tarjeta ethernet y no de wifi :huh:

cuando tecleas iwconfig cuales son las interfaces? puedes copiarlas?
En línea

Ormuzd

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Re: Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...
« Respuesta #5 en: 16 Febrero 2014, 00:01 am »

Código:
wifislax ~ # ifconfig
eth0      Link encap:UNSPEC  HWaddr 00-12-F0-AA-DF-14-00-D4-00-00-00-00-00-00-00-00  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:135747 errors:0 dropped:13322 overruns:0 frame:0
          TX packets:27301 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:68258259 (65.0 Mb)  TX bytes:3439555 (3.2 Mb)

eth1      Link encap:Ethernet  HWaddr 00:00:F0:79:51:07  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:5

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1884 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1884 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:144504 (141.1 Kb)  TX bytes:144504 (141.1 Kb)

wifislax ~ # iwconfig
lo        no wireless extensions.

eth0      IEEE 802.11bg  ESSID:off/any  
          Mode:Monitor  Frequency:2.462 GHz  Access Point: Not-Associated  
          Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2302   Missed beacon:0

eth1      no wireless extensions.

Y de regalo el error q me da al poner en modo monitor con airmon, que no pasa a modo monitor ni me crea la interfaz mon0

Código:
wifislax ~ # airmon-ng start eth0


Found 1 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
14826 dhcpcd
Process with PID 14826 (dhcpcd) is running on interface eth0


Interface Chipset Driver

eth0 Intel 2200BG/2915ABG ipw2200 - [phy0]mon0: unknown interface: No existe el dispositivo

(monitor mode enabled on mon0)

Y como he dicho antes ponga la tarjeta wifi en modo monitor con
Código:
iwconfig eth0 mode monitor
« Última modificación: 16 Febrero 2014, 00:07 am por Ormuzd » En línea

noopynoob

Desconectado Desconectado

Mensajes: 104



Ver Perfil
Re: Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...
« Respuesta #6 en: 16 Febrero 2014, 00:12 am »

Ormuzd haz lo que te dije y me dices si funciona:


airmon-ng start eth0 (si no lo has hecho)
reaver-1.3 -i mon0 -b 88:03:55:xx:xx:xx -c 11 -e xxx -vv
« Última modificación: 16 Febrero 2014, 00:15 am por noopynoob » En línea

Stakewinner00


Desconectado Desconectado

Mensajes: 1.426



Ver Perfil WWW
Re: Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...
« Respuesta #7 en: 16 Febrero 2014, 00:12 am »

que pasa si le das a ifconfig wlan0 up?
En línea

Ormuzd

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Re: Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...
« Respuesta #8 en: 16 Febrero 2014, 00:25 am »

Ormuzd haz lo que te dije y me dices si funciona:


airmon-ng start eth0 (si no lo has hecho)
reaver-1.3 -i mon0 -b 88:03:55:xx:xx:xx -c 11 -e xxx -vv

El codifo del airmon lo tienes justo antes de tu post y da error y no me crea la interfaz mon0

Código:
wifislax ~ # airmon-ng start eth0


Found 1 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
14826 dhcpcd
Process with PID 14826 (dhcpcd) is running on interface eth0


Interface Chipset Driver

eth0 Intel 2200BG/2915ABG ipw2200 - [phy0]mon0: unknown interface: No existe el dispositivo

(monitor mode enabled on mon0)

que pasa si le das a ifconfig wlan0 up?

Me da error porque no tengo interfaz wlan0

Código:
wifislax ~ # ifconfig wlan0 up
wlan0: unknown interface: No existe el dispositivo

Te pego ifconfig -a con todos los interfaces (activados como desactivados)

Código:
wifislax ~ # ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:12:F0:AA:DF:14  
          inet addr:192.168.0.177  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::212:f0ff:feaa:df14/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:138961 errors:0 dropped:14970 overruns:0 frame:0
          TX packets:29071 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:69565699 (66.3 Mb)  TX bytes:3864499 (3.6 Mb)

eth1      Link encap:Ethernet  HWaddr 00:00:F0:79:51:07  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:5

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1948 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1948 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:149440 (145.9 Kb)  TX bytes:149440 (145.9 Kb)

Por lo que se solo es wlan0 cuando es un usb wifi, el tener la tarjeta wifi integrada me la pone en eth0
« Última modificación: 16 Febrero 2014, 00:30 am por Ormuzd » En línea

noopynoob

Desconectado Desconectado

Mensajes: 104



Ver Perfil
Re: Error al usar Reaver para pin WPS: [!] WARNING: Failed to associate with ...
« Respuesta #9 en: 16 Febrero 2014, 00:31 am »

El codifo del airmon lo tienes justo antes de tu post.
Sobre el reaver-1.3 lo pruebo ahora que tengo q entrar en modo monitor y pierdo internet (editare este post con el resultado)


precisamente, es que da error pero al final dice que ya esta en modo monitor:

Citar
(monitor mode enabled on mon0)

por eso queria que lo intentaras a ver.
En línea

Páginas: [1] 2 Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Error al usar reaver
Hacking Wireless
magp_90 4 44,996 Último mensaje 28 Agosto 2012, 01:39 am
por P4nd3m0n1um
ayuda WARNING: Failed to associate with
Hacking Wireless
javiabad18 1 4,039 Último mensaje 21 Mayo 2013, 17:12 pm
por Sh4k4
Ayuda con error LINKER WARNING
Programación C/C++
Renzo21 7 2,131 Último mensaje 7 Febrero 2014, 02:11 am
por Yoel Alejandro
Reaver: Failed to asociate with ¨bssid¨ (ESSID: ¨fulanito¨)
Wireless en Linux
Mariachi01 1 1,519 Último mensaje 28 Julio 2016, 07:48 am
por Sh4k4
Problema con reaver: WPS transaction failed (code: 0x02), re-trying last pin
Wireless en Linux
ysa_bell 0 554 Último mensaje 23 Octubre 2019, 13:58 pm
por ysa_bell
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines