elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Tutorial básico de Quickjs


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  Windows (Moderador: Randomize)
| | |-+  [FIXED]Problema "Advanced installer El sistema no puede encontrar el archivo..."
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: [FIXED]Problema "Advanced installer El sistema no puede encontrar el archivo..."  (Leído 10,561 veces)
motocros_elche


Desconectado Desconectado

Mensajes: 897


Yona http://www.youtube.es/YonaTutorials


Ver Perfil WWW
[FIXED]Problema "Advanced installer El sistema no puede encontrar el archivo..."
« en: 24 Julio 2014, 01:47 am »

EDITO: SOLUCIONADO, aquí comento la solución, pero supongo que otros muchos tendrán este error y no será la misma solución, pero por si acaso la comparto.
http://foro.elhacker.net/windows/problema_advanced_installer_el_sistema_no_puede_encontrar_el_archivo-t418877.0.html;msg1956446#msg1956446

Hola a todos.

Tengo Windows Server 2008 instalado en mi servidor dedicado y reinicie hace poco el servidor ya que hacia unas semanas que no lo reiniciaba y al iniciar me he encontrado con este error:
"Advanced installer El sistema no puede encontrar el archivo especificado"


He probado a instalar Advanced installer, ha desinstalar las aplicaciones instaladas en los ultimo dias (unas 3 como maximo aun que como programa uno) y el error persiste.

Llevo ya un día buscando tanto en español como en ingles sobre este error y no parece haber ni una sola solución, ni si quiera por parte del equipo de Advanced installer.



Creo que este problema proviene de este programa: http://ashersoftware.com/seDirector/download/
Se llama seDirector y su función es la de administrar servidores por ejemplo de juegos y en caso de que el servidor se cierre por algún error lo reabre.


He desinstalado el programa pero el error persiste como ya he dicho.

Sospecho de este programa por que tiene una opción de que se inicie automáticamente al iniciar Windows y en el reinicio apareció el error y el programa no se iniciaba automáticamente.

(He probado a editar msconfig y no hay manera, sigue apareciendo ese error, incluso he instalado un antivirus y he escaneado por si acaso y parece estar todo bien).

Me gustaría reparar el error si es posible en vez de un simple "eliminar el mensaje".


Cualquier ayuda será bienvenida, gracias de antemano, saludos.


« Última modificación: 24 Julio 2014, 03:18 am por motocros_elche » En línea

Eleкtro
Ex-Staff
*
Desconectado Desconectado

Mensajes: 9.705



Ver Perfil
Re: Problema "Advanced installer El sistema no puede encontrar el archivo..."
« Respuesta #1 en: 24 Julio 2014, 02:37 am »

¿Este es el tal Advanced Installer del que hablas?:
· http://www.advancedinstaller.com/main-screen-shot.html
No se, podrías haberlo aclarado.



Me gustaría reparar el error si es posible en vez de un simple "eliminar el mensaje".[/b]

Supongo que si dices eso es porque conoces el programa que está causando el error y lo sueles usar así que prefieres conservarlo, deacuerdo.

Es dificil (por no decir imposible) intentar adivinar desde este lado que archivo está requiriendo dicho programa en tu PC, pero puedes intentar averiguarlo tú manualmente:

1. Comprobar la linea de comandos que inició el programa.
    Cuando te aparezca el mensaje de error, y antes de cerrarlo, escribe este comando en la consola:
Código:
wmic.exe process where name="nombre del proceso.exe" get commandline
   Con suerte quizás te aparezca la ruta hacia un archivo ...¿inexistente?.

2. Monitorizar las acciones del proceso con Process Monitor:
· http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
    Primero debes ejecutar el procmon (obvio) y luego el advanced installer, pero antes te sugiero que te configures algunos filtros básicos en el procmon, porque de lo contrario se te llenará de información inutil y será un tremendo lio para buscar conflictos.

Aparte de eso, para eliminar completamente el mensaje (sin solucionar la causa del problema) además de verificar que no existan entradas de registro asociadas con ese programa, también debes comprobar que no existen Servicios de terceros instalados por ese programa, y en caso de existir los deshabilitas para que no se inicie con windows. Y también debes abrir el programador de tareas de windows (el task scheduler) para verificar que no hayan tareas creadas que estén iniciando ese proceso al inicio de sesión.
...¡busca bien!, aunque de todas formas yo te sugiero la herramienta Anvir Task Manager para administrar los procesos y servicios que se ejecuten al inicio de sesión.


Saludos.


« Última modificación: 24 Julio 2014, 02:44 am por Eleкtro » En línea


motocros_elche


Desconectado Desconectado

Mensajes: 897


Yona http://www.youtube.es/YonaTutorials


Ver Perfil WWW
Re: Problema "Advanced installer El sistema no puede encontrar el archivo..."
« Respuesta #2 en: 24 Julio 2014, 02:44 am »

¿Este es el tal Advanced Installer del que hablas?:
· http://www.advancedinstaller.com/main-screen-shot.html
No se, podrías haberlo aclarado.



Supongo que si dices eso es porque conoces el programa que está causando el error y lo sueles usar así que prefieres conservarlo, deacuerdo.

Es dificil (por no decir imposible) intentar adivinar desde este lado que archivo está requiriendo dicho programa en tu PC, pero puedes intentar averiguarlo tú manualmente:

1. Comprobar la linea de comandos que inició el programa.
    Cuando te aparezca el mensaje de error, y antes de cerrarlo, escribe este comando en la consola:
Código:
wmic.exe process where name="nombre del proceso.exe" get commandline
   Con suerte quizás te aparezca la ruta hacia un archivo ...¿inexistente?.

2. Monitorizar las acciones del proceso con Process Monitor:
· http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
    Primero debes ejecutar el procmon (obvio) y luego el advanced installer, pero antes te sugiero que te configures algunos filtros básicos en el procmon, porque de lo contrario se te llenará de información inutil y será un tremendo lio para buscar conflictos.

Aparte de eso, para eliminar completamente el mensaje (sin solucionar la causa del problema) además de verificar que no existan entradas de registro asociadas con ese programa, también debes comprobar que no existen Servicios de terceros instalados por ese programa, y en caso de existir los deshabilitas para que no se inicie con windows. solo se puede estar iniciando por una clave de registro o por un servicio, no tiene perdida... ¡busca bien!, aunque de todas formas yo te sugiero la herramienta Anvir Task Manager para administrar los procesos y servicios que se ejecuten al inicio de sesión.


Saludos.
Si ese es el Advanced installer pero el programa que yo uso "seDirector" no instala el Advanced installer así que probé a instalarlo por mi mismo y el error continuaba, en mi Windows 7 no sucede ese problema por eso habia descartado que tuviera algo que ver con Advanced installer.

Pero el icono del Advanced installer y el seDirector es el mismo, supongo que seDirector habrá sido creado con Advanced installer.

Voy a probar lo que dices, gracias por la ayuda, saludos.


Añado: La respuesta al comando en la consola es "No hay instancias disponibles".

Lo otro que dices del process monitor no creo que me sirva ya que el problema no parece tener que ver con Advanced installer ya que no estaba ni si quiera instalado a la hora del error y al instalarlo no veo ninguna diferencia.

He mandado ticket de soporte a seDirector a ver si saben algo.

Pero parece ser que el problema esta relacionado con algo más que solo el seDirector ya que eliminándolo de msconfig tanto el servicio como el programa no se soluciona y teniendo o no el Advanced installer instalado tampoco hay diferencia el error continua.

Saludos.
« Última modificación: 24 Julio 2014, 02:53 am por motocros_elche » En línea

Eleкtro
Ex-Staff
*
Desconectado Desconectado

Mensajes: 9.705



Ver Perfil
Re: Problema "Advanced installer El sistema no puede encontrar el archivo..."
« Respuesta #3 en: 24 Julio 2014, 02:50 am »

OK, entiendo, pero has de ir descartando.

En el título del mensaje de Error pone el nombre de la aplicación "Advanced installer", no la del "seDirector";
pero de todas formas para asegurarte del proceso que relmente está lanzando ese mensaje, simplemente cuando aparezca el mensaje abre el administrador de tareas (taskmgr.exe) y examina cual de los dos procesos está activo si el sedirector o el advanced, en caso de estar los dos, mata el proceso del advanced y si el mensaje desaparece entonces ya sabes el proceso que está lanzando el error, y sino entonces haz lo mismo con el proceso del seDirector ese.

Saludos
En línea


motocros_elche


Desconectado Desconectado

Mensajes: 897


Yona http://www.youtube.es/YonaTutorials


Ver Perfil WWW
Re: Problema "Advanced installer El sistema no puede encontrar el archivo..."
« Respuesta #4 en: 24 Julio 2014, 02:54 am »

OK, entiendo, pero has de ir descartando.

En el título del mensaje de Error pone el nombre de la aplicación "Advanced installer", no la del "seDirector";
pero de todas formas para asegurarte del proceso que relmente está lanzando ese mensaje, simplemente cuando aparezca el mensaje abre el administrador de tareas (taskmgr.exe) y examina cual de los dos procesos está activo si el sedirector o el advanced, en caso de estar los dos, mata el proceso del advanced y si el mensaje desaparece entonces ya sabes el proceso que está lanzando el error, y sino entonces haz lo mismo con el proceso del seDirector ese.

Saludos
Claro, el titulo es así por el mensaje que aparece, pues voy a probar con el administrador de tareas como dices y comento, gracias de nuevo, saludos.
En línea

motocros_elche


Desconectado Desconectado

Mensajes: 897


Yona http://www.youtube.es/YonaTutorials


Ver Perfil WWW
Re: Problema "Advanced installer El sistema no puede encontrar el archivo..."
« Respuesta #5 en: 24 Julio 2014, 03:02 am »

Vale, parece ser que aun que yo desde el propio programa seleccione que no se inicie automaticamente al iniciar windows y que lo desmarque de msconfig y que incluso lo desinstale, sigue intentando ejecutarse al inicio.

Tal vez es por otras instalaciones que hice en diferentes rutas (ya desinstaladas).

Pongo la foto:

Ese es el proceso del mensaje que aparece, ya que donde aparecen las aplicaciones en uso hago click derecho sobre la de Advanced installer y clicko sobre "ir al proceso" y me muestra ese proceso.

Supongo que el arreglo es eliminarlo del registro pero no tengo ni idea ya que he tocado pocas veces los registros.

Lo que no sé es si después de eliminar ese proceso del registro al reinstalar el programa se repetirá el problema, probaré esta vez primero sin activar el inicio automático.

Gracias por la ayuda, ya hemos avanzado bastante, saludos.
« Última modificación: 24 Julio 2014, 03:06 am por motocros_elche » En línea

motocros_elche


Desconectado Desconectado

Mensajes: 897


Yona http://www.youtube.es/YonaTutorials


Ver Perfil WWW
Re: Problema "Advanced installer El sistema no puede encontrar el archivo..."
« Respuesta #6 en: 24 Julio 2014, 03:17 am »

Problema solucionado

Al parecer era el archivo instalador guardado en la carpeta descargas, simplemente lo he eliminado y problema resuelto, ya no aparece ese molesto mensaje.

Muchas gracias a Eleкtro por la gran ayuda.

Con el administrador de tareas he visto donde estaba el archivo del proceso y ya esta, aún que me parece algo muy extraño, es la primera vez que veo algo así.

Supongo que el instalador modificaba algunos archivos de Windows, como cuando otros instaladores requieren reiniciar el equipo y luego continuan con la instalación.

Saludos y de verdad muchas gracias por la ayuda... por mas que buscaba sobre este error no había manera jaja.
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problema: "No se puede encontrar AOK"
Juegos y Consolas
Ch3ck 4 2,362 Último mensaje 8 Diciembre 2008, 20:07 pm
por Ch3ck
El producto "hombre" ahora se puede encontrar en Internet
Noticias
wolfbcn 0 1,564 Último mensaje 8 Mayo 2010, 22:31 pm
por wolfbcn
problema con "fixed channel"
Hacking Wireless
faustinpower 7 7,450 Último mensaje 9 Noviembre 2010, 10:29 am
por aabilio
Sistema>>Administracion>> ""No me aparece "Servicios""""
GNU/Linux
yoyoalee 4 8,924 Último mensaje 13 Febrero 2011, 18:34 pm
por leogtz
Camtasia Studio: Windows no puede encontrar el archivo "Studio.exe" - Solución
Software
MineHitex 0 1,763 Último mensaje 23 Agosto 2013, 18:49 pm
por MineHitex
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines