elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Security Series.XSS. [Cross Site Scripting]


+  Foro de elhacker.net
|-+  Informática
| |-+  Software
| | |-+  Rango de hojas excel
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Rango de hojas excel  (Leído 2,351 veces)
1mpuls0


Desconectado Desconectado

Mensajes: 1.186


Ver Perfil
Rango de hojas excel
« en: 20 Abril 2011, 00:41 am »

Hola qué tal.

No creo que sea el lugar correcto para colocar este post, lo mas cercano que se me ocurre es en software.
Así que si es mas correcto dejarlo ahí un moderador por favor muevalo.

Estoy realizando estadísticas de empleados de grandes empresas cada empleado cuenta con id, nombre, telefono y estatus.
Los estatus pueden ser Cita, No Esta, No Labora, No Interesa, Ninguno, No Registrado, etc.
Debo de realizar una grafica por cada empresa de acuerdo a los estatus.
Para contabilizar los estatus realizo la siguiente función =CONTAR.SI(D2:D116,"Cita")

EstatusCantidad
Cita=CONTAR.SI(D2:D116,"Cita")
No Esta=CONTAR.SI(D2:D116,"No Esta")

Y asi para los demás estatus.

Mi duda es si existe alguna funcion en la que pueda guardar el rango en la celda F2: =Rango(D2:D116)

Para que después pueda tener la información de esta manera.

EstatusCantidad
Cita=CONTAR.SI(=F2,"Cita")
No Esta=CONTAR.SI(=F2,"No Esta")

Y solamente modificar el valor del rango de la celda F2 ya que para las diferentes empresas son diferentes rangos.

Saludos.



En línea

abc
Novlucker
Ninja y
Colaborador
***
Desconectado Desconectado

Mensajes: 10.683

Yo que tu lo pienso dos veces


Ver Perfil
Re: Rango de hojas excel
« Respuesta #1 en: 20 Abril 2011, 13:42 pm »

Para empezar, decir que esa manera de hacer las cosas es bastante fea, para eso se crearon las tablas dinámicas :-X

Ahora respondiendo a tu pregunta, puedes utilizar la función INDIRECTO
En F2 pones D2:D116, y en las fórmulas sustituyes por algo así =CONTAR.SI(INDIRECTO(F2),"Cita")

Saludos


En línea

Contribuye con la limpieza del foro, reporta los "casos perdidos" a un MOD XD
"Hay dos cosas infinitas: el Universo y la estupidez  humana. Y de la primera no estoy muy seguro."
Albert Einstein
1mpuls0


Desconectado Desconectado

Mensajes: 1.186


Ver Perfil
Re: Rango de hojas excel
« Respuesta #2 en: 21 Abril 2011, 00:32 am »

Para empezar, decir que esa manera de hacer las cosas es bastante fea, para eso se crearon las tablas dinámicas :-X

Ahora respondiendo a tu pregunta, puedes utilizar la función INDIRECTO
En F2 pones D2:D116, y en las fórmulas sustituyes por algo así =CONTAR.SI(INDIRECTO(F2),"Cita")

Saludos


Gracias por responder.

La verdad a mi tampoco me gusta la idea de hacerlo así, pero tengo un problema con la tabla dinámica.
Se que en muchas ocasiones es muy util la tabla dinámica, pero este no parece ser el caso.

Existen empresas en donde no tiene algun estatus, entonces el valor de ese estatus queda en blanco en la tabla dinámica, ya que solo contabiliza los estatus que existen.
Todas las empresas deben contener los estatus "Cita","ING","Ninguno","No Esta","No Interesa","No Labora","No Registrado","Otros","Si Esta"
Si en la empresa PFIZER solo existen los estatus "No Esta" y "No Labora" entonces los demas estatus en la tabla dinámica quedarian en blanco y al graficar no mostraría los demas estatus.
Algo curioso es que debo de mostrar en la grafica todos la cantidad de los estatus aun cuando su valor sea "cero"

¿Alguna forma de arreglarlo?


Gracias.

En línea

abc
Novlucker
Ninja y
Colaborador
***
Desconectado Desconectado

Mensajes: 10.683

Yo que tu lo pienso dos veces


Ver Perfil
Re: Rango de hojas excel
« Respuesta #3 en: 21 Abril 2011, 04:38 am »

Eso último creo que no se puede :-\
Lo que si podrías hacer es intentar algo como esto, de modo de no tener que cambiar el rango de celdas sino el nombre de la empresa :D
http://jldexcelsp.blogspot.com/2006/02/sumar-y-contar-con-varias-condiciones.html
Y el nombre lo pones en un desplegable :D

Saludos
En línea

Contribuye con la limpieza del foro, reporta los "casos perdidos" a un MOD XD
"Hay dos cosas infinitas: el Universo y la estupidez  humana. Y de la primera no estoy muy seguro."
Albert Einstein
1mpuls0


Desconectado Desconectado

Mensajes: 1.186


Ver Perfil
Re: Rango de hojas excel
« Respuesta #4 en: 23 Abril 2011, 05:32 am »

Gracias Novlucker pero prefiero harcelo a mi modo, ya que son al rededor de 70 empresas y 10 estatus por cada asesor.

 ;)
En línea

abc
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines