elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Trabajando con las ramas de git (tercera parte)


+  Foro de elhacker.net
|-+  Programación
| |-+  Scripting
| | |-+  Problema con Atributo %0
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema con Atributo %0  (Leído 1,580 veces)
NoryNR

Desconectado Desconectado

Mensajes: 18


Ver Perfil
Problema con Atributo %0
« en: 18 Febrero 2008, 09:11 am »

este codigo sirve para que el batch se encuentre a si mismo... ya que no sabes cual es

C:\Documents and Settings\nosabesquenombredesesiontienelagente entonces de esta manera se autoencuentra y se mueve a cualquier carpeta o se copia.. lo que le digas...

una vez lo use y me fue.. pero ahora no consigo hacerlo funcionar...

copy /y %0 c:\WINDOWS\system32\nombre.bat

Me dice que la sintaxis no es correcta.

yo lo intente con move tambien

move /y %0 c:\WINDOWS\system32\


Alguna sugerencia? Gracias



En línea

~[uNd3rc0d3]~

Desconectado Desconectado

Mensajes: 188


programando...


Ver Perfil
Re: Problema con Atributo %0
« Respuesta #1 en: 18 Febrero 2008, 15:35 pm »

a mi me lo copia lo mas bien.....

si a vos no te lo copia algo que podes hacer es pasar el %0 a un txt....extraerlo con un for y probar con una variable comun a ver que pasa

%0 > ruta.txt
for /f "tokens= delims= " %%a in ('ruta.txt') do (set ruta=%%a)
del ruta.txt
copy %ruta%

algo asi para que te des una idea tenes que modificar un poco ese code lo hice re apurado

nos vemos


En línea


leete las reglas asi todos estamos mejor ;)
NoryNR

Desconectado Desconectado

Mensajes: 18


Ver Perfil
Re: Problema con Atributo %0
« Respuesta #2 en: 18 Febrero 2008, 17:01 pm »

RESUELTO!



Fallo mio! xD me daba un pequeño error porque habia espacios en la carpeta donde lo queria copiar \Documents and Settings\...
« Última modificación: 18 Febrero 2008, 17:02 pm por NoryNR » En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
[MySQL] Dividir atributo en dos
Bases de Datos
Kasswed 4 6,228 Último mensaje 10 Mayo 2011, 00:44 am
por Kasswed
(solucionado) Que es el atributo "A"? (Atributo de archivo de almacenamiento.)
Windows
Eleкtro 2 22,163 Último mensaje 31 Enero 2012, 01:00 am
por Eleкtro
[PREGUNTA] Para que sirve el atributo 'name' de los Form's?
Desarrollo Web
Zodiak98 3 1,739 Último mensaje 9 Junio 2013, 23:54 pm
por Shout
Problema con atributo z-index
Programación General
Arm144 0 1,118 Último mensaje 22 Mayo 2017, 21:11 pm
por Arm144
Array atributo de una clase de tamaño igual a otro atributo
Programación C/C++
cNoob 3 1,510 Último mensaje 1 Enero 2018, 21:02 pm
por cNoob
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines