elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Entrar al Canal Oficial Telegram de elhacker.net


+  Foro de elhacker.net
|-+  Programación
| |-+  Scripting
| | |-+  Ayuda en pseint!!
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Ayuda en pseint!!  (Leído 3,023 veces)
stR_ruBen

Desconectado Desconectado

Mensajes: 10


Ver Perfil
Ayuda en pseint!!
« en: 8 Febrero 2017, 20:53 pm »

--------------------------------------------------------------------------------------------
                                             ES CON SUBPROCESOS
--------------------------------------------------------------------------------------------

Hola, tengo un problema con este ejercicio de peseint, es una matriz unidimensional de 12 posiciones rellena con datos aleatorios entre 25 i 255. (simulando accidentes mensuales)

- Tengo que hacer la media de accidentes en todo el año.
- Que devuelva el numero de meses que ha habido mas accidentes que la media.
- Que devuelva el numero de meses que ha habido menos accidentes que la media.
- Numero que se ha producido menos de 50 accidentes.
- Numero que se ha producido menos de 125 accidentes.

Me dan estos errores:
Lin 16 (inst 1): ERROR 303: Subindice () fuera de rango (1...12)

Lin 80 (inst 1): ...dentro del subproceso SUP_MITJA, invocado desde aquí.





Código
  1. Subproceso mitja(accidentes)
  2. contador_mitja=1
  3. mitjana=0
  4. Repetir
  5. mitjana=mitjana+accidentes[contador_mitja]
  6. contador_mitja=contador_mitja+1
  7. Hasta Que contador_mitja = 13
  8. escribir mitjana/12
  9. FinSubProceso
  10.  
  11.  
  12. SubProceso sup_mitja(accidentes)
  13. contador_sup_mitja=1
  14. sup_mitjana=0
  15. Repetir
  16. si accidentes[contador_mitja]>mitjana
  17. Escribir "El mes número "+convertirATexto(accidentes[contador_mitja])+" ha tenido una cantidad de accidentes superior a la media."
  18. FinSi
  19. contador_sup_mitja= contador_sup_mitja+1
  20. Hasta Que contador_sup_mitja = 13
  21. FinSubProceso
  22.  
  23.  
  24. subproceso sub_mitja(accidentes)
  25. contador_sub_mitja=1
  26. sub_mitjana=0
  27. Repetir
  28. si accidentes[contador_mitja]<mitjana
  29. Escribir "El mes número "+convertirATexto(accidentes[contador_mitja])+" ha tenido una cantidad de accidentes inferior a la media."
  30. FinSi
  31. contador_sub_mitja= contador_sub_mitja+1
  32. Hasta Que contador_sub_mitja = 13
  33. FinSubProceso
  34.  
  35.  
  36. SubProceso funcion_sub_50(accidentes)
  37. contador_sub_50=1
  38. sub_50 = 0
  39. Repetir
  40. si accidentes[contador_mitja]<50
  41. Escribir "El mes número "+convertirATexto(accidentes[contador_mitja])+" ha tenido una cantidad de accidentes inferior a 50."
  42. FinSi
  43. contador_sub_50= contador_sub_50+1
  44. Hasta Que contador_sub_50 = 13
  45. FinSubProceso
  46.  
  47.  
  48. SubProceso funcion_sup_125(accidentes)
  49. contador_sup_125=1
  50. sup_125=0
  51. Repetir
  52. si accidentes[contador_mitja]>125
  53. Escribir "El mes número "+convertirATexto(accidentes[contador_mitja])+" ha tenido una cantidad de accidentes superior a 125."
  54. FinSi
  55. contador_sup_125= contador_sup_125+1
  56. Hasta Que contador_sup_125 = 13
  57. FinSubProceso
  58.  
  59. Proceso ejercicio_2
  60. contador=1
  61. Dimension accidentes[12]
  62. //V2 - Introduccion de los accidentes de manera automática
  63.  
  64. Repetir
  65. accidentes[contador]<-azar(130)+25
  66. contador=contador+1
  67. Hasta Que contador=13
  68.  
  69. mitja(accidentes)
  70. sup_mitja(accidentes)
  71. sub_mitja(accidentes)
  72. funcion_sub_50(accidentes)
  73. funcion_sup_125(accidentes)
  74.  
  75. FinProceso


En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Pseint, Ayuda :C
Programación General
Caroline.z3 1 4,519 Último mensaje 18 Diciembre 2010, 03:43 am
por Littlehorse
deseo tener ayuda con pseint
Programación General
fuck_yeah!! 0 1,086 Último mensaje 15 Junio 2012, 21:25 pm
por fuck_yeah!!
pequeña ayuda plz(pseint)
Programación General
Fire.Soul 0 1,137 Último mensaje 17 Mayo 2013, 22:28 pm
por Fire.Soul
[pseint] Ayuda - Cifrado César
Programación General
shadowzgz 4 7,692 Último mensaje 24 Diciembre 2014, 01:32 am
por Eleкtro
Ayuda Pseint algoritmo
Programación General
dariend13 0 1,610 Último mensaje 11 Junio 2017, 01:28 am
por dariend13
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines