elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Introducción a la Factorización De Semiprimos (RSA)


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación C/C++ (Moderadores: Eternal Idol, Littlehorse, K-YreX)
| | |-+  problemas al "daemonizar" un proceso en linux
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: problemas al "daemonizar" un proceso en linux  (Leído 2,399 veces)
dakomt

Desconectado Desconectado

Mensajes: 76


Viking Metal


Ver Perfil
problemas al "daemonizar" un proceso en linux
« en: 9 Junio 2010, 01:19 am »

Hola! Os comento.. tengo un programa en C que se encarga de lanzar una serie de procesos (mediante fork - exec) y si alguno acaba "malamente"
Código:
!WEXITSTATUS(status)
lo vuelve a lanzar.

Hasta aquí bien... He intentado "daemonizar" el programa siguiendo este howto:

http://www-theorie.physik.unizh.ch/~dpotter/howto/daemonize

Y el problema que tengo ahora es que no lanza los procesos...

Indagando por Internet me he topado con este otro post :

http://www.cplusplus.com/forum/unices/20869/

y entiendo que tengo el mismo problema...

pero no consigo solucionarlo

¿por casualidad alguno de vosotros ha tenido alguna vez el mismo problema?



En línea

nicolas_cof


Desconectado Desconectado

Mensajes: 348


Into the Wild


Ver Perfil WWW
Re: problemas al "daemonizar" un proceso en linux
« Respuesta #1 en: 9 Junio 2010, 02:02 am »

Fijate en el siguiente link, de seguro te puede servir...

http://www.advancedlinuxprogramming.com/alp-folder

Salu10.


En línea

dakomt

Desconectado Desconectado

Mensajes: 76


Viking Metal


Ver Perfil
Re: problemas al "daemonizar" un proceso en linux
« Respuesta #2 en: 9 Junio 2010, 02:26 am »

Tengo ese libro y ya le estuve echando un vistazo  :xD pero sigo sin ver la luz.

gracias de todos modos
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problemas con el proceso browserprotect.exe!!!!
Windows
01munrra 6 3,602 Último mensaje 7 Abril 2013, 14:11 pm
por 01munrra
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines