elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Guía actualizada para evitar que un ransomware ataque tu empresa


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web
| | |-+  PHP (Moderador: #!drvy)
| | | |-+  Uso IE y esta instrucción $_SERVER[HTTP_USER_AGENT dice que uso Mozila
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Uso IE y esta instrucción $_SERVER[HTTP_USER_AGENT dice que uso Mozila  (Leído 3,475 veces)
SpiderNet

Desconectado Desconectado

Mensajes: 149


No abuses de tus conocimientos


Ver Perfil WWW
Uso IE y esta instrucción $_SERVER[HTTP_USER_AGENT dice que uso Mozila
« en: 21 Septiembre 2008, 01:05 am »

Estoy usando el navegador Internet Explorer 7.0 y al mostrar el contenido de la variable $_SERVER[HTTP_USER_AGENT  me muestra lo siguiente

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; uE v7; uE v7)

el codigo es este
Código:
$client=addslashes($_SERVER[HTTP_USER_AGENT]);
echo"$client <br>";

Tengo instalado el mozila pero casi nunca lo uso.

Que podría estar pasando???


Saludos!!!


En línea

Quieres un foro solo para principiantes
Visita  http://spidernet.forumotion.com

El miedo es libre, puedes sentirlo....
дٳŦ٭
GNU/Linux Infrastructure Specialist
Colaborador
***
Desconectado Desconectado

Mensajes: 5.110


Ver Perfil WWW
Re: Uso IE y esta instrucción $_SERVER[HTTP_USER_AGENT dice que uso Mozila
« Respuesta #1 en: 21 Septiembre 2008, 06:13 am »

Pues para eso es la variable....


En línea



Con sangre andaluza :)

Rentero
Ex-Staff
*
Desconectado Desconectado

Mensajes: 1.164


La paciencia es la madre de la ciencia.


Ver Perfil
Re: Uso IE y esta instrucción $_SERVER[HTTP_USER_AGENT dice que uso Mozila
« Respuesta #2 en: 21 Septiembre 2008, 14:00 pm »

http://uninstallme.com/por-que-internet-explorer-se-identifica-como-mozilla/
En línea

Firmado.
WHK
CoAdmin
***
Desconectado Desconectado

Mensajes: 6.589


Sin conocimiento no hay espíritu


Ver Perfil WWW
Re: Uso IE y esta instrucción $_SERVER[HTTP_USER_AGENT dice que uso Mozila
« Respuesta #3 en: 28 Septiembre 2008, 21:23 pm »

Ni se te ocurra procesar $client en una query hacia la base de datos sin antes filtrarlo ya que agregando slashses no solucionas una inyección sql ni un xss.
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Duda Redes wep Wlan_00 ,Lo que dice esta web tiene logica?
Hacking Wireless
Anonymous250 3 2,392 Último mensaje 3 Noviembre 2011, 14:49 pm
por Anonymous250
Por que esta instrucción no es válida?
ASM
.:UND3R:. 4 2,505 Último mensaje 21 Noviembre 2011, 04:18 am
por .:UND3R:.
Por que esta instrucción (FPU) genera una excepción.
ASM
.:UND3R:. 5 2,563 Último mensaje 25 Julio 2012, 04:20 am
por _Enko
¿Has perdido tu móvil Android? Esta web te dice dónde está y te ayuda a ...
Noticias
wolfbcn 0 835 Último mensaje 16 Abril 2016, 02:42 am
por wolfbcn
Duda sobre $_SERVER['DOCUMENT_ROOT']; y paths absolutos
Desarrollo Web
Schaiden 0 1,133 Último mensaje 12 Octubre 2017, 08:07 am
por Schaiden
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines