elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Como proteger una cartera - billetera de Bitcoin


+  Foro de elhacker.net
|-+  Informática
| |-+  Hardware (Moderador: Aprendiz-Oscuro)
| | |-+  Bot mas rápido con tarjeta VGA que con tarjeta gráfica dedicada
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Bot mas rápido con tarjeta VGA que con tarjeta gráfica dedicada  (Leído 971 veces)
esmertil

Desconectado Desconectado

Mensajes: 1


Ver Perfil
Bot mas rápido con tarjeta VGA que con tarjeta gráfica dedicada
« en: 9 Noviembre 2017, 15:28 pm »

Tengo un bot para un juego creado con Autoit y este programa hace multiples llamadas con la funcion PixelGetColor ( descifrar el color de los pixeles en pantalla ). Mi PC es un AMD A-10 con grafica integrada y lo curioso es lo siguiente:
- Si instalo los driver de la grafica integrada el Bot va muy lento y si desinstalo estos drivers y por tanto lo que me detecta el PC es la Tarjeta grafica VGA estandar, el bot va muy rapido.
Hasta este punto podreis pensar que si esa es la solucion porque preguntar y tocar nada, pero claro el dilema se da en lo siguiente:
- Con la Tarjeta grafica VGA estandar utilizo la resolucion maxima 1920 x 1080 y hasta ahí no hay problemas porque no hace falta instalar drivers, pero si quiero utilizar el bot en un monitor 4k ( 3840 x 2160 ), necesito instalar los drivers de la tarjeta grafica y por tanto el bot comienza a funcionar lento.

Lo mas curioso es que pensé que la solucion a este problema era instalar una tajeta grafica dedicada pensando que tal vez iba a dejar mas recursos al CPU ( al no tirar de la GPU integrada ) y por tanto se solucionaria el problema de la velocidad del Bot. Pues bien, decido comprar una grafica dedicada y  cuando hice la primera instalacion de los drivers de esta tarjeta grafica dedicada y designé en la BIOS que utilizara la salida de la grafica dedicada, en la primera prueba el bot fue super rapido, pero al reiniciar  el sistema el Bot comenzó a ir lento nuevamente. Despues he intentado instalar y desisntalar todo como al principio pero no hay manera , el Bot sigue yendo muy lento cuando quiero que funcione en 4k.
Yo intuyo que al instalar los driver debe de haber un cambio en alguna configuracion de los graficos que altere la velocidad de esa funcion PixelGetColor.
Haber si a alguno se le ha dado este problema y sabe cual es la solucion. Muchas gracias de antemano.


En línea

bettu


Desconectado Desconectado

Mensajes: 749


Ver Perfil
Re: Bot mas rápido con tarjeta VGA que con tarjeta gráfica dedicada
« Respuesta #1 en: 9 Noviembre 2017, 20:03 pm »

Hola,

Creo que no hiciste lo más importante, probar ese bot con los drivers de la gráfica instalados pero probándolo a 1920x1080. Ten en cuenta que 4k es una resolucion muy muy grande.


Saludos,


En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
audio integrado o tarjeta dedicada de sonido
Hardware
Vjuan_ 3 2,420 Último mensaje 25 Diciembre 2012, 02:32 am
por imoen
Problemón con T.Gráfica y ¿Recomendación de nueva tarjeta gráfica? « 1 2 3 4 »
Hardware
Eleкtro 31 20,038 Último mensaje 27 Febrero 2013, 21:54 pm
por simorg
Problema con la tarjeta gráfica dedicada de un portátil
Hardware
alberars 2 2,229 Último mensaje 13 Diciembre 2014, 01:07 am
por alberars
Problema con tarjeta de video dedicada en Toshiba C55D-b5206
Windows
jorgeeo_O 3 1,275 Último mensaje 12 Enero 2016, 11:58 am
por marmolito
Cómo usar tarjeta gráfica dedicada (GPU) e integrados (iGPU) al mismo tiempo
Noticias
wolfbcn 0 775 Último mensaje 11 Abril 2017, 02:50 am
por wolfbcn
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines