elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Arreglado, de nuevo, el registro del warzone (wargame) de EHN


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  [Wireless] Realtek no me permite inyectar paquetes
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: [Wireless] Realtek no me permite inyectar paquetes  (Leído 1,014 veces)
Diabliyo


Desconectado Desconectado

Mensajes: 1.441


shell# _


Ver Perfil WWW
[Wireless] Realtek no me permite inyectar paquetes
« en: 23 Febrero 2012, 21:59 pm »

Buenas...

Tengo una lap con chipset inalámbrico Realtek, carga el modulo r8192ce_pci, es reconocida como wlan0:

# lspci -vv
Código:
Network controller: Realtek Semiconductor Co., Ltd. Device 8176 (rev 01)
Subsystem: Hewlett-Packard Company Device 1629
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 17
Region 0: I/O ports at 3000 [size=256]
Region 2: Memory at f0200000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Address: 0000000000000000  Data: 0000
Capabilities: [70] Express (v2) Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
MaxPayload 128 bytes, MaxReadReq 512 bytes
DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
ClockPM+ Suprise- LLActRep- BwNot-
LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
Capabilities: [100] Advanced Error Reporting <?>
Capabilities: [140] Virtual Channel <?>
Capabilities: [160] Device Serial Number xx-xx-xx-xx-xx-xx-xx-xx
Kernel driver in use: rtl8192CE
Kernel modules: r8192ce_pci

Cuando pongo la inalámbrica en modo Monior, ya sea manualmente o con airmon-ng start wlan0 y despues invocar la captura con airodump-ng simplemente no consigo Paquetes #DATA, ademas tras ejecutar algun ataque con aireplay-ng (con -3 -1) no me inyecta los paquetes :(.

Y ya comprobé que no sea problema de que los APs se esten protegiendo o no respondan, porque si conecto una USB Wireless con chipset atheros, rápidamente puedo ver como la inyección en repetición arp's (ataque -3), empieza a generar paquetes inyectados y los #DATA incrementan rápidamente.

Otro detalle es que el airmon-ng no me crea la interface mon0.

Saludos !



En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problema con mi Wifi de Realtek y Captura de paquetes
Hacking Wireless
jonpeter46 0 2,536 Último mensaje 17 Diciembre 2010, 09:57 am
por jonpeter46
inyectar paquetes en 54e
Hacking Wireless
pakias 2 1,674 Último mensaje 29 Septiembre 2011, 03:41 am
por pakias
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines