elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Guía rápida para descarga de herramientas gratuitas de seguridad y desinfección


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Problema de conexion de red Wifi
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema de conexion de red Wifi  (Leído 2,559 veces)
Agusax

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Problema de conexion de red Wifi
« en: 26 Noviembre 2014, 09:54 am »

Hola a todos, primero ante todo presentarme como nuevo en el foro.
Soy algo principiante en esto de ubuntu y me ha surgido un problema que no consigo solucionar, es el siguiente:

Resulta que en mi casa puedo conectar a la red wifi sin problemas, al igual que a la red wifi del móvil, pero cuando llego a la universidad e intento conectarme, ya sea en la red pública (con autentificador web) como en la red privada en la cual tengo que descargar certificados, no se conecta.

Me trae un dolor de cabeza curioso, ya que hasta que toqué por error lo del hotspot del ubuntu no he podido conectarme a esas redes.

Muchas gracias de antemano y un saludo a todos :)


En línea

MinusFour
Moderador Global
***
Desconectado Desconectado

Mensajes: 5.510


I'm fourth.


Ver Perfil WWW
Re: Problema de conexion de red Wifi
« Respuesta #1 en: 26 Noviembre 2014, 16:37 pm »

Vas a tener que ser más especifico. ¿Que tipo de autentificación tienen en tu universidad?


En línea

Agusax

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Re: Problema de conexion de red Wifi
« Respuesta #2 en: 26 Noviembre 2014, 20:58 pm »

No sé como responder a eso, pero esto es lo que tenemos que incluir de certificados para acceder a la red WAN Enterprise

Nombre Certificado:   -----@alum.uca.es
Fichero Certificado (PKCS12):   ----@alum.uca.es.p12
Certificado Raiz CA:   cacert.der
Clave Acceso:   ------

El fichero y certificado son archivos que se descargan y se añade en la configuración de la red, pero aun así, en la otra red "pública" de mi universidad no me deja acceder, y ese es introducir solo la contraseña xD
En línea

Agusax

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Re:
« Respuesta #3 en: 2 Diciembre 2014, 20:28 pm »

Sigo sin encontrar una solución para este problema :/
En línea

MinusFour
Moderador Global
***
Desconectado Desconectado

Mensajes: 5.510


I'm fourth.


Ver Perfil WWW
Re:
« Respuesta #4 en: 2 Diciembre 2014, 21:19 pm »

Sigo sin encontrar una solución para este problema :/

Intenta conectarte y luego pon el resultado de:

Código
  1. dmesg | tail -n 20

Para las dos redes.
En línea

Agusax

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Re: Problema de conexion de red Wifi
« Respuesta #5 en: 2 Diciembre 2014, 21:59 pm »

Intenta conectarte y luego pon el resultado de:

Código
  1. dmesg | tail -n 20

Para las dos redes.

No me deja hacer la conexión, se queda conectando. Si es en ese momento, lo hago y mañana te reporto la solución cuando lo pruebe en la red.
En línea

MinusFour
Moderador Global
***
Desconectado Desconectado

Mensajes: 5.510


I'm fourth.


Ver Perfil WWW
Re: Problema de conexion de red Wifi
« Respuesta #6 en: 2 Diciembre 2014, 22:42 pm »

No me deja hacer la conexión, se queda conectando. Si es en ese momento, lo hago y mañana te reporto la solución cuando lo pruebe en la red.

Hay un bug en Ubuntu 14.04 (que me parece afecta hasta 13.04) con WPA sin certificados.
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1104476

Ya se emitio un fix (aunque hay gente diciendo que todavia no esta corregido). De todas formas, te recomiendo que hagas un update y upgrade.

Código
  1. sudo apt-get update && sudo apt-get upgrade

Tambien busca el archivo de configuracion de tu red:

Código
  1. ls -la /etc/NetworkManager/system-connections

Y copia y pega el contenido del archivo:
Código
  1. cd /etc/NetworkManager/system-connections
  2. cat nombreDelArchivoDeRed
En línea

Agusax

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Re: Problema de conexion de red Wifi
« Respuesta #7 en: 3 Diciembre 2014, 10:56 am »

Permiso denegado cuando intento agregar esas redes con el "cat"

Esto me ha soltado cuando hice el "dsmeg"
Código:
agusax@agusax-ubuntu:~$ dmesg | tail -n 20
[  128.358684] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  128.358688] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  160.661876] r8169 0000:02:00.0 eth0: link up
[  160.661890] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  184.178473] cfg80211: Calling CRDA for country: ES
[  184.185742] cfg80211: Regulatory domain changed to country: ES
[  184.185750] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  184.185755] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  184.185759] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  184.185763] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  184.185767] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
[  184.185770] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
[  229.384551] cfg80211: Calling CRDA to update world regulatory domain
[  229.393337] cfg80211: World regulatory domain updated:
[  229.393344] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  229.393346] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393349] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393352] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  229.393354] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393356] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Actualmente estoy conectado por cable.

Edito: Justo cuando intento conectar en la red wifi
Código:
agusax@agusax-ubuntu:/etc/NetworkManager/system-connections$ dmesg | tail -n 20
[  229.393337] cfg80211: World regulatory domain updated:
[  229.393344] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  229.393346] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393349] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393352] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  229.393354] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393356] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  298.140903] init: systemd-logind main process (811) killed by TERM signal
[  331.318922] type=1400 audit(1417600412.414:71): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=3043 comm="apparmor_parser"
[  331.318936] type=1400 audit(1417600412.414:72): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=3043 comm="apparmor_parser"
[  331.319621] type=1400 audit(1417600412.414:73): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=3043 comm="apparmor_parser"
[  448.503342] systemd-udevd[4726]: starting version 204
[  637.486721] cfg80211: Calling CRDA for country: ES
[  637.491753] cfg80211: Regulatory domain changed to country: ES
[  637.491759] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  637.491762] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  637.491765] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  637.491767] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  637.491770] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
[  637.491772] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
« Última modificación: 3 Diciembre 2014, 11:00 am por Agusax » En línea

MinusFour
Moderador Global
***
Desconectado Desconectado

Mensajes: 5.510


I'm fourth.


Ver Perfil WWW
Re: Problema de conexion de red Wifi
« Respuesta #8 en: 3 Diciembre 2014, 15:38 pm »

Permiso denegado cuando intento agregar esas redes con el "cat"

Esto me ha soltado cuando hice el "dsmeg"
Código:
agusax@agusax-ubuntu:~$ dmesg | tail -n 20
[  128.358684] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  128.358688] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  160.661876] r8169 0000:02:00.0 eth0: link up
[  160.661890] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  184.178473] cfg80211: Calling CRDA for country: ES
[  184.185742] cfg80211: Regulatory domain changed to country: ES
[  184.185750] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  184.185755] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  184.185759] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  184.185763] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  184.185767] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
[  184.185770] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
[  229.384551] cfg80211: Calling CRDA to update world regulatory domain
[  229.393337] cfg80211: World regulatory domain updated:
[  229.393344] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  229.393346] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393349] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393352] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  229.393354] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393356] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Actualmente estoy conectado por cable.

Edito: Justo cuando intento conectar en la red wifi
Código:
agusax@agusax-ubuntu:/etc/NetworkManager/system-connections$ dmesg | tail -n 20
[  229.393337] cfg80211: World regulatory domain updated:
[  229.393344] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  229.393346] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393349] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393352] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  229.393354] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  229.393356] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  298.140903] init: systemd-logind main process (811) killed by TERM signal
[  331.318922] type=1400 audit(1417600412.414:71): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=3043 comm="apparmor_parser"
[  331.318936] type=1400 audit(1417600412.414:72): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=3043 comm="apparmor_parser"
[  331.319621] type=1400 audit(1417600412.414:73): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=3043 comm="apparmor_parser"
[  448.503342] systemd-udevd[4726]: starting version 204
[  637.486721] cfg80211: Calling CRDA for country: ES
[  637.491753] cfg80211: Regulatory domain changed to country: ES
[  637.491759] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  637.491762] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  637.491765] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  637.491767] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  637.491770] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
[  637.491772] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)

No veo ningun intento de autentificacion, es extraño. Lo único que se me pudiera ocurrir es que tu wireless se está reajustando para las señales wireless de españa y el router de tu universidad no opere bajo esas frecuencias?

¿Si puedes ver los archivos con el ls, puedes moverte a la carpeta con cd? Hazlo todo como root. Remplaza "<< NombreDelArchivoDeRed >>" por el nombre del archivo.

Código
  1. sudo ls -la /etc/NetworkManager/system-connections
  2. sudo cat /etc/NetworkManager/system-connections/<<NombreDelArchivoDeRed >>

Tambien puedes intentar algo:

Código
  1. sudo iw reg set US

Antes de conectarte.
En línea

Agusax

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Re:
« Respuesta #9 en: 6 Diciembre 2014, 11:59 am »

Haciendo ajustes, he acabado reinstalando ubuntu, así que creo que se habrá solucionado.
Ya informaré el lunes, pero este problema ha sido un quebradero de cabeza.
Muchas gracias ^^
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problema con conexion wifi
Wireless en Windows
spawler 2 2,994 Último mensaje 7 Noviembre 2011, 23:39 pm
por тαптяα
Problema conexión via Wifi
Redes
Marquinhor 6 23,595 Último mensaje 4 Junio 2013, 19:52 pm
por Marquinhor
Problema Conexión Wifi (PS3)
Redes
daniHCF96 2 1,714 Último mensaje 18 Febrero 2014, 01:33 am
por young0320
Problema con conexión WiFi
Redes
Er_JaSoN_69 0 1,122 Último mensaje 16 Septiembre 2014, 15:03 pm
por Er_JaSoN_69
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines