elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Recuerda que debes registrarte en el foro para poder participar (preguntar y responder)


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Kali linux: pkgProblemResolver::Resolve generated breaks
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Kali linux: pkgProblemResolver::Resolve generated breaks  (Leído 1,821 veces)
assw1208

Desconectado Desconectado

Mensajes: 79



Ver Perfil
Kali linux: pkgProblemResolver::Resolve generated breaks
« en: 14 Abril 2022, 18:41 pm »

Hola al intentar instalar el  "smbclient" me sale el siguiente mensaje:

The following packages have unmet dependencies:
 python3-tornado : Breaks: mitmproxy (< 5.0~) but 4.0.4-6.1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

creo que tenga algo que ver con python por el mensaje que sale, pero no tengo mucha idea, no me deja instalar python3 (tengo Python 2.7.18), pero el mensaje es el mismo... Alguien me podría echar una mano?


En línea

"COURAGE TODAY,
                              VICTORY TOMORROW "

                            ----------------W--------------
.xAk.


Desconectado Desconectado

Mensajes: 393


F0r3v3R NeWbI3


Ver Perfil WWW
Re: Kali linux: pkgProblemResolver::Resolve generated breaks
« Respuesta #1 en: 14 Abril 2022, 19:36 pm »

Lo que te ocurre es que en tu sistema utilizas Python 2.7.18 por defecto. Python 3 también lo debes tener instalado. Prueba

Código:
$ python3 --version

Puedes establecerlo como predeterminado, mira las versiones de python que tienes instaladas con:

Código:
# update-alternatives --list python

puedes establecer directamente la versión que quieras o elegirla con:

Código:
# update-alternatives --config python



SaludOS


En línea


Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
[Ruby] Resolve IP 0.1
Scripting
BigBear 0 1,551 Último mensaje 10 Febrero 2012, 19:01 pm
por BigBear
problema al descargar linux headers en kali mate y la kali con escritorio gnome
GNU/Linux
hollow_yami 1 6,300 Último mensaje 7 Diciembre 2016, 21:20 pm
por Ancasu
resolve « 1 2 3 »
GNU/Linux
ᛃᛟᚱᛞᚨᚾ 20 7,918 Último mensaje 16 Junio 2019, 01:51 am
por @XSStringManolo
Lanzamiento de Kali Linux 2021.2 (Kaboxer, Kali-Tweaks, Bleeding-Edge &Privileged Ports)
GNU/Linux
Machacador 1 2,296 Último mensaje 2 Junio 2021, 20:18 pm
por BloodSharp
ayuda para iniciar bien Kali Linux- usuario novato en entornos linux
GNU/Linux
novato2850 1 3,024 Último mensaje 25 Julio 2021, 03:52 am
por BloodSharp
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines