elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Sigue las noticias más importantes de seguridad informática en el Twitter! de elhacker.NET


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Kali Linux: 404 Not Found cada vez que quiero instalar algo con apt-get
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Kali Linux: 404 Not Found cada vez que quiero instalar algo con apt-get  (Leído 3,868 veces)
Schaiden

Desconectado Desconectado

Mensajes: 97



Ver Perfil
Kali Linux: 404 Not Found cada vez que quiero instalar algo con apt-get
« en: 1 Noviembre 2015, 03:35 am »

Hola que tal gente! Estoy trabado desde hace unos días con éste problema, cada vez que intento instalar algo en Kali me salen errores 404. Les muestro por ejemplo el resultado de hacer apt-get update:

Citar
Ign http://http.kali.org kali Release.gpg
Ign http://security.kali.org kali/updates Release.gpg
Ign http://http.kali.org kali Release
Ign http://security.kali.org kali/updates Release.gpg
Ign http://security.kali.org kali/updates Release
Ign http://security.kali.org kali/updates Release
Err http://http.kali.org kali/main Sources
  404  Not Found
Err http://http.kali.org kali/non-free Sources
  404  Not Found
Err http://http.kali.org kali/contrib Sources
  404  Not Found
Err http://http.kali.org kali/main amd64 Packages
  404  Not Found
Err http://http.kali.org kali/non-free amd64 Packages
  404  Not Found
Err http://http.kali.org kali/contrib amd64 Packages
  404  Not Found
Err http://security.kali.org kali/updates/main amd64 Packages
  404  Not Found
Err http://http.kali.org kali/main i386 Packages
  404  Not Found
Err http://security.kali.org kali/updates/contrib amd64 Packages
  404  Not Found
Err http://http.kali.org kali/non-free i386 Packages
  404  Not Found
Err http://security.kali.org kali/updates/non-free amd64 Packages
  404  Not Found
Err http://http.kali.org kali/contrib i386 Packages
  404  Not Found
Err http://security.kali.org kali/updates/main i386 Packages
  404  Not Found
Ign http://http.kali.org kali/contrib Translation-es_AR
Err http://security.kali.org kali/updates/contrib i386 Packages
  404  Not Found
Ign http://http.kali.org kali/contrib Translation-es
Err http://security.kali.org kali/updates/non-free i386 Packages
  404  Not Found
Ign http://http.kali.org kali/contrib Translation-en
Ign http://http.kali.org kali/main Translation-es_AR
Ign http://security.kali.org kali/updates/contrib Translation-es_AR
Ign http://http.kali.org kali/main Translation-es
Ign http://security.kali.org kali/updates/contrib Translation-es
Ign http://http.kali.org kali/main Translation-en
Ign http://security.kali.org kali/updates/contrib Translation-en
Ign http://http.kali.org kali/non-free Translation-es_AR
Ign http://security.kali.org kali/updates/main Translation-es_AR
Ign http://security.kali.org kali/updates/main Translation-es
Ign http://http.kali.org kali/non-free Translation-es
Ign http://security.kali.org kali/updates/main Translation-en
Ign http://http.kali.org kali/non-free Translation-en
Ign http://security.kali.org kali/updates/non-free Translation-es_AR
Ign http://security.kali.org kali/updates/non-free Translation-es
Ign http://security.kali.org kali/updates/non-free Translation-en
Err http://security.kali.org kali/updates/main Sources
  404  Not Found
Err http://security.kali.org kali/updates/contrib Sources
  404  Not Found
Err http://security.kali.org kali/updates/non-free Sources
  404  Not Found

Probé muchas soluciones y ninguna me funcionó... Probé los siguientes comandos:

Código:
rm -rf /var/lib/apt/lists
apt-get update
apt-get install kali-archive-keyring
sudo apt-get install build-essential
sudo apt-get install build-essential checkinstall
sudo apt-get install autoconf automake autotools-dev m4
sudo apt-get install libx11-dev
sudo apt-get install freeglut3-dev
sudo apt-key adv --keyserver pgp.mit.edu --recv-keys ED444FF07D8D0BF6

Mi archivo /etc/apt/sources.list:

Citar
deb http://http.kali.org/kali kali main non-free contrib
deb-src http://http.kali.org/kali kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free
deb-src http://security.kali.org/ kali/updates main contrib non-free

#deb http://mirror.pcextreme.nl/kali kali main non-free contrib

#deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali-dev main contrib non-free
#deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali-dev main/debian-installer
#deb-src http://http.kali.org/kali kali-dev main contrib non-free

#deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali main contrib non-free
#deb [arch=i386,amd64,armel,armhf] http://http.kali.org/kali kali main/debian-installer
#deb-src http://http.kali.org/kali kali main contrib non-free

#deb [arch=i386,amd64,armel,armhf] http://security.kali.org/kali-security kali/updates main contrib non-free
#deb-src http://security.kali.org/kali-security kali/updates main contrib non-free


Las ultimas acciones que realicé , que sospecho que puedan estar causando éste problema, fue eliminar e instalar unas cosas de ruby que necesitaba para poder usar el patter_create.rb, ya que los repositorios de kali tienen una version desactualizada de ruby según parece...
Había ejecutado los siguientes comandos:

Código:
rm -rf /usr/local/lib/ruby
rm -rf /usr/lib/ruby
rm -f /usr/local/bin/ruby
rm -f /usr/bin/ruby
rm -f /usr/local/bin/irb
rm -f /usr/bin/irb
rm -f /usr/local/bin/gem
rm -f /usr/bin/gem
apt-get install build-essential zlib1g zlib1g-dev libreadline6 libreadline6-dev libssl-dev
curl -L https://get.rvm.io | bash -s -- --ignore-dotfiles --autolibs=0 --ruby
source /etc/profile.d/rvm.sh
ruby -v
gem update
echo “gem: –no-document” >> ~/.gemrc
gem install rails
bundle install
gem install pg -v '0.18.1'
gem install metasploit_data_models -v '0.23.1'

Para colmo cada vez que quiero usar las cosas de ruby tengo que ejecutar éste comando:
source /etc/profile.d/rvm.sh

sino no se encuentras las órdenes....

Otra cosa que estuve usando fue proxychains, que también me anda mal, no me funcionan los servidores de proxy que puse en /etc/proxychains.conf, eso que probé unos cuantos...

Y ahora tambien estoy teniendo problemas con el bettercap, que me arroja el siguiente mensaje:

<internal:gem_prelude>:1:in `require': cannot load such file -- rubygems.rb (LoadError)
   from <internal:gem_prelude>:1:in `<compiled>'


MI KALI ESTA HECHO UN CAOOOOOOOS!!!!! Necesito ayuda porque voy a tener que reinstalar todo sino, busco, y busco la solución por todos lados y no encuentro nada :S...

Saludos, y gracias por ayudar!





En línea

A.I.

Desconectado Desconectado

Mensajes: 61


Ver Perfil
Re: Kali Linux: 404 Not Found cada vez que quiero instalar algo con apt-get
« Respuesta #1 en: 3 Noviembre 2015, 01:28 am »

Código
  1. deb http://http.kali.org/kali kali-rolling main contrib non-free
  2. deb http://security.kali.org/kali-security kali-rolling/updates main contrib non-free

http://docs.kali.org/general-use/kali-linux-sources-list-repositories


En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
No puedo instalar kali linux « 1 2 »
GNU/Linux
Hazama 11 41,986 Último mensaje 14 Abril 2014, 13:56 pm
por zimmerman
Error al instalar Kali Linux
GNU/Linux
Proweb 0 2,398 Último mensaje 29 Mayo 2014, 16:05 pm
por Proweb
Problemas al instalar Kali Linux
GNU/Linux
Hurdano 0 2,212 Último mensaje 8 Abril 2015, 12:00 pm
por Hurdano
kali linux 2016.2 Unit metasploit.service not found.
GNU/Linux
Thewark98M 1 6,845 Último mensaje 6 Enero 2017, 03:28 am
por Ancasu
TP LINK TL-WN8200ND - QUIERO USARLO EN KALI LINUX
Materiales y equipos
root.novat0 1 12,063 Último mensaje 14 Diciembre 2017, 20:47 pm
por El_Andaluz
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines