elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Introducción a la Factorización De Semiprimos (RSA)


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  ¿Ubunto da muy lento en máquina virtual VMware?
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: ¿Ubunto da muy lento en máquina virtual VMware?  (Leído 13,518 veces)
theluigy13etv

Desconectado Desconectado

Mensajes: 179


Primero se hace, después se mejora


Ver Perfil
¿Ubunto da muy lento en máquina virtual VMware?
« en: 15 Octubre 2012, 19:05 pm »

Hola, hace unas semanas quise adentrarme al mundo del GNU-Linux ya que siempre he usado productos Microsoft. Entonces para comenzar a probar otras cosas me descargué e instalé en una máquina virtual un tal Ubuntu 12.10
Luego de instalar quise usarlo, lo que me sorprendió fue ver un escritorio tan grande, incluso con barras de desplazamiento  :huh:  :huh:
Pero lo que no me gustó fue que era muy lento, a pesar que le di 2 GB, 4 GB de ram, seguía lento. No sé, tal vez si fue que la máquina virtual no soporta Ubuntu, o necesito una computadora más potente. ¿A alguien le ha pasado lo mismo?
Y otra cosa, quería saber qué distribución Linux me recomiendan, nunca he usado este SO y quiero empezar desde ahora. Gracias


En línea

Caster


Desconectado Desconectado

Mensajes: 787


Ver Perfil WWW
Re: ¿Ubunto da muy lento en máquina virtual VMware?
« Respuesta #1 en: 15 Octubre 2012, 19:10 pm »

Buenas!

Pues mira, que tenga barras de desplazamiento sera a causa de que es un escritorio normal, como otros, entonces si tienes la venta de la maquina virtual minimizada apareceran barras de desplazamiento, logicamente. La causa de que vaya lento no se me ocurre nada, puede ser problema de tu PC.
Una buena distribucion para empezar es Ubuntu, una distribucions, no muy dificil de usar y bastante amigable.

Saludos


En línea

morodog

Desconectado Desconectado

Mensajes: 105



Ver Perfil
Re: ¿Ubunto da muy lento en máquina virtual VMware?
« Respuesta #2 en: 15 Octubre 2012, 19:55 pm »

Le diste 2gb solamente de espacio a linux? dale más, porque luego con las actualizaciones aplicaciones y demás te va a hacer falta.

Le das 4gb de ram, pero que procesador tienes??

Las distros de linux suelen ser limpias e ir bastante rápido , por lo menos mas que los Windows.

Cierra todas las aplicaciones que tengas abiertas para iniciar la máquina virtual, y a ver si te mejora un poco esa lentitud. Y da más espacio a la partición de linux.

Un saludo.
En línea

@nachosanzu

youtube.com/haztuclick
oPen syLar


Desconectado Desconectado

Mensajes: 769


The Best of You..


Ver Perfil WWW
Re: ¿Ubunto da muy lento en máquina virtual VMware?
« Respuesta #3 en: 15 Octubre 2012, 20:05 pm »

Puff.. 4GB y va lento.? xD

Yo tengo una VM con 256MB (tengo 2GB en mi equipo) con y va de lujo con XP..

Intenta descargar una versión mas ligera.. Alguna distro con Lxde (en su defecto XFCE) por defecto... Gnome pues.. quizás se lo mas apropiado para ti.. Pero Es muy pesado

Deberías especificar tus recursos y las especificaciones de tu VM


Añado: Las Ubuntus suelen trae muchas cosas activadas/instaladas que quizas en tu caso no la necesites.. Quizás deberías buscar otra distro.. mas "light" quizas slitaz sea una opcion..
« Última modificación: 15 Octubre 2012, 20:11 pm por oPen syLar » En línea

Siempre habra 2 verdades, la que quieres creer y la que no aceptaras
theluigy13etv

Desconectado Desconectado

Mensajes: 179


Primero se hace, después se mejora


Ver Perfil
Re: ¿Ubunto da muy lento en máquina virtual VMware?
« Respuesta #4 en: 16 Octubre 2012, 04:04 am »

Puff.. 4GB y va lento.? xD

Yo tengo una VM con 256MB (tengo 2GB en mi equipo) con y va de lujo con XP..

Intenta descargar una versión mas ligera.. Alguna distro con Lxde (en su defecto XFCE) por defecto... Gnome pues.. quizás se lo mas apropiado para ti.. Pero Es muy pesado

Deberías especificar tus recursos y las especificaciones de tu VM


Añado: Las Ubuntus suelen trae muchas cosas activadas/instaladas que quizas en tu caso no la necesites.. Quizás deberías buscar otra distro.. mas "light" quizas slitaz sea una opcion..
Jajajaj no le di 2GB de espacio de Disco duro, le di más, me referería que probando con 2GB y 4GB de ram, aún así daba lento.

Tengo una Intel Corei7 con 8 GB de RAM y SO Windows 7 64 bits.
En mi VMware tengo funcionando normal el windows 8, windows 2008 server, windows 7 de 32 bits, windows XP, windows 95, 98, etc, con ellos me da normal, pero con el Ubuntu me va lento. Me parece muy raro. Al hacer un simple click en un botón demora en aparecer el menú contextual, como si fuera un video ralentizado.
« Última modificación: 16 Octubre 2012, 04:10 am por theluigy13etv » En línea

dato000


Desconectado Desconectado

Mensajes: 3.034



Ver Perfil
Re: ¿Ubunto da muy lento en máquina virtual VMware?
« Respuesta #5 en: 16 Octubre 2012, 04:48 am »

Debe ir lento porque seguro necesita las herramientas adicionales que traen soporte de video para maquinas virtuales, como pasa con virtualbox, no se mucho de vmware, pero en virtualbox hay que usar el "additions" para tener soporte 3D y demás cosas que hacen que el escritorio aparezca pesado, lento, fastidioso y tediosos de manejar.

El problema no es de ram, es que el driver de video de tu maquina virtual no esta correctamente configurado.
« Última modificación: 17 Octubre 2012, 14:12 pm por dato000 » En línea


Atry

Desconectado Desconectado

Mensajes: 90



Ver Perfil
Re: ¿Ubunto da muy lento en máquina virtual VMware?
« Respuesta #6 en: 12 Febrero 2013, 14:30 pm »

Hola! se que es un post antiguo pero es que no se llego a dar una solución, e tenido el mismo problema y lo e buscado por muchas paginas y no encontre nada, asi que dejo aqui la solución que yo conseguí darle.

Vb tiene ya valores por defecto para determinados sistemas los cuales detecta por el nombre ubuntu-debian-windowsxp... y para linux generalmente suele aplicar por defecto 8 gigas de memoria, creo k 254 de ram...etc
Yo lo instale y le di 4 gigas de ram y 20 de hdd y me iba super lento y claro estaba flipando por que 4 gigas dan para MUCHO asi que mire y otro de los valores por defecto que pone, es el numero de procesadores! es decir, si tienes un procesador que es potente por tener diversos nucleos, pero que separados no son una maravilla pues te ira lento,
asi que con que vayas a configuración de la maquina virtual, al apartado sistema pestaña procesador, hay elijes la cantidad de procesadores que deseas darle, yo le puse 3 y va a la perfección.

Un saludo ;D
« Última modificación: 12 Febrero 2013, 14:33 pm por Atry » En línea



Le parkour!
mI video! ---> http://www.youtube.com/watch?v=nT9A8L4eK9M
Espero k os guste ;D
alister


Desconectado Desconectado

Mensajes: 513


Ver Perfil
Re: ¿Ubunto da muy lento en máquina virtual VMware?
« Respuesta #7 en: 12 Febrero 2013, 14:36 pm »

jamas entenderé por que una persona puede querer utilizar una distribucion de tipo LIVE en una maquina vrtual a la hora de probarla.

la live esta pensada para que no toque nada de tu disco duro. aprovechate de eso y arráncala DE VERDAD, no de mentira en el virtualizador.

el virtualizador(virtualbox, vmware, etc) vrtualiza un pc completo dentro de tu pc. no se le puede pedir un rendimiento salvaje.

las barras de desplazamiento son debidas a la configuración fluida-no fluida de la pantalla en la maquina virtual. el no saber controlar eso es mas un problema del usuario que de la maquina, que ofrece la opcion de hacer el escritorio mas pequeño y hacer un escalado. solo tienes que aprender a manejar la maquina virtual y sus capacidades, que son muchas.

ubuntu ya integra el driver de video de vbox i de vmware si no recuerdo mal. pero aunque usara el vesa por defecto, no te irá lento por eso. la carga real del hardware la realiza la gráfica real, y esta esta acelarada.

la cpu tambien es importante para el virtualizador. si tiens una cpu humilde, no esperes milagros

no importa en absoluto el disco duro que se asigne a ubuntu para probarla como live. no lo va a usar.

y en definitiva: si quieres probar algo, hazlo bien y de forma justa. prueba el live cd de ubuntu arrancandolo de verdad, que no te va a morder. es muhco mejor que instalar el sistema en una maquina virtual. y para probarlo y hacerse una idea, se ajusta mas a la realidad y te permite saber si tu hardware es soportado. luego si quieres instalarlo, instalalo de verdad en la particion que se merece. si no no estas probando, estas coqueteando.

saludos
« Última modificación: 12 Febrero 2013, 14:42 pm por alist3r » En línea

Back 2 business!
leopatagon

Desconectado Desconectado

Mensajes: 1


Ver Perfil
Re: ¿Ubunto da muy lento en máquina virtual VMware?
« Respuesta #8 en: 2 Abril 2014, 07:35 am »

Algo que probé aunque parezca extraño, es bajarle la cantidad de ram a la VM.

Esto lo hice para evitar el swaping en el host y así ganar velocidad, tengo 2 gb de ram un cpu Intel dual core y a la vm le puse 512.

Funciona bastante mejor, espero haber ayudado, saludos.
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
conectar maquina virtual VMWARE a mi lan casera?
Redes
shadow89 7 55,871 Último mensaje 24 Octubre 2010, 00:34 am
por fer79
Crear Maquina Virtual en Vmware (Hablado)
Software
Milo_EscorpioNN 0 875 Último mensaje 11 Septiembre 2011, 00:46 am
por Milo_EscorpioNN
Problema al crear una maquina Virtual con Vmware 8
GNU/Linux
Dyszx 0 1,715 Último mensaje 2 Marzo 2012, 05:04 am
por Dyszx
ayuda con maquina virtual vmware
Software
General Dmitry Vergadoski 2 522 Último mensaje 9 Julio 2017, 21:53 pm
por General Dmitry Vergadoski
¿Qué rastro deja una máquina virtual (VMware) en el ordenador huésped?
Seguridad
Sir_Francis 1 1,179 Último mensaje 8 Enero 2019, 08:50 am
por r32
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines