elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Rompecabezas de Bitcoin, Medio millón USD en premios


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  como puedo instalar archivos .deb desde un pendrive (por terminal)
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: como puedo instalar archivos .deb desde un pendrive (por terminal)  (Leído 1,096 veces)
cdgr.ing

Desconectado Desconectado

Mensajes: 1


Ver Perfil
como puedo instalar archivos .deb desde un pendrive (por terminal)
« en: 30 Marzo 2017, 04:06 am »

Buenas noches,

soy nuevo en linux, instale debian junto con windows 7, como puedo hacer para instalar los firmware de wifi... tomando en cuanto que no tengo escritorio GNOME ni KDE... quiero instalar tanto el escritorio como el firmware de wifi.

agradezco de antemano su ayuda.

saludos


En línea

engel lex
Moderador Global
***
Desconectado Desconectado

Mensajes: 15.514



Ver Perfil
Re: como puedo instalar archivos .deb desde un pendrive (por terminal)
« Respuesta #1 en: 30 Marzo 2017, 04:12 am »

que escritorio tienes? yo personalmente recomiendo que lo hagas por el gestor gdebi que es visual, si no por consola es (recuerda que debes estar como root, o tu usuario ser un sudoer)

Código:
dpkg -i loquesea.deb



En línea

El problema con la sociedad actualmente radica en que todos creen que tienen el derecho de tener una opinión, y que esa opinión sea validada por todos, cuando lo correcto es que todos tengan derecho a una opinión, siempre y cuando esa opinión pueda ser ignorada, cuestionada, e incluso ser sujeta a burla, particularmente cuando no tiene sentido alguno.
do-while


Desconectado Desconectado

Mensajes: 1.276


¿Habra que sacarla de paseo?


Ver Perfil
Re: como puedo instalar archivos .deb desde un pendrive (por terminal)
« Respuesta #2 en: 30 Marzo 2017, 12:17 pm »

Si el paquete no tiene dependencias o si las dependencias ya están instaladas puedes hacer lo que engel lex te ha dicho. Si para satisfacer las dependencias se tuviese que recurrir a paquetes no instalados tendrías que empezar a instalar una a una las dependencias, las dependencias de las dependencias...

Así que para no tener que estar perdiendo el tiempo y la paciencia, si tienes cable ethernet lo mejor que puedes hacer es conectar el ordenador directamente al router. Otra alternativa es instalar primero los controladores de tu tarjeta wifi utilizando tu móvil como router y luego ya tirar de wifi para instalar el resto de paquetes.

Si la tarjeta wifi está integrada (como en los portátiles) puedes consultar el modelo del chipset con lspci | grep etwork y si es un modelo de los que se conecta por USB ejecutas lsusb y buscas el modelo.

Si es atheros ejecutas, asegurándote primero de que tienes conexión a internet de cualquiera de las formas que ya he mencionado, apt-get install firmware-atheros, si la tarjeta es realtek, apt-get install firmware-realtek, si es una broadcom b43 de algún tipo, me parece que en Debian Stretch utilizan el mismo paquete que en Ubuntu, en Jessie tiene distinto nombre, apt-get install bcm-b43-installer y si no fuese así consultas los candidatos con apt-cache search broadccom o apt-cache search b43 o con palabras relacionadas, con apt-cache show paquete ves la información exacta de un paquete (en este caso te saldrá la lista de chipsets que soporta cada uno de los paquetes) e instalas el que te convenga. En cualquier caso una vez que sepas el fabricante y modelo y si tu tarjeta no es ninguna de las anteriores puedes hacer consultas como ya te he dicho apt-cache search consulta y ves las especificaciones de un paquete con apt-cache show paquete, así que buscas e instalas, y solo si no hay nada específico para tu caso busca algún apaño en internet.

No nos has dicho que versión de Debian utilizas. Siendo que acabas de instalarlo y si no hubieses escogido Debian 9 (Stretch), descargaría una de las isos semanales de stretch y volvería a instalarlo. Es más estable que la actual estable, los paquetes son más recientes y en unos pocos meses pasará a ser la nueva estable.
« Última modificación: 30 Marzo 2017, 12:26 pm por do-while » En línea

- Doctor, confundo los números y los colores.
- Vaya marrón.
- ¿Marrón? ¡Por el culo te la hinco!
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines