elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Entrar al Canal Oficial Telegram de elhacker.net


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web
| | |-+  Bases de Datos (Moderador: Carloswaldo)
| | | |-+  problema con mysql [SOLUCIONADO]
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: problema con mysql [SOLUCIONADO]  (Leído 5,433 veces)
jjam45

Desconectado Desconectado

Mensajes: 58


Ver Perfil
problema con mysql [SOLUCIONADO]
« en: 14 Julio 2010, 22:21 »

Tengo un formulario que quiero enviar a una BD en mysql pero no llega a enviar los datos, despues de dar a enviar en el formulario carga la pagina insertar pero se queda blanca y mirando directamente en la base de datos no hay ningun dato en mi tabla.

Aqui dejo el codigo:

Código:
<form id="empresas" name="empresas" method="post" action="insertar.php">
  <table width="1000" border="0" align="left">
    <tr>
      <th width="59" scope="col">Empresa</th>
      <th width="144" scope="col">Producto</th>
      <th width="167" scope="col">Precio</th>
      <th width="184" scope="col">datos</th>
    </tr>
    <tr>
      <th scope="row"><label for="empresa"></label>
        <select name="empresa" id="empresa">
          <option>Proveedor1</option>
          <option>Proveedor2</option>
          <option>Proveedor3</option>
      </select></th>
      <td><label for="producto"></label>
        <label for="producto"></label>
      <input type="text" name="producto" id="producto" /></td>
      <td><label for="precio"></label>
      <input name="precio" type="text" id="precio" value="0,00" />
      €</td>
      <td><label for="datos"></label>
      <textarea name="datos" id="datos" cols="45" rows="5"></textarea></td>
    </tr>
    <tr>
      <th scope="row"><input type="submit" name="enviar" id="enviar" value="Enviar" /></th>
      <td>&nbsp;</td>
      <td>&nbsp;</td>
      <td>&nbsp;</td>
    </tr>
  </table>
</form>

insertar.php:

Código:
<?php

        

$empresa=$_POST['empresa'];
$producto=$_POST['producto'];
$precio=$_POST['precio'];
$datos=$_POST['datos'];


$link = mysql_connect("mysql.webcindario.com","proveedoresjon","xxxxx");
        mysql_select_db("proveedoresjon",$link);

        mysql_query("INSERT INTO facturas (empresa,producto,precio,datos)
        VALUES ('$empresa','$producto','$precio','$datos')",$link);

?>

Estos son los datos que tengo:
Código:
Servidor: mysql.webcindario.com Base de datos: proveedoresjon
versión: MySQL 5.0.22 usuario: proveedoresjon


« Última modificación: 15 Julio 2010, 01:00 por jjam45 » En línea

Shell Root
Moderador Global
***
Desconectado Desconectado

Mensajes: 3.705


WOS & Khan & Calero LDN


Ver Perfil WWW
Re: problema con mysql
« Respuesta #1 en: 14 Julio 2010, 23:19 »

intentad mirar que error te tira al ejecutar la query. Así:
Código
  1. $query = "INSERT INTO facturas (empresa, producto, precio, datos) VALUES ('1', '2', '3', '4')";
  2. $resultado = mysql_query($query) or die('La consulta falló: ' . mysql_error());

También mirad si los datos enviados por el método POST, si contiene información.


En línea

Por eso no duermo, por si tras mi ventana hay un cuervo. Cuelgo de hilos sueltos sabiendo que hay veneno en el aire.
jjam45

Desconectado Desconectado

Mensajes: 58


Ver Perfil
Re: problema con mysql
« Respuesta #2 en: 14 Julio 2010, 23:27 »

intentad mirar que error te tira al ejecutar la query. Así:
Código
  1. $query = "INSERT INTO facturas (empresa, producto, precio, datos) VALUES ('1', '2', '3', '4')";
  2. $resultado = mysql_query($query) or die('La consulta falló: ' . mysql_error());

También mirad si los datos enviados por el método POST, si contiene información.


Al introducir ese código no me sale nada, sale la pagina en blanco.
¿como miro si contienen información los datos?

Gracias

Código:
consulta SQL:
SELECT * FROM facturas

MySQL ha devuelto un valor vacío (i.e., cero columnas). (La consulta tardó 0.0077 seg)

Código:
consulta SQL:
SHOW TABLES

Tables_in_proveedoresjon
facturas
Código:

consulta SQL:
DESCRIBE facturas

Field  Type  Null Key Default Extra
empresa varchar(20) YES   NULL
producto varchar(40) YES   NULL
precio varchar(10) YES   NULL
datos varchar(100) YES   NULL
« Última modificación: 14 Julio 2010, 23:49 por jjam45 » En línea

jjam45

Desconectado Desconectado

Mensajes: 58


Ver Perfil
Re: problema con mysql
« Respuesta #3 en: 15 Julio 2010, 01:00 »

Ya lo he solucionado!!  ;-)

Un problema tonto, como suponía.

En esta parte del codigo tengo que cambiar la tabla facturas por: proveedoresjon.facturas

Código:
mysql_query("INSERT INTO facturas (empresa,producto,precio,datos)
        VALUES ('$empresa','$producto','$precio','$datos')",$link);

Y queda así:

Código:
mysql_query("INSERT INTO proveedoresjon.facturas (empresa,producto,precio,datos)
        VALUES ('$empresa','$producto','$precio','$datos')",$link);
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
SOLUCIONADO: Delete en mysql
Bases de Datos
mk_137 0 2,548 Último mensaje 28 Diciembre 2010, 13:24
por mk_137
Lio en mysql :@ mysql_select_db() {SOLUCIONADO}
Bases de Datos
:ohk<any> 1 3,141 Último mensaje 5 Mayo 2011, 22:24
por :ohk<any>
Problema con subconsultas en mysql [solucionado]
Bases de Datos
bewa 3 5,143 Último mensaje 1 Abril 2012, 01:52
por bewa
problema ejemplo com mysql en c++[solucionado]
Programación C/C++
flony 0 1,884 Último mensaje 18 Noviembre 2012, 03:24
por flony
Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines