elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Deseas probar algunas mejoras a la interfaz del foro? Prueba cake! acerca de


+  Foro de elhacker.net
|-+  Informática
| |-+  Multimedia (Moderador: Songoku)
| | |-+  (consulta) Megui audio desincronizado x264+aac
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] 2 Ir Abajo Respuesta Imprimir
Autor Tema: (consulta) Megui audio desincronizado x264+aac  (Leído 9,101 veces)
alexowolff

Desconectado Desconectado

Mensajes: 57



Ver Perfil
(consulta) Megui audio desincronizado x264+aac
« en: 5 Mayo 2013, 00:24 »


Esto con Realanime y camtasia no me pasaba pero megui encodea mejor que los anteriores nombrados.

el tema es el audio como lo hace en procesos separados al muxearlo todo bien, pero cuando lo escucho al inicio no noto diferencia al final si se nota como 2 o 3 segundos de retraso en el audio.

x264 + nero aac

Video encodeado megui

Código:
Format                                   : MPEG-4
Format profile                           : JVT
Codec ID                                 : avc1
File size                                : 32.9 MiB
Duration                                 : 4mn 35s
Overall bit rate                         : 1 003 Kbps
Encoded date                             : UTC 2013-05-03 22:47:42
Tagged date                              : UTC 2013-05-03 22:47:42

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4.1
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 4 frames
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 4mn 35s
Bit rate                                 : 1 000 Kbps
Maximum bit rate                         : 2 113 Kbps
Width                                    : 1 024 pixels
Height                                   : 768 pixels
Display aspect ratio                     : 4:3
Frame rate mode                          : Constant
Frame rate                               : 15.000 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.085
Stream size                              : 32.8 MiB (100%)
Writing library                          : x264 core 130 r2273 b3065e6
Encoding settings                        : cabac=1 / ref=4 / deblock=1:-1:-1 / analyse=0x3:0x113 / me=umh / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=150 / keyint_min=15 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=1000 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=50000 / vbv_bufsize=50000 / nal_hrd=none / ip_ratio=1.40 / aq=1:1.00
Encoded date                             : UTC 2013-05-03 22:47:42
Tagged date                              : UTC 2013-05-03 22:51:02



Audio encodeado Nero aac, m4a.

Código:
Format                                   : MPEG-4
Format profile                           : Base Media / Version 2
Codec ID                                 : mp42
File size                                : 1.60 MiB
Duration                                 : 4mn 35s
Overall bit rate mode                    : Variable
Overall bit rate                         : 48.6 Kbps
Encoded date                             : UTC 2013-05-04 22:17:10
Tagged date                              : UTC 2013-05-04 22:17:18

Audio
ID                                       : 1
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : HE-AAC / LC
Codec ID                                 : 40
Duration                                 : 4mn 35s
Bit rate mode                            : Variable
Bit rate                                 : 48.0 Kbps
Maximum bit rate                         : 59.1 Kbps
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 44.1 KHz / 22.05 KHz
Compression mode                         : Lossy
Stream size                              : 1.57 MiB (98%)
Writing library                          : Nero AAC codec 1.5.4.0
Encoding settings                        : -br 48000 -he
Encoded date                             : UTC 2013-05-04 22:17:10
Tagged date                              : UTC 2013-05-04 22:17:18

Menu


Porfa diganme que es problema del audio o del muxeador de megui por que si es el video me corto el cuello. >:D


En línea

Songoku
Supersayan y
Moderador
***
Desconectado Desconectado

Mensajes: 14.502


Supersayan


Ver Perfil WWW
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #1 en: 5 Mayo 2013, 11:04 »

Como ya te dicho en otro hilo esto suele pasar por falta de recursos durante la codificacion.
Saludos...

Songoku


En línea

  

http://lawebdegoku.es                   http://webdegoku.es
alexowolff

Desconectado Desconectado

Mensajes: 57



Ver Perfil
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #2 en: 6 Mayo 2013, 08:19 »

EL RIPEO LO repeti 10 veces no puede ser q falte todas.
En línea

Songoku
Supersayan y
Moderador
***
Desconectado Desconectado

Mensajes: 14.502


Supersayan


Ver Perfil WWW
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #3 en: 6 Mayo 2013, 14:13 »

Repitelo con el pc recien reiniciado, desconectado de internet, con el antivirus, el firewall, y todo lo que no sea imprescindible bien cerrados. No toques el teclado ni el raton durante todo el proceso y no tengas ninguna otra aplicacion abierta ni hagas nada con el pc durante todo el proceso. Deten todos los procesos y servicios inutiles que se carguen al inicio de windows y que seguro son muy numerosos.

Y aun asi si el sistema operativo tiene un excesivo nivel de corrupcion puede que estas medidas no sean suficientes. Y ademas si el programa osea el ripper en este caso consume mas recursos que de los que le puede suministrar el hardware de tu equipo entonces tampoco servirá de nada todo esto.

Pero vamos te repito que estas cosas en el 90% de los casos estan provocadas por falta de recursos (y la falta de recursos puede ser por muchas causas).
Saludos...

Songoku
En línea

  

http://lawebdegoku.es                   http://webdegoku.es
Kurono90

Desconectado Desconectado

Mensajes: 100



Ver Perfil
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #4 en: 6 Mayo 2013, 18:39 »

Bueno, solo para descartar y en el caso de que este desfase sea culpa de ese 10% que no es por falta de recursos... veamos:

1- ¿En MeGUI, el video que generas sin sonido es una pista elemental (.h264) o un contenedor (.mp4 o .mkv)?

Si por esas casualidades el video que generas tiene la extensión .h264, esta es una pista elemental y los muxer, tanto MP4box como MKVToolnix no reconocen los fps (frames por segundo) y por defecto usan 25 fps, pero tu video tiene 15 fps.
El video muxeado con el audio (.mp4 o .mkv) tendrá en la cabecera del contenedor marcado que debe reproducirse a 25 fps por lo que acelerara la reproducción de la pista de video y el audio se ira quedando progresivamente mas atrasado.
No lo veo descabellado ya que en un video tan corto tuviste una descoordinacion progresiva tan rápida.

Solución en este caso: En la opciones del muxer que uses busca una opción para especificar los fps manualmente y escribe 15, o 15000/1000 según si te pide en forma de división. Luego carga el audio y muxea normalmente.

2- Si usaste un flitro de carga como DirectShowSource en el Script AVS de MeGUI, quizá tuviste la mala suerte de que no reconoció correctamente los fps de tu video. No es muy común pero puede pasar, a mi me a pasado con unos .rmvb y me quise matar después.
Pero aun así no tiene lógica, porque en los datos de mediainfo que dejaste el video dura lo mismo que el audio así que no creo que sea esta la causa... pero uno nunca sabe.

Solución en este caso: Volver a encodear el video usando DirectShowSource("C:\videos\kurono\ejemplo.avi", fps=15), como ves agregamos el parámetro fps=15. Para mas seguridad podrías agregar otra linea abajo que diga AssumeFPS(15)

3- Si lo que pusiste en mediainfo es solo un fragmento del video total y en el completo el audio te dura unos cuantos segundos mas o unos cuantos menos, siempre podes estirarlo o acortarlo con Audacity o BeHappy usando la opción "Cambiar ritmo sin cambiar tono", recomiendo hacerlo con Audacity que es mas fácil y solo con pistas estéreo o mono.

4- Solo para descartar podes convertir de vuelta en MeGUI el audio pero probando otros codecs como FAAC (AAC pero codificado con FFMPEG) u OGG (calidad igual que el AAC)

Esto es todo lo que se me ocurre, si ninguna de estas cosas funciona como dice kiko del chavo "pues me doy" y seguramente sea falta de recursos del PC.

Saludos
En línea

alexowolff

Desconectado Desconectado

Mensajes: 57



Ver Perfil
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #5 en: 6 Mayo 2013, 22:28 »



En el muxeo de megui me aparece por defecto el valor de 15fps no se si el audio tmb lo tiene.

el video es un mp4 sin audio el audio es un m4a de mas o menos 4 min, ahi noto el desfasaje.

si le pongo -3 delay al muxeo como el que video no le anda bien en la barra de tiempo se pone loca y es como que adelanto 2 min y se val al final pero en la barra esta en 2 min por ejemplo.


hmm voy a ver si el video muxeado esta bien en el sony vegas o de ultyma encodeo solo el audio como haci antes y aro el mkv merge y hago en ves de mp4 mkv.


ups no probé muxearlo a mkv jajaja lo voy a intentar.


Y decime como consigo es faac lo baje de un lugar pero tiene muchos archivos como si fuera de linux ni idea como instalar el zip o lo baje de un lugar equivocado, en ese mismo tidio tambien estaba el faac2 o algo asi y el nero  aac, yo el nero aac lo baje de la pagina de nero.
En línea

Eleкtro
Colaborador
***
Desconectado Desconectado

Mensajes: 5.865


"En teoría, la teoría y la práctica son lo mismo."


Ver Perfil
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #6 en: 7 Mayo 2013, 11:50 »

¿La supuesta desincronización donde se da?, quiero decir, la notas en el reproductor de video, en el editor de video, o donde?

Te lo comento porque algunos reproductores tienen una mala sincronización (ejemplo: umplayer, smplayer) y te desincronizan sobretodo los videos de 1080p con ms e incluso segundos de diferencia, pero en realidad no están desincronizados.
Si el problema lo notas al reproducir el video te recomiendo que uses el MediaPlayerClassic (Que no es lo mismo que "Mplayer") para salir de dudas y ver si realmente está desincronizado o no.

Aparte, ¿porque no consideras aumentar/disminuir 2-4 frames al framerate del vídeo final para corregir la desincronizacion de 2 segundos?, lo puedes hacer sin reconvertir y es una solución.

Un saludo.
En línea

Como insertar un código:

 

-> Reglas del foro <-
Kurono90

Desconectado Desconectado

Mensajes: 100



Ver Perfil
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #7 en: 8 Mayo 2013, 03:04 »

WTF, ahora que me fijo en el MeGUI ya no esta mas la opción FAAC  :-\ ¿Cuanto hacia que no lo usaba? mierd* que me quede en el tiempo  ;D

La opción mas clara seria usar Ogg vorbis como prueba para ver si pasa lo mismo pero, ahora que veo tu configuración del Nero AAC... tene cuidado en la opción que dice Output channels, no se si influirá pero por las dudas en este caso si tu audio originalmente es estéreo usa la opción "Keep original channels" la opción que estas usando ahora (Downmix multichannel to estereo) es para pasar un audio 5.1 (multicanal) a estéreo.

Y bueno, mas que esto no se me ocurre, tene en cuenta lo que dijo Elektro H@cker y anda probando varios reproductores.

Saludos
En línea

alexowolff

Desconectado Desconectado

Mensajes: 57



Ver Perfil
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #8 en: 8 Mayo 2013, 10:15 »

Kuro existe el desface progresivo? me esta pasando lo mismo con todos los encodeos, lo muxeo con mkvmerge o el muxer de megui a mp4 y pasa lo mismo, el DESFACE, lo reprodusco con bsplayer con VLC y con adobe premier y el adio se corre a mitad del video mas o menos se atrasa 1 seg o -700 para ser exacto (con vlc atrase el audio o adelante no recuerdo, da negativo) probé darle delay al muxearalo pero el incicio se desfaca y al final del video esta correcto, entonces esto es joda.  :-\ :-\ :-\ :-\ :-\ :-\

Alguien conspira en contra mía, lo se.  :P :P :P :P

En línea

Songoku
Supersayan y
Moderador
***
Desconectado Desconectado

Mensajes: 14.502


Supersayan


Ver Perfil WWW
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #9 en: 8 Mayo 2013, 20:59 »

Citar
Kuro existe el desface progresivo?


Claro que existe. No serás de los que instalan todos los codecs y packs de codecs habidos y por haber que caigan en tus manos?
Saludos...

Songoku
« Última modificación: 10 Mayo 2013, 14:01 por Songoku » En línea

  

http://lawebdegoku.es                   http://webdegoku.es
alexowolff

Desconectado Desconectado

Mensajes: 57



Ver Perfil
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #10 en: 10 Mayo 2013, 04:02 »

tengo K lite codepack 2 y 64 bits cada uno una instalacion aparte.

ademas reproductores que tiene sus codescst tmb y no se si el megui o avs script o premier adebe instala sus cosas.
En línea

Eleкtro
Colaborador
***
Desconectado Desconectado

Mensajes: 5.865


"En teoría, la teoría y la práctica son lo mismo."


Ver Perfil
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #11 en: 10 Mayo 2013, 06:06 »

tengo K lite codepack 2 y 64 bits cada uno una instalacion aparte.

Yo hace años también pensaba como tú pero Songoku me ayudó a aclararme las ideas jeje.

Desinstálate esa ***** de k-lite, los dos, no los necesitas en tu PC.

1. Instálate AC3-File para reproducir audio AC3/DTS/etc: http://www.ac3filter.net/wiki/Download_AC3File
2. Instálate FFDShow tryouts para reproducir todo lo demás (Video/Audio): http://ffdshow-tryout.sourceforge.net/
3. Y opcionálmente instálate XVid o Divx si quieres codificar en ese formato: http://www.xvid.org/Downloads.15.0.html
En línea

Como insertar un código:

 

-> Reglas del foro <-
alexowolff

Desconectado Desconectado

Mensajes: 57



Ver Perfil
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #12 en: 11 Mayo 2013, 12:28 »

Curioso direccion!

en que post te aclara eso?
En línea

Eleкtro
Colaborador
***
Desconectado Desconectado

Mensajes: 5.865


"En teoría, la teoría y la práctica son lo mismo."


Ver Perfil
Re: (consulta) Megui audio desincronizado x264+aac
« Respuesta #13 en: 11 Mayo 2013, 16:14 »

en que post te aclara eso?

No lo recuerdo, creo que fue en un post de mi antiguo usuario, pregunté algo sobre el klite, pero no sé ni que pregunté, y luego la conversación fue tomando forma hacia que codecs eran necesarios y cuales no.

Saludos.
En línea

Como insertar un código:

 

-> Reglas del foro <-
Páginas: [1] 2 Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
VIDEO DESINCRONIZADO
Multimedia
mary_mor15 5 1,025 Último mensaje 3 Octubre 2004, 05:32
por Mason33
Problema con audio desincronizado
Multimedia
WildFroVII 6 2,041 Último mensaje 16 Marzo 2008, 17:03
por WildFroVII
Problema al encodear con el Megui en ultimo paso
Multimedia
batr22 0 1,511 Último mensaje 14 Octubre 2011, 21:20
por batr22
Reproductor de audio [Consulta]
Desarrollo Web
Shamaroot 2 579 Último mensaje 30 Enero 2012, 20:55
por Shamaroot
(Consulta) Problema con megui
Multimedia
alexowolff 13 3,071 Último mensaje 6 Mayo 2013, 08:27
por alexowolff
Powered by SMF 1.1.19 | SMF © 2006-2008, Simple Machines