elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: [Tutorial] Tortilla + TOR = + privacidad


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux
| | |-+  problema con fedora 17, no me aparece login
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: problema con fedora 17, no me aparece login  (Leído 695 veces)
Belial & Grimoire


Desconectado Desconectado

Mensajes: 556


Tea_Madhatter


Ver Perfil
problema con fedora 17, no me aparece login
« en: 10 Febrero 2013, 00:57 »

hola

alguien sabe como podria reparar a fedora 17?, lo que pasa es que siempre me hace lo mismo, hay un momento en que se carga pero ya no me aparece el login, solo se queda la pantalla en negro y ya no avanza, al principio crei que era por los controladores de video, pero ya intente usar tanto los libres como los privativos... ahorita grub ya no me dejaba entrar a windows asi que modifique el archivo grub.cfg para poder entrar y lo logre, pero ahora me volvio a hacer lo mismo fedora

y no quiero tener que formatear mi computadora todo el tiempo solo por ese error, y en google no encuentro nada que me pueda ayudar, alguien sabe algo al respecto?


En línea

.                                 
alister


Desconectado Desconectado

Mensajes: 513


Ver Perfil
Re: problema con fedora 17, no me aparece login
« Respuesta #1 en: 10 Febrero 2013, 01:00 »

hola

has olvidado poner los datos del problema

saludos


En línea

Back 2 business!
Belial & Grimoire


Desconectado Desconectado

Mensajes: 556


Tea_Madhatter


Ver Perfil
Re: problema con fedora 17, no me aparece login
« Respuesta #2 en: 10 Febrero 2013, 01:38 »

jeje, el problema era que ya no me aparecia el login, cuando oprimia ESC para ver que fallaba al cargar, todo me aparecia bien

pero ya logre resolverlo, me meti como "Recovery" y desinstale el driver de video libre

luego segui estos pasos, y ahora mismo ya estoy en fedora de nuevo, a ver si a alguien mas le sirve por si usa fedora 17

Código:
Create missing version.h for Kernel 3.7.3:
sudo gedit /lib/modules/3.7.3-101.fc17.x86_64/build/include/linux/version.h

Insert the following lines and save the file:
#define LINUX_VERSION_CODE 198403
#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))

Download Catalyst driver 13.1:
wget http://www2.ati.com/drivers/linux/amd-driver-installer-catalyst-13.1-linux-x86.x86_64.zip

Unzip the drivers:
unzip amd-driver-installer-catalyst-13.1-linux-x86.x86_64.zip

Make the installer executable:
chmod +x amd-driver-installer-catalyst-13.1-linux-x86.x86_64.run

Run the installer:
sudo ./amd-driver-installer-catalyst-13.1-linux-x86.x86_64.run

Building the kernel modules WILL fail. Do NOT reboot after installation!

Patch firegl_public.c:
sudo gedit /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c

Add the following lines directly after line 100 and save the file:
#ifndef VM_RESERVED
#define VM_RESERVED (VM_DONTEXPAND | VM_DONTDUMP)
#endif

Compiling the kernel modules should work now:
cd /lib/modules/fglrx/build_mod/
sudo ./make.sh

cd /lib/modules/fglrx/
sudo ./make_install.sh

Reboot and the kernel module should load properly.

If the 32bit OpenGL libraries are needed, they just have to be linked properly:
ln -s /usr/lib32/libAMDXvBA.so /usr/lib/libAMDXvBA.so
ln -s /usr/lib32/libAMDXvBA.so.1 /usr/lib/libAMDXvBA.so.1
ln -s /usr/lib32/libAMDXvBA.so.1.0 /usr/lib/libAMDXvBA.so.1.0
ln -s /usr/lib32/libGL.so /usr/lib/libGL.so
ln -s /usr/lib32/libGL.so.1 /usr/lib/libGL.so.1
ln -s /usr/lib32/libGL.so.1.2 /usr/lib/libGL.so.1.2
ln -s /usr/lib32/libOpenCL.so.1 /usr/lib/libOpenCL.so.1
ln -s /usr/lib32/libSlotMaximizerAg.so /usr/lib/libSlotMaximizerAg.so
ln -s /usr/lib32/libXvBAW.so /usr/lib/libXvBAW.so
ln -s /usr/lib32/libXvBAW.so.1 /usr/lib/libXvBAW.so.1
ln -s /usr/lib32/libXvBAW.so.1.0 /usr/lib/libXvBAW.so.1.0
ln -s /usr/lib32/libamdocl32.so /usr/lib/libamdocl32.so
ln -s /usr/lib32/libatiadlxx.so /usr/lib/libatiadlxx.so
ln -s /usr/lib32/libaticalcl.so /usr/lib/libaticalcl.so
ln -s /usr/lib32/libaticaldd.so /usr/lib/libaticaldd.so
ln -s /usr/lib32/libaticalrt.so /usr/lib/libaticalrt.so
ln -s /usr/lib32/libatiuki.so /usr/lib/libatiuki.so
ln -s /usr/lib32/libatiuki.so.1 /usr/lib/libatiuki.so.1
ln -s /usr/lib32/libatiuki.so.1.0 /usr/lib/libatiuki.so.1.0
ln -s /usr/lib32/libfglrx_dm.so /usr/lib/libfglrx_dm.so
ln -s /usr/lib32/libfglrx_dm.so.1 /usr/lib/libfglrx_dm.so.1
ln -s /usr/lib32/libfglrx_dm.so.1.0 /usr/lib/libfglrx_dm.so.1.0
mkdir /usr/lib/dri
ln -s /usr/lib32/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so

Credits go the Xziped from FedoraForum.de.

gracias de todas formas

salu2  ;D
En línea

.                                 
alister


Desconectado Desconectado

Mensajes: 513


Ver Perfil
Re: problema con fedora 17, no me aparece login
« Respuesta #3 en: 10 Febrero 2013, 01:46 »

sospché que eran los drivers pero si no comentas el hardware que tienes y demas, era arriesgdo responderte.

me alegro que ya esté ok.
saludos
En línea

Back 2 business!
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Error al hacer Login on y Login Off en PHPBB
Desarrollo Web
oseck 1 766 Último mensaje 23 Julio 2004, 04:30
por Jeferi
Problema con login en yabbse
Desarrollo Web
zyb@rg 1 418 Último mensaje 30 Marzo 2005, 13:41
por MinusFour
problema con login en actionscript
Desarrollo Web
Eduardo G 0 390 Último mensaje 2 Abril 2007, 21:45
por Eduardo G
login evitar login otras personas
Desarrollo Web
blathorlei 13 2,080 Último mensaje 19 Octubre 2007, 16:27
por SERBice
problema login con vsftpd
Redes
thedoctor77 8 3,765 Último mensaje 20 Septiembre 2011, 21:12
por sanreikaj
Powered by SMF 1.1.19 | SMF © 2006-2008, Simple Machines