elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Top 20 herramientas Hacking más populares de 2020


  Mostrar Mensajes
Páginas: [1]
1  Comunicaciones / Redes / Re: [Dudas] Preguntas básicas de redes en: 8 Septiembre 2011, 14:19 pm
Hola, muchas gracias por aclararme las dudas!

Yo creía que aunque estés en una empresa el siguiente salto siempre iba a ser el POP del ISP, y que la función de enrutamiento solo servía entre las conexiones de dispositivos rápidos que hay en los ISP y entre estos.
2  Comunicaciones / Redes / [Dudas] Preguntas básicas de redes en: 8 Septiembre 2011, 11:43 am
Buenas!
Tengo algunas dudas de redes que no puedo aclarar, a ver si alguno puede responderme alguna:

1) Por qué para conectarme a internet mis datos tienen que pasar por un ISP?

Mi teoría es que los cables de teléfono que salen de mi casa y van por los postes de luz no se conectan a internet, terminan en "algún lugar".

2) La sesión PPPoE la realiza el modem que está incluído en mi "modem/router", no? bueno, adonde envía mi user y pass? a un POP? a un router? a un modem? a un DSLAM?

3) Si la sesión PPP se realiza sin tener una dirección IP, como hace el "aparato" del ISP (pop, o modem, o router, o dslam) para responder a la petición de mi módem?

Me dijeron que se podían intercambiar datos entre mi modem y el "otro aparato" porque estoy "fisicamente conectado a ese aparato". Esto quiere decir que el cable de telefono de mi casa termina en ese aparato sin ningun dispositivo de por medio? (como un router u otro dispositivo).

4) Si un router se encarga de enrutar los datos al mejor siguiente salto, para que sirve tener un router si total el siguiente salto SIEMPRE va a ser el dispositivo del ISP? osea, el siguiente salto de mi modem/router es siempre el mismo, la dirección 200.3.60.10 de arnet.

5) De mi pc a mi modem/router se usa el protocolo de capa 2 Ethernet, de mi router al router de arnet se usa PPP, y del router de arnet al siguiente router, que protocolo?

6) Hay un solo siguiente salto por interfaz del router? o puede haber 2 siguientes saltos para una misma interfaz?

Bueno creo que esas son todas mis dudas, si pueden ayudarme se los agradecería mucho.
3  Foros Generales / Foro Libre / Que carrera pensás que se complementa con el ccna y el mcitp? en: 5 Febrero 2011, 11:34 am
Hola a todos, estoy por empezar a el ccna y el mcitp y quisiera saber que carrera universitaria se complemente perfectamente con estas dos certificaciones (que no sean ingenierías).

Ya que tengo pensado certificarme este año y el año que viene empezar en la universidad y trabajar.

Opinen, saludos y gracias   :P
4  Programación / Programación General / Re: Podrían revisar este pseudocodigo ne busca de errores? en: 31 Mayo 2010, 22:45 pm

OLVIDABA EL ENUNCIADO:

Se pide hacer un programa en el cual se permita el ingreso de números. Se pide que el mismo muestre por pantalla todos aquellos Números apocalípticos.
Por fin de proceso, se pide que se muestre
a)   El promedio de los números apocalípticos impares.
b)   Un ranking de los 10 números apocalípticos pares más grandes ingresados ordenados en forma ascendente.


Numero apocalíptico: todo numero natural que 2^n da como resultado un numero que contiene tres 6 sucesivos, por eejmplo: 2^157=  1.82687704666... por lo tanto, 157, es un número apocalíptico
5  Programación / Programación General / Podrían revisar este pseudocodigo ne busca de errores? en: 31 Mayo 2010, 22:41 pm
NOTA: Si ven espacios vacios es porqe no aparece la asignacion (=  o <--)

Pseudocódigo
Algoritmo Principal:

INICIO
         Asignar.valor.par.impar.CE.suma (par, impar, CE, Suma = entero)
         Revisar.fin.datos (haydatos = bolean)
         MIENTRAS (continuar) HACER
                   Obtener.num (num=entero)
                   SI es.apocaliptico (num) entonces
                             MOSTRAR (num, “es apocalíptico”)
                             SI es.par (num) entonces
                                       Par        par + 1
                                       Llenar.arreglo (a=tarrent)
                             SINO
                                       CE            CE + 1
                   SINO
                               MOSTRAR (num, “no es apocalíptico”)
           Revisar.fin.datos (continuar = bolean)
           FINMIENTRAS
          PROCEDIMIENTO promedio ( suma, promedio: Entero ;  CE: VALOR)
           MOSTRAR (“el promedio de apocalípticos impares es”, promedio)         
          ordenar.arreglo.des (a=tarrent ; i , par=entero)
                 MOSTRAR  ( “los 10 Números pares mayores en forma ascendente son ”)
                   PARA  ( i = 1  hasta  10)
                            MOSTRAR ( a )
                   FINPARA
FIN

PROCEDIMIENTO Revisar.fin.datos (REF haydatos = boleano)
                   REPETIR
                              MOSTRAR (“Desea Ingresar datos? (s/n)”)
                               INGRESAR (respuesta)
                    HASTA QUE (respuesta = “s”) o (respuesta = “n”)
                    SI (respuesta = “s”)  entonces
                                haydatos        verdadero
                    SINO
                                Haydatos         Falso
                    FINSI
FINPROCEDIMIENTO
                               
Variables Locales:  Respuesta (caracter)
Precondiciones: ---- (No hay datos de entrada)
Pos Condiciones: A continuar se le asigna verdadero si el usuario ingresa “s”, sino, si ingresa “n”, continuar se le asigna falso.



PROCEDIMIENTO obtener.num (REF num = entero)
                      MOSTRAR (“Ingrese un número”)
                       INGRESAR (num)
FINPROCEDIMIENTO

Variables Locales: ----
Precondiciones: ----
Pos condiciones: Pide al usuario ingresar un número

PROCEDIMIENTO Asignar.valor.par.impar.CE.suma (REF par, impar, CE, suma = entero)
              Par         0
              Impar        0
              CE           0
              Suma         0
FINPROCEDIMIENTO

Variables Locales: ----
Precondiciones: ----
Pos Condiciones: Se le asigna 0 a las variables Par, Impar, CE y suma
                 


FUNCIÓN es.par (VALOR num = entero) = Booleano
                 SI (num resto 2 = 0) entonces
                             Es         verdadero
                 SINO
                             Es         Falso
                 FINSI
           DEVOLVER (Es)
FINFUNCIÓN

Variables Locales: Es (Booleano)
Pre condiciones: ---
Pos condiciones: Es toma el valor verdadero si el número dividido 2 da resto 0, sino, Es es falso


FUNCIÓN es.epocalíptico (VALOR num = entero) = booleano
             Cont           0
             a          1
             MIENTRAS cont < num HACER
                              a           a * 2
                              Cont            Cont + 1
              FINMIENTRAS
              Cantseis           0
              Res           0
              MIENTRAS (a > 1) o (Cantseis < 3) HACER
                               Res            a resto 10
                               a         a div 10
                               SI(res = 6) entonces             
                                             Cantseis          cantseis + 1
                                SINO
                                              Cantseis         0
                                FINSI
               FINMIENTRAS
               SI ( cantseis = 3 ) entonces
                                Es          verdadero
               SINO
                                Es           falso
               FINSI
               DEVOLVER (Es)
FINFUNCION

Variables Locales:  Cont, Res, Cantseis, a = entero      ;      Es = Boleano
Pre condiciones: ---
Pos condiciones: “Es” toma el valor de verdadero si cantseis llega al valor 3, sino “Es” toma es valor de falso
PROCEDIMIENTO  llenar.arreglo  (REF a=tarrent ;  i=entero ; VALOR num, par=entero)
DIMENSIÓN  a[par]
 a           num         
FINPROCEDIMIENTO

Variables Locales = ---
Precondiciones = par >= 0
Pos Condiciones = Se dimensiona el arreglo a con la cantidad de apocalípticos pares, y después se introduce “num” en el arreglo.



PROCEDIMIENTO  ordenar.arreglo.des ( REF a=tarrent ; i = entero ; par=entero)         
          aux          0
         PARA ( i = 1  hasta  i < par ) HACER
                     PARA (x = 1  hasta   x < par) HACER
                                  SI ( a[i+1]  >  a
  • )  ENTONCES
                                             aux         a
                                             a         a
                                             a
  •             aux
                                  FINSI
                      FINPARA
           FINPARA
FINPROCEDIMIENTO

Variables Locales = X, aux : entero
Precondiciones = par>=0
Pos Condiciones = Se compara a con a
  • , si a es menor a a
    • , se cambian de lugar, sino, se pasa al siguiente elemento y se vuelven a comparar.

    PROCEDIMIENTO Promedio ( REF = suma, promedio : entero ;  VALOR =  CE: entero)
                         suma            suma + num
                         promedio           suma /CE
    FINPROCEDIMIENTO

    Variables Locales = ---
    Precondiciones = ---
    Pos Condiciones = La variable “suma” va tomando el valor de la suma de los “num” impares ingresados, y al final se obtiene el promedio dividiendo a “suma” por la cantidad de elementos impares, y se le asigna el valor a la variable “promedio”

    Gracias
6  Programación / Programación C/C++ / Por favor ayuda con esta simple pregunta de pseudocodigo? en: 26 Mayo 2010, 23:37 pm
Me dieron para hacer un t.p de informatica, donde a base de un enunciado yo tengo que hacer el "analisis" (objetivo, datos de entrada, datos de salida, precondiciones y lote de datos). El profesor me dijo que estaba todo bien, exepto el "lote de datos" ya que segun el "faltan lotes de datos"


El enunciado es el sig:
Se pide hacer un programa en el cual se permita el ingreso de números. Se pide que el mismo muestre por pantalla todos aquellos Números apocalípticos.
Por fin de proceso, se pide que se muestre
a)El promedio de los números apocalípticos impares.
b)Un ranking de los 10 números apocalípticos pares más grandes ingresados ordenados en forma ascendente.


yo hice un lote de datos donde puse estas columnas: numero ingresado, es apocaliptico?, es par, es impar, prom impares, rank 10 nº pares mas grandes.
y di muchos ejemplos de numeros.
Por que dice que faltan lotes de datos? (le intente preguntar pero estaba de mal humor y no me dio bola)
si alguien puede ayudarme con el lote de datos estaria muy agradecido!
7  Programación / Programación C/C++ / Re: Problema de Pseudocodigo, ayuda por favor en: 16 Mayo 2010, 22:51 pm
no sabia perdon!
lo que yo hice es esto:

inicio
       revisarFinDatos (continuar=boleano)
             mientras (continuar=verdadero) hacer
                    ingresar (num)
                    ant <-- num
                    ingresar (num)
                    act <-- num
                    si (act < ant) entonces
                           10 <--- ant

y hasta ahi llegue, gracias
             
8  Programación / Programación C/C++ / Problema de Pseudocodigo, ayuda por favor en: 16 Mayo 2010, 22:30 pm
Buenas tardes, tengo un problema con el siguiente algoritmo:

Desarrollar un programa que ingrese números, cuando el usuario no quiera ingresar mas numeros se muestren los 10 números MAS GRANDES ingresados ordenados ascendentemente

Si alguien puede ayudarme se lo agradezco, muchas gracias
Páginas: [1]
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines