elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Tutorial básico de Quickjs


  Mostrar Mensajes
Páginas: [1]
1  Comunicaciones / Redes / Error compilar squid 3 Debian 7 en: 28 Abril 2015, 18:09 pm
Buenas, estuve viendo por toda la red alguna forma para poder administrar el trafico https, el problema esta en que necesito limitar el streaming de youtube en la red que administro, con squid pude hacer maravillas menos eso (debo aclarar que recien estoy empezando a conocer Linux), y es por el https que pasa como un caño sin que squid lo vea, busque y busque y no encontre nada claro para recompilar el squid y pueda manejar https, les comento los 8 pasos que encontre y que me parecieron los mas entendibles:
 
 1) apt-get source squid3
 2) apt-get build-dep squid3
 3) apt-get install devscripts build-essential fakeroot cdbs libsasl2-dev libcppunit-dev libcap2-dev libexpat1-dev libxml2-dev libltdl-dev
 4) Editamos el archivo debian/rules, En la sección DEB_CONFIGURE_EXTRA_FLAGS tenemos que agregar las siguientes lineas:
 
 --enable-ssl \
 --with-open-ssl=/etc/ssl/openssl.cnf file \
 
 5) Ejecutar ./configure no debería devolver ningún error
 6) debuild -us -uc -b
 7) cd ..
 8) dpkg -i squid*.deb
 
 Con el paso 1 todo bien, pero cuando voy al paso 2 me sale este error:
 
 Leyendo lista de paquetes... Hecho
 Creando árbol de dependencias
 Leyendo la información de estado... Hecho
 Nota, seleccionando «libcap-dev» en lugar de «libcap2-dev»
 Los siguientes paquetes tienen dependencias incumplidas:
 build-essential : Depende: libc6-dev pero no va a instalarse o
 libc-dev
 Depende: gcc (>= 4:4.4.3) pero no va a instalarse
 Depende: g++ (>= 4:4.4.3) pero no va a instalarse
 cdbs : Depende: debhelper (>= 5.0.30) pero no va a instalarse
 comerr-dev : Depende: libc6-dev pero no va a instalarse o
 libc-dev
 Depende: libcomerr2 (= 1.41.12-4+deb6u2) pero 1.42.5-1.1 va a ser instalado
 libcap-dev : Depende: libcap2 (= 1:2.19-3) pero 1:2.22-1.2 va a ser instalado
 libexpat1-dev : Depende: libexpat1 (= 2.0.1-7+squeeze1) pero 2.1.0-1+deb7u1 va a ser instalado
 Depende: libc6-dev pero no va a instalarse o
 libc-dev
 libkrb5-dev : Depende: krb5-multidev (= 1.8.3+dfsg-4squeeze9) pero no va a instalarse
 libldap2-dev : Depende: libldap-2.4-2 (= 2.4.23-7.3+deb6u1) pero 2.4.31-1+nmu2 va a ser instalado
libltdl-dev : Depende: libltdl7 (= 2.2.6b-2) pero 2.4.2-1.1 va a ser instalado
 libpam0g-dev : Depende: libpam0g (= 1.1.1-6.1+squeeze1) pero 1.1.3-7.1 va a ser instalado
 Depende: libc6-dev pero no va a instalarse o
 libc-dev
 libsasl2-dev : Depende: libsasl2-modules (= 2.1.23.dfsg1-7) pero 2.1.25.dfsg1-6+deb7u1 va a ser instalado
 Depende: libc6-dev pero no va a instalarse
 libxml2-dev : Depende: libxml2 (= 2.7.8.dfsg-2+squeeze11) pero 2.8.0+dfsg1-7+nmu2 va a ser instalado
 E: No se pudieron satisfacer las dependencias de construcción de squid3.
 
 
 Que estoy haciendo mal? agradeceria cualquier aporte, muchas gracias.
Páginas: [1]
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines