elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Recuerda que debes registrarte en el foro para poder participar (preguntar y responder)


  Mostrar Temas
Páginas: [1]
1  Foros Generales / Dudas Generales / Transmision EDI por X400 en: 21 Enero 2013, 16:20 pm
Buenas señores,
Necesito que cualquiera que tenga la mas minima nocion de esto me comente cosas, os pongo en situacion.
En mi oficina yo soy el que normalmente hace todos los programas EDI, se forma un consejo y acordamos el formato y el protocolo de transmision, normalmente ftp.
Ahora me toca trabajar con una empresa Checa y me pide que utilicemos el formato Standar EDI que es por transmision X400 de la informacion... ni decir tiene que es la primera vez que oigo hablar de esto, asi que estoy bastante perdido.

Si alguno me puede dar alguna orientacion, ya sea en español o ingles le estare eternamente agradecido.

Gracias por adelantado.
2  Programación / Bases de Datos / registros alterados comparando 2 tablas en: 24 Septiembre 2012, 12:16 pm
hola gente,
Lo que estoy buscando es comparar 2 tablas, las 2 tienen un ID identico, y lo que quiero es comparar el resto de campos para que me devuelva los registros que han cambiado en cualquiera de sus campos.
si ha cambiado tan solo 1 campo ha de salir.

no busco registros que esten en una tabla y en la otra no, si no registros que esten en las 2 tablas y sean diferentes.

¿alguien se le ocurre algo?

yo sigo dandole vueltas a ver que saco.
3  Programación / Scripting / [Python] problemas con las listas linkeadas... en: 12 Abril 2012, 16:11 pm
Vamos a ver, estoy ultimando una transmision EDI de facturas y hay un detalle que me esta trallendo de cabeza, voy a ir poniendo cada parte del codigo.
Primero tenemos una lista con listas anidadas:
Código
  1. [sup]Form119 = [['119',  1,       3,     'A'],
  2.          [None,    4,       3,     'A'],
  3.          [None,    7,       13,    'A'],
  4.          [None,    20,      35,    'A'],
  5.          [None,    55,      35,    'A'],
  6.          [None,    90,      35,    'A'],
  7.          [None,    125,     35,    'A'],
  8.          [None,    160,     35,    'A'],
  9.          [None,    195,     35,    'A'],
  10.          [None,    230,     9,     'A'],
  11.          [None,    239,     35,    'A'],
  12.          [None,    274,     3,     'A'],
  13.          [None,    277,     35,    'A'],
  14.          [None,    312,     35,    'A'],
  15.          [None,    347,     35,    'A'],
  16.          [None,    382,     35,    'A'],
  17.          [None,    417,     35,    'A'],
  18.          [None,    452,     20,    'A'],
  19.          [None,    472,     20,    'A'],
  20.          [None,    492,     20,    'A'],
  21.          [None,    512,     3,     'A'],
  22.          [None,    515,     35,    'A'],
  23.          [None,    550,     51,    'A']][/sup]

ahora tengo que rellenar unos campos y pasarlo a texto plano, esta lista sirve para mantener los formatos durante la construccion del mensaje.
aqui es donde se rellenan:
Código
  1. [sup]    def Build_119(self, Vfac):
  2.        Inv_Prt_BYDP = list(Form119)
  3.        Inv_Prt_IV = list(Form119)
  4.        Inv_Prt_SU = list(Form119)
  5.        Respuesta = list()
  6.        Datos = EG.con("""select C_ILN, C_NOM, C_DIR, C_DIRA, COD_CPO, C_POB,
  7.                            C_NIF, C_ILNZ, C_ZON, C_FPR, C_FCP, C_FPO
  8.                            from CLIENTES, VFACTURA
  9.                            where VFACTURA.COD_C = CLIENTES.COD_C
  10.                            and COD_VFA = '%s'""" % Vfac)
  11.        Inv_Prt_BYDP[2][0] = Datos[0][0]
  12.        Inv_Prt_BYDP[3][0] = Datos[0][1]
  13.        Inv_Prt_BYDP[6][0] = Datos[0][2]
  14.        Inv_Prt_BYDP[7][0] = Datos[0][3]
  15.        Inv_Prt_BYDP[9][0] = Datos[0][4]
  16.        Inv_Prt_BYDP[10][0] = Datos[0][5]
  17.        Inv_Prt_BYDP[11][0] = 'DE'
  18.        Inv_Prt_BYDP[14][0] = Datos[0][6]
  19.  
  20.        Inv_Prt_BY =list(Inv_Prt_BYDP)
  21.        Inv_Prt_BY[1][0] = 'BY'
  22.        Respuesta.append(self.The_Builder(Inv_Prt_BY))
  23.  
  24.        Inv_Prt_DP = list(Inv_Prt_BYDP)
  25.        Inv_Prt_DP[1][0] = 'DP'
  26.        Respuesta.append(self.The_Builder(Inv_Prt_DP))
  27.  
  28.        Inv_Prt_IV[1][0] = 'IV'
  29.        Inv_Prt_IV[2][0] = Datos[0][7]
  30.        Inv_Prt_IV[3][0] = Datos[0][8]
  31.        Inv_Prt_IV[6][0] = Datos[0][9]
  32.        Inv_Prt_IV[7][0] = ''
  33.        Inv_Prt_IV[9][0] = Datos[0][10]
  34.        Inv_Prt_IV[10][0] = Datos[0][11]
  35.        Inv_Prt_IV[11][0] = 'DE'
  36.        Inv_Prt_IV[14][0] = 'DE812706034'
  37.        Respuesta.append(self.The_Builder(Inv_Prt_IV))
  38.  
  39.        Datos = EG.con("""select C_ILN, C_NOM, C_DIR, C_DIRA, COD_CPO, C_POB, C_NIF
  40.                            from CLIENTES
  41.                            where COD_C = 'EURAL'""")
  42.  
  43.        Inv_Prt_SU[1][0] = 'SU'
  44.        Inv_Prt_SU[2][0] = Datos[0][0]
  45.        Inv_Prt_SU[3][0] = Datos[0][1]
  46.        Inv_Prt_SU[6][0] = Datos[0][2]
  47.        Inv_Prt_SU[7][0] = Datos[0][3]
  48.        Inv_Prt_SU[9][0] = Datos[0][4]
  49.        Inv_Prt_SU[10][0] = Datos[0][5]
  50.        Inv_Prt_SU[11][0] = 'DE'
  51.        Inv_Prt_SU[14][0] = Datos[0][6]
  52.        Respuesta.append(self.The_Builder(Inv_Prt_SU))
  53.  
  54.        return '\n'.join(Respuesta)[/sup]

actualmente esta funcionando, pero solo porque voy convirtiendo a texto cada vez que completo una de las copias, como veis al principio de la funcion declaro que 3 ojetos son iguales a la lista anteriormente puesta, pero al acabar la funcion, da igual como lo haga, tanto Form119, Inv_Prt_BYDP, Inv_Prt_IV, Inv_Prt_SU, Inv_Prt_BY y Inv_Prt_DP son identicas, es como si estubiese machando todo el rato Form119... ¿alguien me puede decir como coño me desago del maldito link de las listas? he hecho pruebas en el Pythonwin y supuestamente declarando list(Form119) se elimina el link y puedes madificar cada una por separado, sospecho que al tener listas anidadas hay algo que esta fallando... ¿alguna ayuda?



Elektro H@cker: Usa las etiquetas de código, que para algo están.
4  Programación / Desarrollo Web / ¿como declarar un iterable en una funcion en SQL? en: 31 Enero 2012, 18:42 pm
vamos a ver, esto parece muy facil pero no encuentro como solucionarlo, he creado una funcion sql que a la hora de consultarla queda asi:
Código:
select *  from dbo.GetFutStkSim('008', '2012-02-01 00:00:00', '2012-02-01 23:59:00',  '2012-01-31 00:00:00', '2012-01-31 23:59:00', '2012-01-18 00:00:00', '2012-01-18 23:59:00')

el hace un mogollon de consultas y devuelve el resultado, el asunto es que por necesidades, ahora necesito insertar una variable mas a la funcion, tiene que ser una lista tipo:
Código:
('cliente1', 'cliente2', 'cliente3')

el problema es que no se que tipo de variable tengo que declararle en la funcion para que me acepte este tipo de datos.
El motivo es que en ciertas consultas de la funcion quiero decirle que haga un:
Código:
and cod_cliente in @Tabla
PD: el tipo de variable table no vale por lo visto... ¿alguien sabria decirme algo? sino voy a tener que desmontar la funcion y seria un coñazo insufrible por una pequeña modificacion...

Gracias por adelantado
5  Programación / Scripting / Animacion web con Python... en: 19 Enero 2012, 16:09 pm
Buenas, estaba comentando un post y me ha surgido una duda... python, como lenguaje de interprete que es podria funcionar en la web si el navegador tuviese implementado el interprete... lo cual es una historia... pero la gente si tiene java, lo cual me hace llegar a la siguiente reflexion... si existe jython, que es un interprete de python que desarrollado en java, ¿no seria posible crear un 'adaptador' para pasar el codigo de pyhon como java? ¿ya existe? si es asi ¿como se llama?, si no ¿problemas de desarrolarlo?

Gracias por adelantado por vuestras aportaciones.
6  Informática / Electrónica / [APAD] pantalla rota repuesto diferente xD en: 13 Enero 2011, 17:21 pm
Bueno señores, explico un poco la situación, tengo un apad de china que desgraciadamente durante el desensamblaje perdió la pantalla táctil "perdida de rota xD " y aunque le compre un repuesto... no consigo conectarla de nuevo al puerto original... el cable es de esos planos que suelen llevar las pantallas o portátiles por dentro, es como una lamina de plástico fina con el circuito impreso, y el problema es que el repuesto tiene el cable por un lado en vez de por abajo como tenia el original y además el final del cable es mas ancho por lo que no encaja, así que quería saber si alguien sabe como lo puedo arreglar, porque me temo que si le meto estaño a eso se va a tostar el cable y solo conseguiré cargarme el repuesto.

si alguien tiene alguna solución para poder, aunque sea, unir ese cable a uno normal y soldar este directamente a la placa me haría un grandioso favor.

PD: no se si esto iría aquí o en electrónica... espero que el master tenga a bien moverlo si fuera el lugar equivocado.
7  Informática / Electrónica / regular la potencia de un motor electrico en: 10 Enero 2011, 10:51 am
Buenas, vereis estoy trasteando con motores y queria montarme un quadcoptero, como el ar. drone, que ya lo tengo :P pero me gustaria hacer uno con motores mas potentes, para que pueda levantar mas peso y poder usarlo como plataforma de diseño.

el caso es que necesito regular la velocidad a la que gira cada motor, y la verdad es que ando un poco perdido, ¿como lo puedo hacerlo con un señal digital?

vi este circuito...
http://www.superrobotica.com/S310110.htm
Pero me parece una p**a locura pagar ese precio por cada motor... asi que me preguntaba si algumo sabia como podria solventarlo de una forma mas economica.

Por cierto, motor de 9v a 12A, gobernado por circuito a 5v, ¿alguna idea de componentes?

PD: Me valen simplemente pista no necesito que me desarrolleis el circuito  :silbar:
Páginas: [1]
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines