elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Introducción a Git (Primera Parte)


  Mostrar Temas
Páginas: [1]
1  Programación / Scripting / [BATCH] Error al actualizar variable. en: 10 Diciembre 2018, 03:57 am
Buenas noches otra vez.

Otro batch que no acaba de funcionarme bien.
Quiero crear una estructura de carpetas donde aparecan los 12 meses del año, y dentro de ellas se creen tantas carpetas como dias tiene el mes.

Si que me he dado cuenta que no actualiza bien la variable Mes (Usada en :Folder). Siempre va un paso por detras del indice del FOR de inicio. (Linea 11)

El caso es que no se porque, me fallan los meses de Agosto y Septiembre.

Os dejo el codigo, y os dejo un fichero con la salida.

Muchas gracias.

- CODIGO -

@ECHO OFF

CLS

SETLOCAL ENABLEEXTENSIONS
SET me=%~n0
SET parent=%~dp0

SET AuxRuta=C:\Temp\Reports\Tacacs\2018

FOR /L %%i IN (1,1,12) DO (
   ECHO %me%: Parametros en llamada a Folder. Indice FOR: %%i Ruta: %AuxRuta%
   CALL :Folder %%i %AuxRuta%
)   
   
GOTO :EOF

: Folder
REM Parametros de entrada Mes en numero y Ruta.

SET Meses=JANUARY FEBRUARY MARCH APRIL MAY JUNE JULY AUGUST SEPTEMBER OCTOBER NOVEMBER DECEMBER

IF %1 GEQ 10 (
   SET Mes=%1
   ECHO %me%: El mes actual en numero es: %Mes%. Linea 26
    ECHO.
) ELSE (
   SET Mes=0%1
   ECHO %me%: El mes actual en numero es: %Mes%. Linea 30
    ECHO.
  )

FOR /F "Tokens=%Mes%" %%a IN ("%Meses%") DO (
   SET NOM_MES=%Mes%-%%a
   ECHO %me%: NOM_MES: %Mes%-%%a  Linea 36
   ECHO.


CD %2\%NOM_MES%
ECHO %me%: Parametros invocacion CrearCarpetaDia: %Mes% %2\%NOM_MES% Linea 41
ECHO.
ECHO %me%: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

IF %Mes%==01 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 31)
IF %Mes%==02 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 28)
IF %Mes%==03 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 31)
IF %Mes%==04 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 30)
IF %Mes%==05 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 31)
IF %Mes%==06 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 30)
IF %Mes%==07 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 31)
IF %Mes%==08 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 31)
IF %Mes%==09 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 30)
IF %Mes%==10 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 31)
IF %Mes%==11 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 30)
IF %Mes%==12 ( CALL :CrearCarpetaDia %Mes% %2\%NOM_MES% 31)

   
GOTO :EOF

:CrearCarpetaDia
REM Parametros de entrada: Mes, Ruta, dias del mes.
ECHO.
ECHO %me%: CrearCarpetaDia. Parametros %1 %2 %3
ECHO.
FOR /L %%j IN (1,1,%3) DO (
    IF %%j GEQ 10 (
      ECHO %me%: CreaCarpeta: %2\%%j-%1 Linea 68
   ) ELSE (
      ECHO %me%: CreaCarpeta: %2\0%%j-%1 Linea 70
      )       
)
ECHO.

GOTO :EOF


- SALIDA -

Test6: Parametros en llamada a Folder. Indice FOR: 1 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: . Linea 30

Test6: NOM_MES: 01-JANUARY  Linea 36

Test6: Parametros invocacion CrearCarpetaDia: 01 C:\Temp\Reports\Tacacs\2018\01-JANUARY Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 01 C:\Temp\Reports\Tacacs\2018\01-JANUARY 31

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\01-01 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\02-01 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\03-01 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\04-01 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\05-01 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\06-01 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\07-01 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\08-01 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\09-01 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\10-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\11-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\12-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\13-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\14-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\15-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\16-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\17-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\18-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\19-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\20-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\21-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\22-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\23-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\24-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\25-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\26-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\27-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\28-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\29-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\30-01 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\01-JANUARY\31-01 Linea 68

Test6: Parametros en llamada a Folder. Indice FOR: 2 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: 01. Linea 30

Test6: NOM_MES: 02-FEBRUARY  Linea 36

Test6: Parametros invocacion CrearCarpetaDia: 02 C:\Temp\Reports\Tacacs\2018\02-FEBRUARY Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 02 C:\Temp\Reports\Tacacs\2018\02-FEBRUARY 28

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\01-02 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\02-02 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\03-02 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\04-02 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\05-02 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\06-02 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\07-02 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\08-02 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\09-02 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\10-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\11-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\12-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\13-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\14-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\15-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\16-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\17-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\18-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\19-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\20-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\21-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\22-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\23-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\24-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\25-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\26-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\27-02 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\02-FEBRUARY\28-02 Linea 68

Test6: Parametros en llamada a Folder. Indice FOR: 3 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: 02. Linea 30

Test6: NOM_MES: 03-MARCH  Linea 36

Test6: Parametros invocacion CrearCarpetaDia: 03 C:\Temp\Reports\Tacacs\2018\03-MARCH Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 03 C:\Temp\Reports\Tacacs\2018\03-MARCH 31

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\01-03 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\02-03 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\03-03 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\04-03 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\05-03 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\06-03 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\07-03 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\08-03 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\09-03 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\10-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\11-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\12-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\13-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\14-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\15-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\16-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\17-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\18-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\19-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\20-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\21-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\22-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\23-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\24-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\25-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\26-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\27-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\28-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\29-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\30-03 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\03-MARCH\31-03 Linea 68

Test6: Parametros en llamada a Folder. Indice FOR: 4 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: 03. Linea 30

Test6: NOM_MES: 04-APRIL  Linea 36

Test6: Parametros invocacion CrearCarpetaDia: 04 C:\Temp\Reports\Tacacs\2018\04-APRIL Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 04 C:\Temp\Reports\Tacacs\2018\04-APRIL 30

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\01-04 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\02-04 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\03-04 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\04-04 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\05-04 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\06-04 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\07-04 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\08-04 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\09-04 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\10-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\11-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\12-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\13-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\14-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\15-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\16-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\17-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\18-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\19-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\20-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\21-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\22-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\23-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\24-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\25-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\26-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\27-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\28-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\29-04 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\04-APRIL\30-04 Linea 68

Test6: Parametros en llamada a Folder. Indice FOR: 5 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: 04. Linea 30

Test6: NOM_MES: 05-MAY  Linea 36

Test6: Parametros invocacion CrearCarpetaDia: 05 C:\Temp\Reports\Tacacs\2018\05-MAY Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 05 C:\Temp\Reports\Tacacs\2018\05-MAY 31

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\01-05 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\02-05 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\03-05 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\04-05 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\05-05 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\06-05 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\07-05 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\08-05 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\09-05 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\10-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\11-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\12-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\13-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\14-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\15-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\16-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\17-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\18-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\19-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\20-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\21-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\22-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\23-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\24-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\25-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\26-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\27-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\28-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\29-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\30-05 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\05-MAY\31-05 Linea 68

Test6: Parametros en llamada a Folder. Indice FOR: 6 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: 05. Linea 30

Test6: NOM_MES: 06-JUNE  Linea 36

Test6: Parametros invocacion CrearCarpetaDia: 06 C:\Temp\Reports\Tacacs\2018\06-JUNE Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 06 C:\Temp\Reports\Tacacs\2018\06-JUNE 30

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\01-06 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\02-06 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\03-06 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\04-06 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\05-06 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\06-06 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\07-06 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\08-06 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\09-06 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\10-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\11-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\12-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\13-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\14-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\15-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\16-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\17-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\18-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\19-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\20-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\21-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\22-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\23-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\24-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\25-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\26-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\27-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\28-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\29-06 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\06-JUNE\30-06 Linea 68

Test6: Parametros en llamada a Folder. Indice FOR: 7 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: 06. Linea 30

Test6: NOM_MES: 07-JULY  Linea 36

Test6: Parametros invocacion CrearCarpetaDia: 07 C:\Temp\Reports\Tacacs\2018\07-JULY Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 07 C:\Temp\Reports\Tacacs\2018\07-JULY 31

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\01-07 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\02-07 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\03-07 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\04-07 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\05-07 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\06-07 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\07-07 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\08-07 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\09-07 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\10-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\11-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\12-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\13-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\14-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\15-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\16-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\17-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\18-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\19-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\20-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\21-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\22-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\23-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\24-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\25-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\26-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\27-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\28-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\29-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\30-07 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\31-07 Linea 68

Test6: Parametros en llamada a Folder. Indice FOR: 8 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: 07. Linea 30

Test6: Parametros invocacion CrearCarpetaDia: 08 C:\Temp\Reports\Tacacs\2018\07-JULY Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 08 C:\Temp\Reports\Tacacs\2018\07-JULY 31

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\01-08 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\02-08 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\03-08 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\04-08 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\05-08 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\06-08 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\07-08 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\08-08 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\09-08 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\10-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\11-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\12-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\13-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\14-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\15-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\16-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\17-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\18-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\19-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\20-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\21-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\22-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\23-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\24-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\25-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\26-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\27-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\28-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\29-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\30-08 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\31-08 Linea 68

Test6: Parametros en llamada a Folder. Indice FOR: 9 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: 08. Linea 30

Test6: Parametros invocacion CrearCarpetaDia: 09 C:\Temp\Reports\Tacacs\2018\07-JULY Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 09 C:\Temp\Reports\Tacacs\2018\07-JULY 30

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\01-09 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\02-09 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\03-09 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\04-09 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\05-09 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\06-09 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\07-09 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\08-09 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\09-09 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\10-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\11-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\12-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\13-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\14-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\15-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\16-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\17-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\18-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\19-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\20-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\21-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\22-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\23-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\24-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\25-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\26-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\27-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\28-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\29-09 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\07-JULY\30-09 Linea 68

Test6: Parametros en llamada a Folder. Indice FOR: 10 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: 09. Linea 26

Test6: NOM_MES: 10-OCTOBER  Linea 36

Test6: Parametros invocacion CrearCarpetaDia: 10 C:\Temp\Reports\Tacacs\2018\10-OCTOBER Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 10 C:\Temp\Reports\Tacacs\2018\10-OCTOBER 31

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\01-10 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\02-10 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\03-10 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\04-10 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\05-10 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\06-10 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\07-10 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\08-10 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\09-10 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\10-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\11-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\12-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\13-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\14-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\15-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\16-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\17-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\18-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\19-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\20-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\21-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\22-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\23-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\24-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\25-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\26-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\27-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\28-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\29-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\30-10 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\10-OCTOBER\31-10 Linea 68

Test6: Parametros en llamada a Folder. Indice FOR: 11 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: 10. Linea 26

Test6: NOM_MES: 11-NOVEMBER  Linea 36

Test6: Parametros invocacion CrearCarpetaDia: 11 C:\Temp\Reports\Tacacs\2018\11-NOVEMBER Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 11 C:\Temp\Reports\Tacacs\2018\11-NOVEMBER 30

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\01-11 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\02-11 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\03-11 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\04-11 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\05-11 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\06-11 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\07-11 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\08-11 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\09-11 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\10-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\11-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\12-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\13-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\14-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\15-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\16-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\17-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\18-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\19-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\20-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\21-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\22-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\23-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\24-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\25-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\26-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\27-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\28-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\29-11 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\11-NOVEMBER\30-11 Linea 68

Test6: Parametros en llamada a Folder. Indice FOR: 12 Ruta: C:\Temp\Reports\Tacacs\2018
Test6: El mes actual en numero es: 11. Linea 26

Test6: NOM_MES: 12-DECEMBER  Linea 36

Test6: Parametros invocacion CrearCarpetaDia: 12 C:\Temp\Reports\Tacacs\2018\12-DECEMBER Linea 41

Test6: Folder. Invocamos a CrearCarpetaDia segun el numero de dias que tendran los meses en 2018. Linea 43

Test6: CrearCarpetaDia. Parametros 12 C:\Temp\Reports\Tacacs\2018\12-DECEMBER 31

Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\01-12 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\02-12 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\03-12 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\04-12 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\05-12 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\06-12 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\07-12 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\08-12 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\09-12 Linea 70
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\10-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\11-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\12-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\13-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\14-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\15-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\16-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\17-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\18-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\19-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\20-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\21-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\22-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\23-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\24-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\25-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\26-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\27-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\28-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\29-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\30-12 Linea 68
Test6: CreaCarpeta: C:\Temp\Reports\Tacacs\2018\12-DECEMBER\31-12 Linea 68




2  Programación / Scripting / [BATCH] Dudas varias en: 2 Diciembre 2018, 03:22 am

Buenas noches.

Estoy desarrollando una batch para que me genere unas determinadas carpetas en una rutas segun la tarea que me encomiende mi jefe.
Mi problema es que cada vez que ejecuto el batch, la primera vez siempre me da error, la segunda ya se completa correctamente (Bueno, aun me falta pulir detalles)

Y ahora mismo, me da el siguiente error
31 was unexpected at this time.

No entiendo que ayer funcionase, y hoy no.

Puede estar relacionado con el numero de lineas que llvo escritas?
Hay algun tamaño maximo (o recomendado) que haga que la ejecucion se vuelva inestable?


Un saludo

 :D
3  Programación / Scripting / [BATCH] Error al final de la ejecucion en: 3 Noviembre 2018, 17:21 pm
Buenas tardes a tod@s.

Estoy intentando crear un pedazo de codigo que me cree 12 carpetas, una para mes, pero al final de la ejecucion me da un error que me gustaria entender, para solucionarlo .

Os dejo el codigo:

@ECHO OFF

CLS
ECHO.
PUSHD C:\Temp
FOR /L %%i IN (1,1,12) DO ( CALL :Mes %%i)

: Mes

SET Meses=JANUARY FEBRUARY MARCH APRIL MAY JUNE JULY AUGUST SEPTEMBER OCTOBER NOVEMBER DECEMBER
ECHO Valor del parametro: %1
ECHO.
FOR /F "Tokens=%1" %%a IN ("%Meses%") DO (
   IF %1 GEQ 10 (
      ECHO  %1-%%a
      MKDIR %1-%%a
   ) ELSE (
      ECHO  0%1-%%a
      MKDIR 0%1-%%a
      )   
GOTO :EOF      
)
ECHO.
GOTO :EOF


Y ahora la salida que me da:

Valor del parametro: 1

 01-JANUARY
Valor del parametro: 2

 02-FEBRUARY
Valor del parametro: 3

 03-MARCH
Valor del parametro: 4

 04-APRIL
Valor del parametro: 5

 05-MAY
Valor del parametro: 6

 06-JUNE
Valor del parametro: 7

 07-JULY
Valor del parametro: 8

 08-AUGUST
Valor del parametro: 9

 09-SEPTEMBER
Valor del parametro: 10

 10-OCTOBER
Valor del parametro: 11

 11-NOVEMBER
Valor del parametro: 12

 12-DECEMBER
Valor del parametro:

10 was unexpected at this time.

C:\temp>


El caso es que no acabo de ver porque sale la linea que dice:
10 was unexpected at this time.

El texto que dice Valor del parametro es añadido mio para control. Al final no aparecera, ya que lo quitare.

Muchisimas gracias.


4  Comunicaciones / Redes / [Packet Tracer] IPSec Ike Phase 1 no funciona en: 24 Julio 2018, 12:51 pm
Buenos días a tod@s,

Primero que nada muchas gracias por entrar a leer.
Estoy preparando en CCNA Security, e intento utilizar el PT para resolver ejercicios.
El caso es que no soy capaz de hacer que dos routers usen IPSec, ni siquiera levantan la phase1, por lo que no soy capaz de crear el tunel para los datos.

He leido sobre si PT soporta IPSec o no, y sinceramente hay de todo un poco. En la versión 7 si que parece que se soporte, pero no estoy seguro.
En GNS3 no he intentado nada, porque tengo unos problemillas con el CRC de las imagenes, pero esto ya lo abrire en otro hilo, si no consigo resolverlo.

Os dejo el runn config de mis dos routers.

R1:
VLC#sh running-config
Building configuration...

Current configuration : 1380 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname VLC
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524O53M
license boot module c1900 technology-package securityk9
!
!
crypto isakmp policy 2
 encr aes 128
 hash md5
 authentication pre-share
 group 2
 lifetime 21600
!
crypto isakmp key cisco123 address 43.0.0.2
!
!
crypto ipsec transform-set VLC->LHR esp-aes 256 esp-sha-hmac
!
crypto map Airports 2 ipsec-isakmp
 set peer 43.0.0.2
 set pfs group2
 set security-association lifetime seconds 86400
 set transform-set VLC->LHR
 match address 100
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
 ip address 23.0.0.2 255.255.255.252
 duplex auto
 speed auto
 crypto map Airports
!
interface GigabitEthernet0/1
 ip address 10.0.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/0/0
 no ip address
 shutdown
!
interface Serial0/1/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 23.0.0.1
!
ip flow-export version 9
!
!
access-list 100 permit ip 10.0.1.0 0.0.0.255 172.16.0.0 0.0.0.255
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
end


VLC#

R2:


LHR#sh running-config
Building configuration...

Current configuration : 1412 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname LHR
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX15244PX1
license boot module c1900 technology-package securityk9
!
!
crypto isakmp policy 2
 encr aes 128
 hash md5
 authentication pre-share
 group 2
 lifetime 21600
!
crypto isakmp key cisco123 address 23.0.0.2
!
!
crypto ipsec transform-set LHR->VLC esp-aes 256 esp-sha-hmac
!
crypto map Airports 2 ipsec-isakmp
 set peer 23.0.0.2
 set pfs group2
 set security-association lifetime seconds 86400
 set transform-set LHR->VLC
 match address 100
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
 description TOWARDS-INTERNET
 ip address 43.0.0.2 255.255.255.252
 duplex auto
 speed auto
 crypto map Airports
!
interface GigabitEthernet0/1
 ip address 172.16.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/0/0
 no ip address
 shutdown
!
interface Serial0/1/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 43.0.0.1
!
ip flow-export version 9
!
!
access-list 100 permit ip 172.16.0.0 0.0.0.255 10.0.1.0 0.0.0.255
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
end

LHR#
Como veis no hay nada raro, solo la configuración de la IPSec.
Entre medias de los dos routers, tengo otro llamado Internet, que simula los posibles routers entre R1 y R2, por los cuales deberian pasar los paquetes. No tiene más que dos interfaces configurados, cada uno hacia uno de los routers, pero sin publicación de rutas de ninguna clase.

Muchas gracias !!


5  Comunicaciones / Redes / Simular DHCP en PT en: 28 Febrero 2015, 09:53 am
Buenos días a todos.
Primero que nada presentarme, ya que es la primera vez que escribo en el foro de comunicaciones.
Pues nada, estoy estudiando para el CCNA y tengo una duda acerca del funcionamiento DHCP de los routers cisco.
Bueno, o de la simulación en Packet Tracer.
Estoy haciendo un ejercicio de configuración en dos casos:
 a) El router R0 hace de DHCP de toda la red
 b) Un servidor de la lan del R0 hace de DHCP.

 Mi duda esta en el punto a)
 ¿Puede el router R0 hacer de DHCP para todo el diseño? En los ejemplos que he visto por Internet, y en la explicación del libro de Wendell Odom, solo habla de utilizar el helper-address en el caso de que el servidor dhcp no sea un router, pero no dice explícitamente que sea condición necesaria para utilizarlo.
 Siguiendo con esto, si no he entendido mal, el router que hace de dhcp solo puede serlo de su red local.

¿Estoy equivocado?

Muchisimas gracias.

PD: El punto b) lo tratare cuando resuelva el a)
6  Informática / Software / [ECLIPSE] - Resaltador de Sintaxis en: 1 Julio 2013, 17:13 pm
 Buenas tardes.

 Trasteando con el eclipse, para instalar el UML2, he 'roto' algo, y ahora Eclipse no activa el resaltador de sintaxis.
 ¿Os ha pasado a alguno de vosotros?

 Muchas gracias.
Páginas: [1]
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines