elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Top 20 herramientas Hacking más populares de 2020


  Mostrar Mensajes
Páginas: 1 [2]
11  Programación / Scripting / Re: [BATCH] Error al final de la ejecucion en: 3 Noviembre 2018, 18:48 pm
Repasando el codigo, me he dado cuenta que no habia puesto en GOTO :EOF detras del FOR.

He dejado el codigo tal que asi:


@ECHO OFF

CLS
ECHO.
PUSHD C:\Temp
FOR /L %%i IN (1,1,12) DO ( CALL :Mes %%i)
GOTO :EOF

: Mes

SET Meses=JANUARY FEBRUARY MARCH APRIL MAY JUNE JULY AUGUST SEPTEMBER OCTOBER NOVEMBER DECEMBER
FOR /F "Tokens=%1" %%a IN ("%Meses%") DO (
   IF %1 GEQ 10 (
      ECHO  %1-%%a
   REM   MKDIR %1-%%a
   ) ELSE (
      ECHO  0%1-%%a
   REM   MKDIR 0%1-%%a
      )         
)
GOTO :EOF


Y la salida me queda ahora como yo queria.



 01-JANUARY
 02-FEBRUARY
 03-MARCH
 04-APRIL
 05-MAY
 06-JUNE
 07-JULY
 08-AUGUST
 09-SEPTEMBER
 10-OCTOBER
 11-NOVEMBER
 12-DECEMBER

C:\temp>



12  Programación / Scripting / [BATCH] Error al final de la ejecucion en: 3 Noviembre 2018, 17:21 pm
Buenas tardes a tod@s.

Estoy intentando crear un pedazo de codigo que me cree 12 carpetas, una para mes, pero al final de la ejecucion me da un error que me gustaria entender, para solucionarlo .

Os dejo el codigo:

@ECHO OFF

CLS
ECHO.
PUSHD C:\Temp
FOR /L %%i IN (1,1,12) DO ( CALL :Mes %%i)

: Mes

SET Meses=JANUARY FEBRUARY MARCH APRIL MAY JUNE JULY AUGUST SEPTEMBER OCTOBER NOVEMBER DECEMBER
ECHO Valor del parametro: %1
ECHO.
FOR /F "Tokens=%1" %%a IN ("%Meses%") DO (
   IF %1 GEQ 10 (
      ECHO  %1-%%a
      MKDIR %1-%%a
   ) ELSE (
      ECHO  0%1-%%a
      MKDIR 0%1-%%a
      )   
GOTO :EOF      
)
ECHO.
GOTO :EOF


Y ahora la salida que me da:

Valor del parametro: 1

 01-JANUARY
Valor del parametro: 2

 02-FEBRUARY
Valor del parametro: 3

 03-MARCH
Valor del parametro: 4

 04-APRIL
Valor del parametro: 5

 05-MAY
Valor del parametro: 6

 06-JUNE
Valor del parametro: 7

 07-JULY
Valor del parametro: 8

 08-AUGUST
Valor del parametro: 9

 09-SEPTEMBER
Valor del parametro: 10

 10-OCTOBER
Valor del parametro: 11

 11-NOVEMBER
Valor del parametro: 12

 12-DECEMBER
Valor del parametro:

10 was unexpected at this time.

C:\temp>


El caso es que no acabo de ver porque sale la linea que dice:
10 was unexpected at this time.

El texto que dice Valor del parametro es añadido mio para control. Al final no aparecera, ya que lo quitare.

Muchisimas gracias.


13  Comunicaciones / Redes / Re: [Packet Tracer] IPSec Ike Phase 1 no funciona en: 24 Julio 2018, 13:30 pm
Me respondo yo solo .....
En la configuración de la phase1, habia puesto AES 128, mientras que en la phase2, tenia AES 256.
Cambiando el AES 128 por 256 se soluciona el problema.

Fallo mio por no tener en cuenta ese detalle.

Saludos !!!
14  Comunicaciones / Redes / [Packet Tracer] IPSec Ike Phase 1 no funciona en: 24 Julio 2018, 12:51 pm
Buenos días a tod@s,

Primero que nada muchas gracias por entrar a leer.
Estoy preparando en CCNA Security, e intento utilizar el PT para resolver ejercicios.
El caso es que no soy capaz de hacer que dos routers usen IPSec, ni siquiera levantan la phase1, por lo que no soy capaz de crear el tunel para los datos.

He leido sobre si PT soporta IPSec o no, y sinceramente hay de todo un poco. En la versión 7 si que parece que se soporte, pero no estoy seguro.
En GNS3 no he intentado nada, porque tengo unos problemillas con el CRC de las imagenes, pero esto ya lo abrire en otro hilo, si no consigo resolverlo.

Os dejo el runn config de mis dos routers.

R1:
VLC#sh running-config
Building configuration...

Current configuration : 1380 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname VLC
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524O53M
license boot module c1900 technology-package securityk9
!
!
crypto isakmp policy 2
 encr aes 128
 hash md5
 authentication pre-share
 group 2
 lifetime 21600
!
crypto isakmp key cisco123 address 43.0.0.2
!
!
crypto ipsec transform-set VLC->LHR esp-aes 256 esp-sha-hmac
!
crypto map Airports 2 ipsec-isakmp
 set peer 43.0.0.2
 set pfs group2
 set security-association lifetime seconds 86400
 set transform-set VLC->LHR
 match address 100
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
 ip address 23.0.0.2 255.255.255.252
 duplex auto
 speed auto
 crypto map Airports
!
interface GigabitEthernet0/1
 ip address 10.0.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/0/0
 no ip address
 shutdown
!
interface Serial0/1/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 23.0.0.1
!
ip flow-export version 9
!
!
access-list 100 permit ip 10.0.1.0 0.0.0.255 172.16.0.0 0.0.0.255
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
end


VLC#

R2:


LHR#sh running-config
Building configuration...

Current configuration : 1412 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname LHR
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX15244PX1
license boot module c1900 technology-package securityk9
!
!
crypto isakmp policy 2
 encr aes 128
 hash md5
 authentication pre-share
 group 2
 lifetime 21600
!
crypto isakmp key cisco123 address 23.0.0.2
!
!
crypto ipsec transform-set LHR->VLC esp-aes 256 esp-sha-hmac
!
crypto map Airports 2 ipsec-isakmp
 set peer 23.0.0.2
 set pfs group2
 set security-association lifetime seconds 86400
 set transform-set LHR->VLC
 match address 100
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
 description TOWARDS-INTERNET
 ip address 43.0.0.2 255.255.255.252
 duplex auto
 speed auto
 crypto map Airports
!
interface GigabitEthernet0/1
 ip address 172.16.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/0/0
 no ip address
 shutdown
!
interface Serial0/1/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 43.0.0.1
!
ip flow-export version 9
!
!
access-list 100 permit ip 172.16.0.0 0.0.0.255 10.0.1.0 0.0.0.255
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
end

LHR#
Como veis no hay nada raro, solo la configuración de la IPSec.
Entre medias de los dos routers, tengo otro llamado Internet, que simula los posibles routers entre R1 y R2, por los cuales deberian pasar los paquetes. No tiene más que dos interfaces configurados, cada uno hacia uno de los routers, pero sin publicación de rutas de ninguna clase.

Muchas gracias !!


15  Comunicaciones / Redes / Re: Simular DHCP en PT en: 21 Abril 2015, 17:28 pm
Si puedes tener el servidor de DHCP en otro segmento de broadcast. Solo que en los segmentos que no este el servidor DHCP vas a tener que usar ip address-helper para hacer referencia a donde esta el servidor DHCP.

Muchas gracias por la respuesta.
Respecto a hacer que un router ejecute ip helper-address para direccionar hacia otro router, lo revise bien y creo que no merece la pena. No se si se podrá hacer o no, pero en packet tracer no me dejo, y al final desistí. Configure DHCP en cada router, y solucione el problema.

En cuanto a los de los diferentes segmentos de red, el servidor DHCP y el ip helper-addres, funciono a la primera.

Lo dicho, muchas gracias por la respuesta, y perdona por el retraso al contestar.
16  Comunicaciones / Redes / Re: Simular DHCP en PT en: 2 Marzo 2015, 16:38 pm
Buenas tardes a todos.
He estado el fin de semana leyendo un poco acerca del tema, y parece ser que un router solo puede hacer de DHCP para sus propias LAN, pero no para una LAN remota.

El punto b) que os comente no me ha dado problemas, incluso después de hacerlo con rutas estáticas, las he quitado y activado el ospf y ha funcionado todo bien, y a la primera.

Un saludo.

 :D
17  Comunicaciones / Redes / Simular DHCP en PT en: 28 Febrero 2015, 09:53 am
Buenos días a todos.
Primero que nada presentarme, ya que es la primera vez que escribo en el foro de comunicaciones.
Pues nada, estoy estudiando para el CCNA y tengo una duda acerca del funcionamiento DHCP de los routers cisco.
Bueno, o de la simulación en Packet Tracer.
Estoy haciendo un ejercicio de configuración en dos casos:
 a) El router R0 hace de DHCP de toda la red
 b) Un servidor de la lan del R0 hace de DHCP.

 Mi duda esta en el punto a)
 ¿Puede el router R0 hacer de DHCP para todo el diseño? En los ejemplos que he visto por Internet, y en la explicación del libro de Wendell Odom, solo habla de utilizar el helper-address en el caso de que el servidor dhcp no sea un router, pero no dice explícitamente que sea condición necesaria para utilizarlo.
 Siguiendo con esto, si no he entendido mal, el router que hace de dhcp solo puede serlo de su red local.

¿Estoy equivocado?

Muchisimas gracias.

PD: El punto b) lo tratare cuando resuelva el a)
18  Informática / Software / Re: [ECLIPSE] - Resaltador de Sintaxis en: 3 Julio 2013, 18:59 pm
Ya he dado con la tecla. Resulta que hice mal la instalación de los modulos para UML2, y jodi el java editor.
Total, borrar completamente, incluidos el workspace y la carpeta .eclipse, y reinstalar desde cero.

 Saludos
19  Informática / Software / [ECLIPSE] - Resaltador de Sintaxis en: 1 Julio 2013, 17:13 pm
 Buenas tardes.

 Trasteando con el eclipse, para instalar el UML2, he 'roto' algo, y ahora Eclipse no activa el resaltador de sintaxis.
 ¿Os ha pasado a alguno de vosotros?

 Muchas gracias.
Páginas: 1 [2]
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines