Foro de elhacker.net

Seguridad Informática => Hacking Básico => Mensaje iniciado por: Depredador en 17 Mayo 2020, 02:17



Título: Problema con nmap
Publicado por: Depredador en 17 Mayo 2020, 02:17
Hola, miren quiero experimentar un poco hackeado con las herramientas de shadowbokers (básicamente hackear windows 7). Bueno hasta aquí todo bien, però esq quiero hacer todos los pasos empezando por escanear la red con nmap -sP 192.168.0.1/24 (mi máquina Windows 7 está en la red, la máquina esta en VMware) bueno el problema esq no veo ninguna ip que sea del Windows 7 al hacer el scan si alguien sabe el problema o me da alguna recomendación para poder practicar.

PD: cual era El script de nmap para saber el sistema operativo que está usando o directamente con un scan os (nmap -O 192.168.x.x) ya me sale el sistema operativo, creo que se necessitava el puerto 445 abierto. :o

Saludos! :rolleyes:


Título: Re: Problema con nmap
Publicado por: rub'n en 17 Mayo 2020, 06:01
Hola, miren quiero experimentar un poco hackeado con las herramientas de shadowbokers (básicamente hackear windows 7). Bueno hasta aquí todo bien, però esq quiero hacer todos los pasos empezando por escanear la red con nmap -sP 192.168.0.1/24 (mi máquina Windows 7 está en la red, la máquina esta en VMware) bueno el problema esq no veo ninguna ip que sea del Windows 7 al hacer el scan si alguien sabe el problema o me da alguna recomendación para poder practicar.

PD: cual era El script de nmap para saber el sistema operativo que está usando o directamente con un scan os (nmap -O 192.168.x.x) ya me sale el sistema operativo, creo que se necessitava el puerto 445 abierto. :o

Saludos! :rolleyes:

La ip de tu VMWARE debes poder verla, si dudas, usa ipconfig dentro de la cmd del win 7 en Vmware

Luego haz ese scan de nuevo con NMAP y en el output busca esa ip


Título: Re: Problema con nmap
Publicado por: Depredador en 17 Mayo 2020, 12:28
Eso ya lo hice mira: https://youtu.be/GZNTEhqubA8   :o


Título: Re: Problema con nmap
Publicado por: rub'n en 17 Mayo 2020, 13:03
Eso ya lo hice mira: https://youtu.be/GZNTEhqubA8   :o

Has esto en kali

Código
  1. nmap -T4 -F 192.168.235.2/24

Código
  1. nmap -sP 192.168.235.2/24

Escanea toda la red, en base la puerta de enlace predeterminada de tu router. que creo que es 192.168.235.2 o 192.168.235.1


Título: Re: Problema con nmap
Publicado por: EdePC en 17 Mayo 2020, 13:17
No están en la misma Red, lo normal es configurar las máquinas virtuales como Bridge o Puente.

Al final tu máquina virtual y tu real deberían de estar en la misma red: 192.168.1.x

Luego puedes hacer un "ping" con el nmap a la red asi (solo busca, no escanea puertos):

sudo nmap -sn 192.168.1.0/24

Te recomendaría tener a mano el nmap cheat-sheet: http://share.ialab.dsu.edu/CRRC/Red%20Team/NmapCheatSheetv1.1.pdf


Título: Re: Problema con nmap
Publicado por: Depredador en 17 Mayo 2020, 14:37
Se supone que he de configurar la network de la maquina virtual?
http://imgfz.com/i/NbwVEuv.png


Título: Re: Problema con nmap
Publicado por: rub'n en 17 Mayo 2020, 14:42
Se supone que he de configurar la network de la maquina virtual?
http://imgfz.com/i/NbwVEuv.png

Si, ahi lo tienes en NAT, elige bridge o puente, para que ambas maquinas este en el mismo pool de ip por el DHCP.


Puedes escanear tambien a tu maquina host, es decir donde tienes instalado el soft Vmware

Y ojo, por lo que veo, tanto win 7 y kali en ese video ambas estaban en la misma red. no se si ambas las tenias en NAT, cuando iniciaste la publicación.


Título: Re: Problema con nmap
Publicado por: Depredador en 17 Mayo 2020, 15:00
Pero digamos que ahora tengo el puente, ok, para conectarme a internet necessito un wirless adapter con el bridge para poderme conectar a internet. Si conecto el wirless a una máquina necessitare dos wirless para poder tener conexión en las dos máquinas virtuales?
 :rolleyes:
Saludos!


Título: Re: Problema con nmap
Publicado por: EdePC en 17 Mayo 2020, 15:18
En modo Puente las máquinas virtuales consiguen estar en la misma Red que el PC real como si fueran otras PC reales. Si la PC real tiene conexión a Internet entonces las virtuales también porque utilizan el mismo adaptador de red del PC real para conectarse al Router Local.


Título: Re: Problema con nmap
Publicado por: Depredador en 17 Mayo 2020, 15:44
Es que no me funciona observa: https://youtu.be/P9GHUkCpqKI


Título: Re: Problema con nmap
Publicado por: EdePC en 17 Mayo 2020, 17:18
Kali suele ser bastante terco cuando está instalado XD, por eso prefiero usarlo siempre como LiveCD. Tienes que hacer los pasos básicos:

1. Comprobar como anda tu Adaptador de Red con ifconfig, ver si esta UP y RUNNING, si tiene una IP válida, etc
2. Reiniciar tus servicios de red: sudo service networking restart y/o sudo service network-manager restart
3. Darle down y luego up a tu adaptador de red
4. Revisar tu cliente DHCP o configurar una IP fija


Título: Re: Problema con nmap
Publicado por: MinusFour en 17 Mayo 2020, 17:33
Las maquinas virtuales estaban en la misma subred, no estoy seguro si estaban en el mismo segmento de red pero probablemente sí. ¿Quieres que tu VM vea tu host y a otros equipos de tu subred?

Sin poder ver las tramas que pasan por Kali es difícil de saber que es lo que esta pasando. Yo usaría wireshark para ver que es lo que esta pasando en la interface de red y encontrar el problema pero eso ya es un poco más complicado. La documentación de VMWare Workstation dice que si soporta hacer puentes de dispositivos inalambricos pero depende de tu versión de VMware (y a menos que estes usando una versión antigua de VMware debería funcionar).

Yo diría que es un problema de seguridad con tu router o quizás el puente no está configurado correctamente. En el menu de Edit, debe haber una opción que diga Virtual Network Editor. Ahí puedes configuar cada una de las interfaces virtuales que crea VMware. Selecciona la red que usa bridge (VMNet0, creo que es la que es por defecto) y en "Bridge To" selecionas la interface que usa tu dispositivo wireless.

Podría ser un problema en capa 3, dependiendo de tu configuración del router. Como estás usando una interface wireless también recomendaría que replicaras el estado físico de la red (el checkbox que no has marcado debajo de la opción para ponerlo en puente).


Título: Re: Problema con nmap
Publicado por: rub'n en 17 Mayo 2020, 17:40
Instale tambien vmware con kali 2.0 y mismo error  :rolleyes: , que drama para usar kali con internet, sin embargo cosa que no me pasa con virtualbox ultima version.

Virtual box rules!!!


incluso recomiendan modificar, y probe pero nada  :¬¬

* sudo nano /etc/resolv.conf y colocacar los dns de google 8.8.8.8 / 8.8.4.4
* https://www.kali.org/docs/general-use/kali-linux-sources-list-repositories/  Mucho drama.
* Proxy ninguno, o si lo está, que funcione.


Título: Re: Problema con nmap
Publicado por: Depredador en 18 Mayo 2020, 13:25
Las maquinas virtuales estaban en la misma subred, no estoy seguro si estaban en el mismo segmento de red pero probablemente sí. ¿Quieres que tu VM vea tu host y a otros equipos de tu subred?

Sin poder ver las tramas que pasan por Kali es difícil de saber que es lo que esta pasando. Yo usaría wireshark para ver que es lo que esta pasando en la interface de red y encontrar el problema pero eso ya es un poco más complicado. La documentación de VMWare Workstation dice que si soporta hacer puentes de dispositivos inalambricos pero depende de tu versión de VMware (y a menos que estes usando una versión antigua de VMware debería funcionar).

Yo diría que es un problema de seguridad con tu router o quizás el puente no está configurado correctamente. En el menu de Edit, debe haber una opción que diga Virtual Network Editor. Ahí puedes configuar cada una de las interfaces virtuales que crea VMware. Selecciona la red que usa bridge (VMNet0, creo que es la que es por defecto) y en "Bridge To" selecionas la interface que usa tu dispositivo wireless.

Podría ser un problema en capa 3, dependiendo de tu configuración del router. Como estás usando una interface wireless también recomendaría que replicaras el estado físico de la red (el checkbox que no has marcado debajo de la opción para ponerlo en puente).
A mi el bridge en VBox me va perfectamente...  :-\
Y ahora por mucho bridge que haya puesto en el widnows 7 en VBox, des de VMware no me detecta la ip del Windows 7 al hacer el escaneo con nmap me detecta todas las ip menos la del Win 7. Voy a probar a instalar el kali en el VBox y haber que pasa... Una gran decepción VMware...  :( Para que vean: https://youtu.be/6ksAYvQbIL8
Bueno ni con VBox me sale la ip al hacer el scan... :( me pasa lo mismo que en el video.


Título: Re: Problema con nmap
Publicado por: MinusFour en 18 Mayo 2020, 15:46
¿En primer lugar, puedes hacer ping al equipo?

Código
  1. nmap -sn -PE 192.168.1.0/24

¿Esto te funciona?