Foro de elhacker.net

Programación => Java => Mensaje iniciado por: K-YreX en 5 Abril 2020, 06:58



Título: Problema WindowBuilder (Eclipse) - Ventana Cortada
Publicado por: K-YreX en 5 Abril 2020, 06:58
El tema es que he instalado WindowBuilder en Eclipse para trabajar de forma gráfica y a la hora de utilizar la pestaña Design (que muestra la ventana con sus componentes), ésta aparece cortada. El lateral derecho se corta y no llegan a verse los botones de minimizar, maximizar y cerrar.
Además si agrando la ventana, los botones desaparecen completamente mientras que si la reduzco de tamaño se ven parcialmente.

He probado también a añadir un botón para ver si eso afecta al posicionamiento de los elementos y de momento parece que no pero de todas formas resulta molesto y me gustaría poder arreglarlo. Dejo una imagen para que se vea más claro lo que explico.
(https://imageshack.com/i/pnUqnRF5p)

He probado varias versiones de Eclipse (4.15.0 2020-03 y 4.14.0 2019-12), varias versiones de WindowBuilder (la última y una anterior) y varios sistemas operativos (Ubuntu 18.04 y Windows 10) y el problema es el mismo siempre. También cambié los valores de xms y xmx del fichero eclipse.ini porque aparecía cierto lag al trabajar con ello y actualmente los tengo como estaban por defecto:
Código:
-Xms256m
-Xmx2048m

PD: Todo ello utilizando jdk-11.


Título: Re: Problema WindowBuilder (Eclipse) - Ventana Cortada
Publicado por: rub'n en 12 Abril 2020, 14:00
El tema es que he instalado WindowBuilder en Eclipse para trabajar de forma gráfica y a la hora de utilizar la pestaña Design (que muestra la ventana con sus componentes), ésta aparece cortada. El lateral derecho se corta y no llegan a verse los botones de minimizar, maximizar y cerrar.
Además si agrando la ventana, los botones desaparecen completamente mientras que si la reduzco de tamaño se ven parcialmente.

He probado también a añadir un botón para ver si eso afecta al posicionamiento de los elementos y de momento parece que no pero de todas formas resulta molesto y me gustaría poder arreglarlo. Dejo una imagen para que se vea más claro lo que explico.
(https://imageshack.com/i/pnUqnRF5p)

He probado varias versiones de Eclipse (4.15.0 2020-03 y 4.14.0 2019-12), varias versiones de WindowBuilder (la última y una anterior) y varios sistemas operativos (Ubuntu 18.04 y Windows 10) y el problema es el mismo siempre. También cambié los valores de xms y xmx del fichero eclipse.ini porque aparecía cierto lag al trabajar con ello y actualmente los tengo como estaban por defecto:
Código:
-Xms256m
-Xmx2048m

PD: Todo ello utilizando jdk-11.

Que tal doc?

No uso eclipse pero,

* Intenta ejecutarlo desde la consola, e imprime la salida da ver que tal, y pegala aquí.

* con la Jdk 8 ? (o sea, tu proyecto usando la Jdk 1.8)
Otra cosa, ve acostumbrandote con la openJdk LMAOO.



Título: Re: Problema WindowBuilder (Eclipse) - Ventana Cortada
Publicado por: K-YreX en 13 Abril 2020, 10:58

* Intenta ejecutarlo desde la consola, e imprime la salida da ver que tal, y pegala aquí.
El problema lo tengo en la interfaz de WindowBuilder dentro de Eclipse, lo que es el programa se ejecuta bien pero con el descuadre ese que se ve en la ventana de edición de la imagen que puse en el primer mensaje.


* con la Jdk 8 ? (o sea, tu proyecto usando la Jdk 1.8)
Otra cosa, ve acostumbrandote con la openJdk LMAOO.
Normalmente utilizo la openjdk pero por si el problema estaba ahí probé a usar también la otra. Al final ha resultado que con Jdk 8 se ve correctamente. Es un problema ya que tengo que utilizar el 11 pero al menos he encontrado el problema ya que no encontraba nada por Internet sobre esto.

Muchas gracias por la idea. :-X

PD: Dejaré otra imagen con el problema corregido para que se vea la diferencia y por si le sirve a alguien más.
(https://imagizer.imageshack.com/v2/640x480q90/923/csbzeD.png)


Título: Re: Problema WindowBuilder (Eclipse) - Ventana Cortada
Publicado por: rub'n en 13 Abril 2020, 14:09
El problema lo tengo en la interfaz de WindowBuilder dentro de Eclipse, lo que es el programa se ejecuta bien pero con el descuadre ese que se ve en la ventana de edición de la imagen que puse en el primer mensaje.
Normalmente utilizo la openjdk pero por si el problema estaba ahí probé a usar también la otra. Al final ha resultado que con Jdk 8 se ve correctamente. Es un problema ya que tengo que utilizar el 11 pero al menos he encontrado el problema ya que no encontraba nada por Internet sobre esto.

Muchas gracias por la idea. :-X

PD: Dejaré otra imagen con el problema corregido para que se vea la diferencia y por si le sirve a alguien más.
(https://imagizer.imageshack.com/v2/640x480q90/923/csbzeD.png)

Perfecto doc, otra cosa, si necesitas la jdk11, lo mas seguro es que quieras usar alguna librería nativa de ella, ya que contiene nuevas cosas, pero sabes muy bien que eso tiene solución importando esa dependencia a tu proyecto, con maven etc, o importando el .jar que no es tan buena idea hoy en día, no usar un gestor de dependencias como gradle o maven etc. pero ahí te ves doc.

Yo te puedo pasar un pom.xml de maven para que lo uses.