Foro de elhacker.net

Programación => Programación General => Mensaje iniciado por: Tachikomaia en 21 Diciembre 2017, 23:56



Título: mostrar <> o < o <= o == en pantalla?
Publicado por: Tachikomaia en 21 Diciembre 2017, 23:56
hola mundo!!!

hice 1 programa q me muestra el num 0 o 1 o 2 o 3 al azar y ahora quiero q en ves de eso me muestre <> o < o <= o == al azar tambien ¿como seria el seudocode?

gracias!!!


Título: Re: mostrar <> o < o <= o == en pantalla?
Publicado por: NEBIRE en 22 Diciembre 2017, 05:14
(casi) Igual que hayas resuelto el caso previo...

Código:
Funcion EleccionAleatoria
    entero x
    char respuesta
    Hacer
        x= Aleatorio(ente 0 y 3)
        // Mostrar x  //esto sería lo que hacías antes
        // ...y esto la modificación
        Seleccionar x
              cuando 0
                  Mostrar "<>"
              cuando 1
                  Mostrar "<"
              cuando 2
                  Mostrar "<="
              cuando 3
                  Mostrar "=="
        Fin seleccion

        respuesta = PedirAlUsuario("Desea repetir la operación (s/n)?"
    Repetir mientras (respuesta = "s")
Fin funcion


Título: Re: mostrar <> o < o <= o == en pantalla?
Publicado por: Tachikomaia en 22 Diciembre 2017, 18:57
Buenísimo!!!  ;-)

¿Y si en vez de sólo los símbolos quisiera que me muestre una condición de estas?
v == a
v <= a
a <= v
v < a
a < v
a <> v

a sería un número aleatorio, y v sería una referencia a una variable, se vería así, "v".

Basado en tu pseudocódigo supongo que podría ser algo así:
Código:
Funcion EleccionAleatoria
    entero x
    entero a
    char cha
    char resultado
    char respuesta
    Hacer
        x= Aleatorio(entre 0 y 5)
        a= Aleatorio(entre 0 y 10)
        ach= Convertir entero en char(a)
        Seleccionar x
              cuando 0
                  resultado= unir char ("v == ", cha)
              cuando 1
                  resultado= unir char ("v <= ", cha)
              cuando 2
                  resultado= unir char ("v < ", cha)
              cuando 3
                  resultado= unir char ("v <> ", cha)
              cuando 4
                  resultado= unir char (cha, " < v")
              cuando 5
                  resultado= unir char (cha, " <= v")
        Fin seleccion
        Mostrar resultado
        respuesta = PedirAlUsuario("Desea repetir la operación (s/n)?"
    Repetir mientras (respuesta = "s")
Fin funcion
¿Algún error?