Foro de elhacker.net

Programación => Desarrollo Web => Mensaje iniciado por: yoelrodguez en 3 Febrero 2016, 16:07 pm



Título: Problema con jquery y safari
Publicado por: yoelrodguez en 3 Febrero 2016, 16:07 pm
Hola a todos,  tengo el siguiente problema estoy haciendo una matriz donde cargo una imagen,  que me proviene de un modal de bootstrap. El problema se me está presentado en un la Tablet de Mac que utiliza safari como navegador. Este código lo estoy ejecutando en una Tablet Android con Chrome y sin problema al igual que en una pc con Windows que tengo instalado la versión de safari para Windows y también se me ejecuta bien. Aquí les dejo el código para ver si me pueden ayudar.

Saludos

Código  jquery
Código:
//Actiavamos el modo de edición.
$(".edicion").click(function(){
cl = $(this).attr('class');
pos = cl.indexOf("span-imagenedion");
if(pos < 0){
$(this).removeClass("span-imagenedioff").addClass("span-imagenedion");
$('div.imgmosa').each(function(){
$(this).removeClass("span-imagenlim").addClass('span-imagenmas');
});
}else{
$(this).removeClass("span-imagenedion").addClass("span-imagenedioff");
$('div.imgmosa').each(function(){
$(this).removeClass("span-imagenmas").addClass('span-imagenlim');
});
}

});

//Cargasmos el modal con la lista de tipo del producto.
$("div.span-imagenmas").live('click',function(){
id = $(this).attr('id');
$("#divid").val(id);
     $.post('index.php?c=movimiento&f=tipolistmodal',function(data){
$("#tab-prod").html(data.tabla);
$("#myModal3").modal();
},'json');

});
Código HTML
Código:
  <div class="row show-grid">
  <div class="span1 imgmosa" id="div1"></div>
  <div class="span1 imgmosa" id="div2"></div>
  <div class="span1 imgmosa" id="div3"></div>
  <div class="span1 imgmosa" id="div4"></div>
  <div class="span1 imgmosa" id="div5"></div>
  <div class="span1 imgmosa" id="div6"></div>
  <div class="span1 edicion"></div>
  </div>