elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Píldoras formativas en seguridad de la información


+  Foro de elhacker.net
|-+  Media
| |-+  Multimedia (Moderador: Songoku)
| | |-+  Problema para reproducir vídeos de disco duro en tv
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: 1 [2] 3 Ir Abajo Respuesta Imprimir
Autor Tema: Problema para reproducir vídeos de disco duro en tv  (Leído 2,777 veces)
YreX-DwX


Desconectado Desconectado

Mensajes: 698



Ver Perfil
Re: Problema para reproducir vídeos de disco duro en tv
« Respuesta #10 en: 8 Diciembre 2019, 02:52 »

He tenido este tema un poco abandonado por falta de tiempo pero voy a comentar hasta donde he llegado para los que tuviesen curiosidad.
Resulta que he estado intentando convertir dichos vídeos a 24 fps pero no lo he logrado (puede que sea por mi desconocimiento en este tema). Al seleccionar 24 fps en la conversión, obtenía un vídeo mucho más largo de lo original (con 1000 fps según las propiedades del vídeo), con el audio descoordinado y que pasado el tiempo original del vídeo, éste se quedaba con la pantalla en negro.
Al final optaré por utilizar el formato mp4 que automáticamente me cambia los fps a 24 y no genera descoordinación con el audio.

Suena a que te has comprado una TV que no trabaja con PAL y solo NTSC.
Por lo que he estado leyendo, el sistema de la TV depende del lugar de compra y ésta fue comprada en Europa por lo que debería trabajar con el sistema PAL en vez de NTSC. De todas maneras PAL trabaja a 25 fps y NTSC a 30 fps, por lo que no entiendo porque el problema está con los 25 fps si no supera ninguna de los dos valores y en cambio a 24 fps sí puedo reproducir los vídeos.

Si alguien tiene alguna sugerencia más, puede comentármela y lo probaré lo antes posible para daros una respuesta.


En línea

Código
  1. cout << "Todos tenemos un defecto, un error en nuestro código" << endl;
MinusFour
Colaborador
***
Conectado Conectado

Mensajes: 4.833


I'm fourth.


Ver Perfil WWW
Re: Problema para reproducir vídeos de disco duro en tv
« Respuesta #11 en: 8 Diciembre 2019, 04:49 »

De todas maneras PAL trabaja a 25 fps y NTSC a 30 fps, por lo que no entiendo porque el problema está con los 25 fps si no supera ninguna de los dos valores y en cambio a 24 fps sí puedo reproducir los vídeos.

Bueno, NTSC si es efectivamente 29.97 FPS (30 redondeados) pero muchos videos son grabados cerca de 24p (a 23.976 fps) para equipos NTSC.

Si quieres te puedo dar unas muestras a 24p, 25p, 30p en H.264 con niveles main. sencillas para ver si es en efecto eso. Tu también lo puedes hacer si usas un editor de video. Resolve es un editor de video gratuito y deberías poder elegir todas estas opciones. Tienes un mes gratuito con Premiere Pro (de adobe) también. También podrías usar una herramienta como OBS para grabar unas muesstras o simplemente ffmpeg que es lo que usa OBS.


En línea

YreX-DwX


Desconectado Desconectado

Mensajes: 698



Ver Perfil
Re: Problema para reproducir vídeos de disco duro en tv
« Respuesta #12 en: 8 Diciembre 2019, 17:10 »

Acabo de observar una cosa que me hace pensar que el problema no está en los fps... Acabo de probar con un vídeo nuevo *.mp4 a 24 fps y tampoco se ve; sin embargo, he probado con un vídeo diferente *.mp4 a 25 fps y ese sí se puede ver. Os dejo las propiedades de ambos:
Vídeo que sí se ve:
  • Formato: avi
  • Dimensiones: 720 x 404
  • Códec de vídeo: MPEG-4 Vídeo
  • Tasa de fotogramas: 25 fps
  • Tasa de bits (vídeo): 1438 Kbps
  • Códec de audio: MPEG-1 Layer 3 (MP3)
  • Frecuencia de muestreo: 44100 Hz
  • Tasa de bits (audio): 127 Kbps

Vídeo que no se ve:
  • Formato: avi
  • Dimensiones: 720 x 404
  • Códec de vídeo: MPEG-4 Vídeo
  • Tasa de fotogramas: 24 fps
  • Tasa de bits (vídeo): 1499 Kbps
  • Códec de audio: MPEG-1 Layer 3 (MP3)
  • Frecuencia de muestreo: 44100 Hz
  • Tasa de bits (audio): 127 Kbps

PD: He localizado otro vídeo con todas las propiedades iguales al segundo de los expuestos arriba y que sí se ve... Ahora ya no tengo ni la menor idea de a qué puede deberse.

EDIT: Para obtener las propiedades de los vídeos no estoy usando ningún programa específico y si me queréis recomendar algún programa, trabajo con Ubuntu 18 aunque de ser necesario, puedo tener acceso a un Windows 10.
« Última modificación: 8 Diciembre 2019, 17:13 por YreX-DwX » En línea

Código
  1. cout << "Todos tenemos un defecto, un error en nuestro código" << endl;
MinusFour
Colaborador
***
Conectado Conectado

Mensajes: 4.833


I'm fourth.


Ver Perfil WWW
Re: Problema para reproducir vídeos de disco duro en tv
« Respuesta #13 en: 8 Diciembre 2019, 17:21 »

Acabo de observar una cosa que me hace pensar que el problema no está en los fps... Acabo de probar con un vídeo nuevo *.mp4 a 24 fps y tampoco se ve; sin embargo, he probado con un vídeo diferente *.mp4 a 25 fps y ese sí se puede ver. Os dejo las propiedades de ambos:
Vídeo que sí se ve:
  • Formato: avi
  • Dimensiones: 720 x 404
  • Códec de vídeo: MPEG-4 Vídeo
  • Tasa de fotogramas: 25 fps
  • Tasa de bits (vídeo): 1438 Kbps
  • Códec de audio: MPEG-1 Layer 3 (MP3)
  • Frecuencia de muestreo: 44100 Hz
  • Tasa de bits (audio): 127 Kbps

Vídeo que no se ve:
  • Formato: avi
  • Dimensiones: 720 x 404
  • Códec de vídeo: MPEG-4 Vídeo
  • Tasa de fotogramas: 24 fps
  • Tasa de bits (vídeo): 1499 Kbps
  • Códec de audio: MPEG-1 Layer 3 (MP3)
  • Frecuencia de muestreo: 44100 Hz
  • Tasa de bits (audio): 127 Kbps

PD: He localizado otro vídeo con todas las propiedades iguales al segundo de los expuestos arriba y que sí se ve... Ahora ya no tengo ni la menor idea de a qué puede deberse.

EDIT: Para obtener las propiedades de los vídeos no estoy usando ningún programa específico y si me queréis recomendar algún programa, trabajo con Ubuntu 18 aunque de ser necesario, puedo tener acceso a un Windows 10.

Lo único que me llama la atención aquí es que dices que vienen en el formato mp4 pero ahí dice que tienen formato avi. Prueba a renombrar la extensión de los dos archivos a ver si al cambiar a .avi funciona (quizás el demuxer de la tele no sea tan inteligente para identificar que es avi).

Por otro lado puede ser que esa herramienta que estés utilizando para obtener la información del video está mal. ¿Porque no usas MediaInfo?
En línea

crazykenny


Desconectado Desconectado

Mensajes: 3.598



Ver Perfil WWW
Re: Problema para reproducir vídeos de disco duro en tv
« Respuesta #14 en: 8 Diciembre 2019, 18:22 »

Hola, YdreX-DwX.

Justo ahora acabo de encontrarme con el tema que has creado, y, antes de sugerir nada, quisiera preguntarte que programa estas utilizando.

Y, bueno, lo comento porque, como sugerencia, si estas utilizando el programa Format Factory para convertir vídeos, quisiera recomendarte el utilizarlo y probar a ver que pasa, ya que, por mi parte, llevo años utilizandolo para convertir vídeos .mkv a .mp4 (y de paso, añadirles subtitulos), y, de momento,  nunca he tenido el problema que aquí has expuesto.

Muchas gracias por vuestra atención, y, bueno, saludos.
En línea

A nivel personal, lo que me da mas miedo no son los planteamientos y acciones individuales, sino las realizadas en grupo, ya que estas ultimas pueden acabar con consecuencias especialmente nefastas para todos.
Se responsable, consecuente y da ejemplo.
http://informaticayotrostemas.blogspot.com.es/2013/12/situacion-de-la-educacion-actual-en.html
https://informaticayotrostemas.blogspot.com/
YreX-DwX


Desconectado Desconectado

Mensajes: 698



Ver Perfil
Re: Problema para reproducir vídeos de disco duro en tv
« Respuesta #15 en: 8 Diciembre 2019, 22:49 »

Lo único que me llama la atención aquí es que dices que vienen en el formato mp4 pero ahí dice que tienen formato avi. Prueba a renombrar la extensión de los dos archivos a ver si al cambiar a .avi funciona (quizás el demuxer de la tele no sea tan inteligente para identificar que es avi).

Por otro lado puede ser que esa herramienta que estés utilizando para obtener la información del video está mal. ¿Porque no usas MediaInfo?
Fallo mío lo de mp4 :-X Me estaba refiriendo a dos vídeos en formato avi pero he escrito mp4 sin darme cuenta. Será del lío que tengo ya entre formatos y códecs.
He probado a usar MediaInfo y los resultados para ambos vídeos son totalmente idénticos. He comprobado hasta el último número y no he encontrado ninguna diferencia ni en las propiedades de vídeo ni en las de audio.
Código:
Video
ID                                       : 0
Format                                   : MPEG-4 Visual
Format profile                           : Simple@L3
Format settings, BVOP                    : No
Format settings, QPel                    : No
Format settings, GMC                     : No warppoints
Format settings, Matrix                  : Default (H.263)
Codec ID                                 : XVID
Codec ID/Hint                            : XviD
Duration                                 : 42 min 56 s
Bit rate                                 : 1 500 kb/s
Width                                    : 720 pixels
Height                                   : 404 pixels
Display aspect ratio                     : 16:9
Original display aspect ratio            : 16:9
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Compression mode                         : Lossy
Bits/(Pixel*Frame)                       : 0.215
Stream size                              : 461 MiB (91%)
Writing library                          : Lavc56.60.100

Audio
ID                                       : 1
Format                                   : MPEG Audio
Format version                           : Version 1
Format profile                           : Layer 3
Format settings                          : Joint stereo / MS Stereo
Codec ID                                 : 55
Codec ID/Hint                            : MP3
Duration                                 : 42 min 56 s
Bit rate mode                            : Constant
Bit rate                                 : 128 kb/s
Channel(s)                               : 2 channels
Sampling rate                            : 44.1 kHz
Compression mode                         : Lossy
Stream size                              : 39.3 MiB (8%)
Alignment                                : Aligned on interleaves
Interleave, duration                     : 26  ms (0.63 video frame)
Interleave, preload duration             : 522  ms
Esas son las propiedades que muestra MediaInfo. La única diferencia entre un vídeo y otro son 2 segundos de diferencia en la duración del audio (lo cuál me parece irrelevante pero lo digo por si las moscas).

Hola, YdreX-DwX.

Justo ahora acabo de encontrarme con el tema que has creado, y, antes de sugerir nada, quisiera preguntarte que programa estas utilizando.

Y, bueno, lo comento porque, como sugerencia, si estas utilizando el programa Format Factory para convertir vídeos, quisiera recomendarte el utilizarlo y probar a ver que pasa, ya que, por mi parte, llevo años utilizandolo para convertir vídeos .mkv a .mp4 (y de paso, añadirles subtitulos), y, de momento,  nunca he tenido el problema que aquí has expuesto.

Muchas gracias por vuestra atención, y, bueno, saludos.
De momento las conversiones que he realizado las he hecho usando VLC ya que trabajo sobre Ubuntu y como ya lo tenía instalado, me evité el tener que buscar otro programa. Las conversiones de *.mkv a *.mp4 se realizaron bien como comenté en alguno de los mensajes anteriores pero el cambio de la tasa de fotogramas, no. No sé si es porque al cambiar el número de fotogramas por segundo, se modifica la duración del vídeo...
Aún no he podido probar Format Factory pero quería aprovechar este mensaje para responder y de paso agradecer la colaboración.
En línea

Código
  1. cout << "Todos tenemos un defecto, un error en nuestro código" << endl;
MinusFour
Colaborador
***
Conectado Conectado

Mensajes: 4.833


I'm fourth.


Ver Perfil WWW
Re: Problema para reproducir vídeos de disco duro en tv
« Respuesta #16 en: 8 Diciembre 2019, 23:15 »

Fallo mío lo de mp4 :-X Me estaba refiriendo a dos vídeos en formato avi pero he escrito mp4 sin darme cuenta. Será del lío que tengo ya entre formatos y códecs.

Bueno, estos videos no son H.264, son Xvid. ¿Dices que ambos videos usan el mismo codec y solo uno de ellos se reproduce en la tele? ¿También dices que ambos videos usan 23.976 FPS?
En línea

YreX-DwX


Desconectado Desconectado

Mensajes: 698



Ver Perfil
Re: Problema para reproducir vídeos de disco duro en tv
« Respuesta #17 en: 8 Diciembre 2019, 23:59 »

Bueno, estos videos no son H.264, son Xvid. ¿Dices que ambos videos usan el mismo codec y solo uno de ellos se reproduce en la tele? ¿También dices que ambos videos usan 23.976 FPS?
En un principio el problema me surgió con un vídeo en formato *.mkv que usaba H.264 y pensaba que en ello recaía el problema.
PD: He localizado otro vídeo con todas las propiedades iguales al segundo de los expuestos arriba y que sí se ve... Ahora ya no tengo ni la menor idea de a qué puede deberse.
Sin embargo, estos dos últimos vídeos de los que hablo son Xvid, sí y ambos usan el mismo códec y ambos a 23.976 fps. Y en efecto, uno de ellos se puede reproducir y el otro no.
Me he asegurado también de que ambos se pueden reproducir en el ordenador y así es, ambos se reproducen.
En línea

Código
  1. cout << "Todos tenemos un defecto, un error en nuestro código" << endl;
MinusFour
Colaborador
***
Conectado Conectado

Mensajes: 4.833


I'm fourth.


Ver Perfil WWW
Re: Problema para reproducir vídeos de disco duro en tv
« Respuesta #18 en: 9 Diciembre 2019, 21:41 »

En un principio el problema me surgió con un vídeo en formato *.mkv que usaba H.264 y pensaba que en ello recaía el problema.Sin embargo, estos dos últimos vídeos de los que hablo son Xvid, sí y ambos usan el mismo códec y ambos a 23.976 fps. Y en efecto, uno de ellos se puede reproducir y el otro no.
Me he asegurado también de que ambos se pueden reproducir en el ordenador y así es, ambos se reproducen.

Pues francamente, no tengo idea ya. Lo único que se me ocurre es que el sistema de archivos del media que estás utilizando está corrupto o quizás tenga problemas con la información del archivo, como un título con letras extrañas o algo así.

O quizás simplemente el archivo está dañado en cierta forma que hay errores en las que los reproductores de PC pueden seguir corriendo el video y el reproductor de la tele no.
En línea

YreX-DwX


Desconectado Desconectado

Mensajes: 698



Ver Perfil
Re: Problema para reproducir vídeos de disco duro en tv
« Respuesta #19 en: 11 Diciembre 2019, 00:18 »

Ya he conseguido solucionar el problema. :rolleyes: :rolleyes:
Como ya lo había probado todo y nada funcionaba, probé y conectar el disco duro a otra tv y vi que está ni siquiera reconocía el disco duro por lo que pasé los vídeos de ese disco duro (de 4 TB) a otro (de 1 TB) y ahora ya puedo ver todos los vídeos sin problemas.
Al final resulta que no era problema de los códecs ni las tasas ni nada de eso pero bueno, me ha servido para aprender un poco sobre el tema.

Muchas gracias a los que habéis colaborado.
En línea

Código
  1. cout << "Todos tenemos un defecto, un error en nuestro código" << endl;
Páginas: 1 [2] 3 Ir Arriba Respuesta Imprimir 

Ir a:  

Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines