elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Entrar al Canal Oficial Telegram de elhacker.net


+  Foro de elhacker.net
|-+  Seguridad Informática
| |-+  Hacking Ético (Moderador: toxeek)
| | |-+  Problema tras actualizar Metasploit
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema tras actualizar Metasploit  (Leído 2,043 veces)
vk496

Desconectado Desconectado

Mensajes: 205


Ver Perfil
Problema tras actualizar Metasploit
« en: 26 Mayo 2012, 14:21 pm »

Buenas, vengo a preguntaros sobre un problema que tengo en mi Ubuntu 12.04 LTS

Recientemente instalé Metasploit con sus dependencias y no hubo ningun problema para usarlo, pero cuando lo actualicé con msfupdate no me deja arrancarlo y me saca este error:

Código:
root@vk496:/# sudo msfconsole
/usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1177:in `remove_method': method `gem' not defined in Kernel (NameError)
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:1177
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `fastlib_original_require'
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `require'
from /opt/metasploit-4.1.4/msf3/lib/packetfu/packetfu.rb:11
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `fastlib_original_require'
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `require'
from /opt/metasploit-4.1.4/msf3/lib/packetfu.rb:3
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `fastlib_original_require'
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `require'
from /opt/metasploit-4.1.4/msf3/lib/msf/core/db.rb:26
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `fastlib_original_require'
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `require'
from /opt/metasploit-4.1.4/msf3/lib/msf/core/db_manager.rb:4
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `fastlib_original_require'
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `require'
from /opt/metasploit-4.1.4/msf3/lib/msf/core/framework.rb:68
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `fastlib_original_require'
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `require'
from /opt/metasploit-4.1.4/msf3/lib/msf/core.rb:33
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `fastlib_original_require'
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `require'
from /opt/metasploit-4.1.4/msf3/lib/msf/ui/console/driver.rb:1
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `fastlib_original_require'
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `require'
from /opt/metasploit-4.1.4/msf3/lib/msf/ui/console.rb:10
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `fastlib_original_require'
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `require'
from /opt/metasploit-4.1.4/msf3/lib/msf/ui.rb:10
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `fastlib_original_require'
from /opt/metasploit-4.1.4/msf3/lib/fastlib.rb:368:in `require'
from /usr/local/bin/msfconsole:128

Intenté reinstalar el rubygems pero me sigue dando el mismo problema....

Alguna sugerencia¿

Gracias a todos de antemano, Salu2
En línea

Stakewinner00


Desconectado Desconectado

Mensajes: 1.426



Ver Perfil WWW
Re: Problema tras actualizar Metasploit
« Respuesta #1 en: 6 Junio 2012, 21:22 pm »

primero te recomiendo borrar y volver a ionstalar el metasploit que avezes funciona.
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Ayuda. Tras actualizar el Kernel 2.6.34 de Backtrack
GNU/Linux
santi2808 1 1,869 Último mensaje 9 Julio 2010, 04:39 am
por luinuz
problema placa base tras actualizar bios
Hardware
tAySeR 4 3,442 Último mensaje 31 Julio 2010, 16:41 pm
por Aprendiz-Oscuro
Imposible Actualizar Metasploit BT4 R1
Hacking Básico
jpmo4 4 4,211 Último mensaje 16 Octubre 2010, 11:08 am
por Debci
Pregunta "tonta" Tras actualizar a 11.04 « 1 2 »
GNU/Linux
HeXmiT 11 3,884 Último mensaje 1 Mayo 2011, 20:07 pm
por Slava_TZD
problemas al actualizar metasploit con el msfupdate
Hacking Básico
aixeiger 1 2,087 Último mensaje 26 Diciembre 2012, 16:03 pm
por daicon
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines