elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Doble factor de autenticación o verificación en dos pasos


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux
| | |-+  Unix/Unix-Like
| | | |-+  aircrack en freeBSD
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] 2 Ir Abajo Respuesta Imprimir
Autor Tema: aircrack en freeBSD  (Leído 5,553 veces)
Joe Fraddy

Desconectado Desconectado

Mensajes: 275


Ver Perfil
aircrack en freeBSD
« en: 4 Febrero 2014, 20:12 »

Saudos a todos:

He estado haciendo algunas pruebas con aircrack-ng en freeBSD, pero algo sale mal, os pongo los pasos que he seguido.

0. Primero he compilado el programa desde los ports:

Código:
# ifconfig wlan0 down
(para des-habilitar mi tarjeta)

Código:
# ifconfig ${INTERFACE} -mediaopt monitor
(para ponerme en modo monitor)

Código:
# airodump-ng wlan0
(para scannear las redes)

Código:
# airodump-ng -c ${CHANNEL} -w redcxd --bssid 66:77:88:99:00:11 ${INTERFACE}

Hasta aquí todo esta bien, pero a la hora de tratar de inyectar paquetes a la red hago esto y falla:

Código:
# aireplay-ng -1 0 -a 66:77:88:99:00:11 -h 00:11:22:33:44:55 -e  ejemplo ${INTERFACE}

Me dice que mi ${INTERFACE} se ha puesto en el canal 3, 4 o 13, etc, mientras que la red a la que estoy lanzando paquetes se encuentra en el canal 11.

No se si hay que compilar el kernel, parcharlo o me falta algún dato, les agradecería me ayudaran.

Un saludo :-)


En línea

cpu2


Desconectado Desconectado

Mensajes: 923


Ver Perfil
Re: aircrack en freeBSD
« Respuesta #1 en: 4 Febrero 2014, 21:59 »

Mejor postea el error, y elimina la opcion -e de aireplay-ng.

Si el problema persiste seria revisar los foros y los cambios de ese paquete por si alguien tiene el mismo error que tu, no se si me explico. Tambien tendrias que mirar si los drivers nativos de FreeBSD soportan la inyeccion de paquetes, si tienes que instalar algun parche.

No se si tienes que configurar la tarjeta con ifconfig en el canal que quieres escuchar.

Un saludo.


En línea

Joe Fraddy

Desconectado Desconectado

Mensajes: 275


Ver Perfil
Re: aircrack en freeBSD
« Respuesta #2 en: 5 Febrero 2014, 00:59 »

Si, muchas gracias, ya he quitado la opción -e, pero sale lo mismo, aquí están las dos ventanas:

I LA VENTANA DE CAPTURA DE PAQUETES:

Código:
CH 11 ][ Elapsed: 2 mins ][ 2014-02-04 17:49 ][ fixed channel wlan0: 7
los números finales están cambiando constantemente a 1 2 4 13, etc...

II Y en la pantalla de inyección me sale lo siguiente:

Código:
17:48:49  Waiting for beacon frame (BSSID: A4:B1:E9:A1:B4:F0) on channel 13
17:48:51  wlan0 is on channel 13, but the AP uses channel 11

Parece ser un problema del kernel, pero no estoy seguro.
En línea

cpu2


Desconectado Desconectado

Mensajes: 923


Ver Perfil
Re: aircrack en freeBSD
« Respuesta #3 en: 5 Febrero 2014, 07:44 »

Estado leyendo que hay gente de otras distribuciones que tienen el mismo problema, puedes decirme el chip de la tarjeta, version del aircrack.

Tambien podrias pasarme un ifconfig de wlan0, seguro que no es problema del kernel.

Un saludo.
En línea

Joe Fraddy

Desconectado Desconectado

Mensajes: 275


Ver Perfil
Re: aircrack en freeBSD
« Respuesta #4 en: 5 Febrero 2014, 17:54 »

Si, mi tarjeta es una atheros:

Un dmesg:

Código:
ath0: <Atheros 9287> mem 0xec000000-0xec00ffff irq 18 at device 4.0 on pci1
ath0: AR9287 mac 384.2 RF5133 phy 15.15

un ifconfig wlan0:

Código:
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether 64:70:02:c5:a0:fd
inet 192.168.1.64 netmask 0xffffff00 broadcast 192.168.1.255
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
media: IEEE 802.11 Wireless Ethernet OFDM/48Mbps mode 11g
status: associated
ssid xxxxxxxxxxx channel x (2412 MHz 11g) bssid 00:25:68:b6:25:80
regdomain 32924 country CN indoor ecm authmode OPEN privacy ON
deftxkey 1 wepkey 1:40-bit txpower 20 bmiss 7 scanvalid 450 bgscan
bgscanintvl 300 bgscanidle 250 roam:rssi 7 roam:rate 5 protmode CTS
wme burst roaming MANUAL

para mi conexión, uso wpa_supplicant, pero no creo que sea ese el problema, porque tengo que hacer down al wlan0 y despues un up en modo monitor.

Gracias :-)
En línea

cpu2


Desconectado Desconectado

Mensajes: 923


Ver Perfil
Re: aircrack en freeBSD
« Respuesta #5 en: 5 Febrero 2014, 20:34 »

No mostraste el dato que me interesaba, el canal, como puedes observar en airodump te dice que tu tarjeta esta fijada en el canal 7, y aireplay esta rotando.

Prueba en poner tu tarjeta en el canal del AP con ifconfig, que segun aireplay es el 11 o el que sea, para descartar problemas de controladores, parches etc...

Podrias crear una interface para modo monitor, si no deja la interfaz wlan0 "limpia", comenta las lineas de hostname.if (hostname.wlan0m supongo) o de la forma que este configurado, la pones en modo monitor y en el canal del AP.

Un saludo.
En línea

Joe Fraddy

Desconectado Desconectado

Mensajes: 275


Ver Perfil
Re: aircrack en freeBSD
« Respuesta #6 en: 5 Febrero 2014, 22:23 »

Ok, el canal es el 11, como entonces puedo situarme en ese canal cuando audito???
En línea

cpu2


Desconectado Desconectado

Mensajes: 923


Ver Perfil
Re: aircrack en freeBSD
« Respuesta #7 en: 5 Febrero 2014, 23:37 »

Antes de auditar tienes que poner el canal con ifconfig, ya que por lo que veo tienes uno ya situado, por eso te dije que puedes "clonar" wlan0 y ponerla en modo monitor, lee el man de ifconfig y lee sobre create, wlandev, wlanmode.

Pero para salir de dudas, para poner tu interfaz en el canal es a si de simple.

Código:
ifconfig wlan0 channel 11

Un saludo.
En línea

Joe Fraddy

Desconectado Desconectado

Mensajes: 275


Ver Perfil
Re: aircrack en freeBSD
« Respuesta #8 en: 6 Febrero 2014, 01:06 »

Me sigue saliendo lo mismo, parece que el problema se presenta también en linux y se soluciona parchando el kernel o recompilando el driver wifi

El problema es este:

Código:
CH 11 ][ Elapsed: 2 mins ][ 2014-02-04 17:49 ][ fixed channel wlan0: 7

No se si hay que cargar algo al principio en /boot/loader.conf

Estoy usando freeBSD 9.1
En línea

cpu2


Desconectado Desconectado

Mensajes: 923


Ver Perfil
Re: aircrack en freeBSD
« Respuesta #9 en: 6 Febrero 2014, 01:56 »

Si la gente de Linux alguna lo arreglo instalando otra version de los compat-wireless y algunos parches.

Pero la verdad en FreeBSD no lo tengo muy claro, estado mirando los ports y resulta que el mismo paquete tienes unos parches no se si el mismo pkg los instala, pero bueno no esta de mas mirarlos.

Código:
http://svnweb.freebsd.org/ports/head/net-mgmt/aircrack-ng/files/

Si despues de eso no solucionas el problema, no se que decirte, te invitaria a que comentaras el mismo problema en daemon forums, date cuenta que en este subforo no hay gente.

Un saludo.
En línea

Páginas: [1] 2 Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
aircrack-ng gui 2.1 uso aircrack y empiesa de la 14024 y termina en 14321
Wireless en Windows
LordSed 1 2,545 Último mensaje 15 Octubre 2008, 21:31
por Red Chasqui
aircrack-ptw y aircrack-ng no me ofrecen ninguna clave « 1 2 »
Wireless en Linux
charlitron 16 8,001 Último mensaje 30 Diciembre 2008, 12:22
por KARR
Diferencia entre aircrack-ptw y/o aircrack-ng
Wireless en Linux
angui 1 1,681 Último mensaje 6 Febrero 2011, 06:24
por _Slash_
puedo ejecutar aircrack-ng y aircrack-ptw a la vez?
Wireless en Linux
mardukc 1 1,663 Último mensaje 13 Abril 2011, 16:04
por ChimoC
FreeBSD: Como asegurar FreeBSD
Unix/Unix-Like
9ttnix 2 2,270 Último mensaje 26 Noviembre 2011, 07:04
por Foxy Rider
Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines