elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Página de elhacker.net en Google+ Google+


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Problema al instalar Discord para Lubuntu
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] 2 Ir Abajo Respuesta Imprimir
Autor Tema: Problema al instalar Discord para Lubuntu  (Leído 893 veces)
adrysp

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Problema al instalar Discord para Lubuntu
« en: 17 Mayo 2017, 12:21 »

Hola, tengo el problema de que intento instalar Discord para lubuntu 17.04 Zesty Zapus.

Descargo el archivo deb de la pagina oficial de Discord y lo abro, me envía al Software y me da la opción de instalar, le doy a la opción, se queda instalando al 9% y de repente termina, pero se queda el botón de instalar, y otra vez lo mismo.

Modificación: He probado el código:
Código:
$ sudo dpkg -i ruta/a/discord.deb
$ sudo apt-get -f install
Pero no consigo poner bien la ruta y me salta el error:
Citar
dpkg: error: cannot access archive 'ruta/a/discord.deb': No existe el archivo o el directorio
La ruta donde tengo descargado los archivos .deb y tar.gz es:
Citar
/home/sanfelix/Descargas

Modificación 2:
Resuelto el tema de la ruta y el nombre del archivo el problema es que"la arquitectura del paquete (amd64) no corresponde con la del sistema (i386)", ¿alguna solución para esto?
Citar
sanfelix@sanfelix-260-a108ns:~$ sudo dpkg -i ~/Descargas/discord-0.0.1.deb
[sudo] password for sanfelix:
dpkg: error al procesar el archivo /home/sanfelix/Descargas/discord-0.0.1.deb (--install):
 la arquitectura del paquete (amd64) no corresponde con la del sistema (i386)
Se encontraron errores al procesar:
 /home/sanfelix/Descargas/discord-0.0.1.deb

Modificación 3:
Trasteando por Google encontré este comando:
Citar
sanfelix@sanfelix-260-a108ns:~$ sudo dpkg --force-architecture -i ~/Descargas/discord-0.0.1.deb
[sudo] password for sanfelix:
dpkg: atención: sobreseyendo el problema porque está activa la opción --force:
 
dpkg: atención: la arquitectura del paquete (amd64) no corresponde con la del sistema (i386)
Seleccionando el paquete discord:amd64 previamente no seleccionado.
(Leyendo la base de datos ... 148733 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../Descargas/discord-0.0.1.deb ...
Desempaquetando discord:amd64 (0.0.1) ...
dpkg: problemas de dependencias impiden la configuración de discord:amd64:
 discord:amd64 depende de libc6.
 discord:amd64 depende de libasound2.
 discord:amd64 depende de libgconf-2-4.
 discord:amd64 depende de libnotify4.
 discord:amd64 depende de libnspr4.
 discord:amd64 depende de libnss3.
 discord:amd64 depende de libstdc++6.
 discord:amd64 depende de libxss1.
 discord:amd64 depende de libxtst6.
 discord:amd64 depende de libappindicator1.

dpkg: error al procesar el paquete discord:amd64 (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para desktop-file-utils (0.23-1ubuntu2) ...
Procesando disparadores para mime-support (3.60ubuntu1) ...
Se encontraron errores al procesar:
 discord:amd64

Modificación 4:
El problema es que tengo el Lubuntu para 32 bits, y Discord solo funciona en 64 bits.

Gracias y disculpar las molestias.


PD: Soy nuevo usuario en Linux. Perdonar mi ignorancia.


« Última modificación: 22 Mayo 2017, 10:41 por adrysp » En línea

Slava_TZD
Wiki

Desconectado Desconectado

Mensajes: 1.303

♪ [8675309] ♪


Ver Perfil WWW
Re: Problema al instalar Discord para Lubuntu
« Respuesta #1 en: 17 Mayo 2017, 12:31 »

Código:
$ sudo dpkg -i ruta/a/discord.deb
$ sudo apt-get -f install

Saludos


En línea

<mage> what should I give sister for unzipping?
<Kevyn> Um. Ten bucks?
<mage> no I mean like, WinZip?
[Quote #23601]
adrysp

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Re: Problema al instalar Discord para Lubuntu
« Respuesta #2 en: 17 Mayo 2017, 15:06 »

Código:
$ sudo dpkg -i ruta/a/discord.deb
$ sudo apt-get -f install

Saludos

Gracias por contestar, pero me sale este error:
Citar
dpkg: error: cannot access archive 'ruta/a/discord.deb': No existe el archivo o el directorio
En línea

Slava_TZD
Wiki

Desconectado Desconectado

Mensajes: 1.303

♪ [8675309] ♪


Ver Perfil WWW
Re: Problema al instalar Discord para Lubuntu
« Respuesta #3 en: 17 Mayo 2017, 15:21 »

Reemplaza "ruta a" por la ruta al fichero que descargaste...el error que te da es bastante claro "No existe el archivo o el directorio". Te recomiendo leer al menos lo más básico sobre la terminal si piensas usar cualquier distro mas de 5 minutos...
En línea

<mage> what should I give sister for unzipping?
<Kevyn> Um. Ten bucks?
<mage> no I mean like, WinZip?
[Quote #23601]
adrysp

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Re: Problema al instalar Discord para Lubuntu
« Respuesta #4 en: 17 Mayo 2017, 15:51 »

Antes de nada, Slava_TZD como comente en el primer comentario, soy muy nuevo en esto de Linux, pero decirte que e buscado e informado un poco por Google, recurrir a pedir ayuda en un foro es de lo ultimo que hago.

Reemplaza "ruta a" por la ruta al fichero que descargaste...el error que te da es bastante claro "No existe el archivo o el directorio". Te recomiendo leer al menos lo más básico sobre la terminal si piensas usar cualquier distro mas de 5 minutos...

Referente a tu contestación que agradezco, pero que agradecería que fuera un poco mas explicito (debido a mi ignorancia), probé varias formas cambiando "ruta a" pero no ha habido forma.
También e buscado cosas básicas sobre la terminal, pero no encuentro nada que me ayude en este caso.

Mi ruta es "/home/sanfelix/Descargas" por si puede ayudar un poco de información.

Gracias y disculpa si te ha molestado mi ignorancia Slava_TZD.


En línea

Slava_TZD
Wiki

Desconectado Desconectado

Mensajes: 1.303

♪ [8675309] ♪


Ver Perfil WWW
Re: Problema al instalar Discord para Lubuntu
« Respuesta #5 en: 17 Mayo 2017, 15:54 »

Suponiendo que el fichero se llame discord.deb (sino reemplaza discord por discord-0.1 o lo que sea)

Código:
$ sudo dpkg -i ~/Descargas/discord.deb
$ sudo apt-get -f install
En línea

<mage> what should I give sister for unzipping?
<Kevyn> Um. Ten bucks?
<mage> no I mean like, WinZip?
[Quote #23601]
adrysp

Desconectado Desconectado

Mensajes: 6


Ver Perfil
Re: Problema al instalar Discord para Lubuntu
« Respuesta #6 en: 17 Mayo 2017, 16:00 »

Suponiendo que el fichero se llame discord.deb (sino reemplaza discord por discord-0.1 o lo que sea)

Código:
$ sudo dpkg -i ~/Descargas/discord.deb
$ sudo apt-get -f install

Muchas gracias, no había caído en el nombre del archivo.

Pero "la arquitectura del paquete (amd64) no corresponde con la del sistema (i386)", ¿alguna solución para esto?
Citar
sanfelix@sanfelix-260-a108ns:~$ sudo dpkg -i ~/Descargas/discord-0.0.1.deb
[sudo] password for sanfelix:
dpkg: error al procesar el archivo /home/sanfelix/Descargas/discord-0.0.1.deb (--install):
 la arquitectura del paquete (amd64) no corresponde con la del sistema (i386)
Se encontraron errores al procesar:
 /home/sanfelix/Descargas/discord-0.0.1.deb
En línea

Slava_TZD
Wiki

Desconectado Desconectado

Mensajes: 1.303

♪ [8675309] ♪


Ver Perfil WWW
Re: Problema al instalar Discord para Lubuntu
« Respuesta #7 en: 17 Mayo 2017, 16:39 »

Código:
sudo dpkg --add-architecture i386

https://wiki.debian.org/Multiarch/HOWTO

Y luego los otros dos comandos.

EDIT: Olvida lo anterior, tu Ubuntu es de 32bits (justo lo contrario de lo que normalmente pasa), tienes tres opciones, si tu procesador soporta 64bits (lo puedes comprobar con lspcu) puedes añadir esa arquitectura ("sudo dpkg --add-architecture amd64") e instalar el paquete, instalar Ubuntu de 64bits o usar Mumble que es libre y lo puedes compilar donde te salga de...

Citar
$ sudo lscpu
CPU op-mode(s):        32-bit, 64-bit




« Última modificación: 17 Mayo 2017, 17:01 por Slava_TZD » En línea

<mage> what should I give sister for unzipping?
<Kevyn> Um. Ten bucks?
<mage> no I mean like, WinZip?
[Quote #23601]
do-while


Desconectado Desconectado

Mensajes: 1.239


¿Habra que sacarla de paseo?


Ver Perfil
Re: Problema al instalar Discord para Lubuntu
« Respuesta #8 en: 18 Mayo 2017, 02:37 »

No he dicho nada, no me había dado cuenta de que es un problema de arquitectura, no de dependencias... (eso me pasa por entrar a comentar jodido de sueño...)

Si algún admin quiere borrar esto, se lo agradecería.
« Última modificación: 18 Mayo 2017, 02:42 por do-while » En línea

- Doctor, confundo los números y los colores.
- Vaya marrón.
- ¿Marrón? ¡Por el culo te la hinco!
Slava_TZD
Wiki

Desconectado Desconectado

Mensajes: 1.303

♪ [8675309] ♪


Ver Perfil WWW
Re: Problema al instalar Discord para Lubuntu
« Respuesta #9 en: 18 Mayo 2017, 22:46 »

Código:
discord:amd64 depende de libc6.
 discord:amd64 depende de libasound2.
 discord:amd64 depende de libgconf-2-4.
 discord:amd64 depende de libnotify4.
 discord:amd64 depende de libnspr4.
 discord:amd64 depende de libnss3.
 discord:amd64 depende de libstdc++6.
 discord:amd64 depende de libxss1.
 discord:amd64 depende de libxtst6.
 discord:amd64 depende de libappindicator1.

Como ya te comentaba, el paquete es para otra arquitectura y todas esas dependencias también. Dependiendo de tu procesador, añades soporte para amd64 y podrás instalarlo sin problemas o reinstalas el sistema de nuevo.

Si eres el último en escribir en el hilo está bien editar el último mensaje y así no haces doble post pero en cualquier otro caso es hasta contraproducente. La gente que ya te leyó desde el primer día no tiene porque leer de nuevo tu primer mensaje y lo que es peor el último mensaje no será el que has añadido sino el de la última persona en escribir por lo que tu thread se hunde :D
En línea

<mage> what should I give sister for unzipping?
<Kevyn> Um. Ten bucks?
<mage> no I mean like, WinZip?
[Quote #23601]
Páginas: [1] 2 Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Al instalar Lubuntu 12.10 file-roller no extrae directamente (SOLUCIONADO)
GNU/Linux
adgellida 1 1,604 Último mensaje 10 Diciembre 2012, 22:11
por Ketchuz
Problema con Las X en Lubuntu 12.10
GNU/Linux
Ketchuz 6 3,687 Último mensaje 13 Mayo 2013, 16:59
por dato000
problemas de video tras instalar lubuntu 12.10
GNU/Linux
juandingas 0 748 Último mensaje 11 Marzo 2013, 01:58
por juandingas
Problema Instalar Lubuntu 14 64 bits
GNU/Linux
painkillerpucela 1 488 Último mensaje 21 Febrero 2016, 12:41
por Machacador
windows XP no inicia tras instalar lubuntu
Windows
krls 2 387 Último mensaje 22 Enero 2017, 08:33
por Randomize
Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines