elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Personaliza-Escoge el diseño del foro que más te guste.


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux
| | |-+  No funciona chmod +x para dar permisos
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: No funciona chmod +x para dar permisos  (Leído 1,608 veces)
ithory

Desconectado Desconectado

Mensajes: 14


Ver Perfil
No funciona chmod +x para dar permisos
« en: 17 Noviembre 2012, 16:44 »

Hola buenas, estoy tratando de ejecutar varios archivos .sh que me descargo pero en todos me pone lo mismo:
Algo asi como que no tengo permisos para ejecutarlo.
Entonces me voy a la terminal, hago chmod +x nombrearchivo pero no ocurre nada, sigue teniendo solo los permisos de r y w.

Alguien sabe por que no funciona el chmod? tambien he probado con chmod 777 nombredelarchivo pero nada, incluso estando como root (uso debian).

Estoy tratando de instalar el BOINC (una aplicacion para la ayuda a la investigacion extraterrestre, entre otras)
pero no me funciona porque no tengo permisos. (Es un .sh)

Alguien sabe como arreglar esto de que el chmod no funcione??

Saludos!!


En línea

tonigellida


Desconectado Desconectado

Mensajes: 530


Hardware & Software Developer


Ver Perfil WWW
Re: No funciona chmod +x para dar permisos
« Respuesta #1 en: 17 Noviembre 2012, 17:49 »

1.Ponlos en /home/tuusuario
2.Secundario-Propiedades-Permisos y verifica que en ejecutar ponga cualquiera o algo parecido. Esto significa que el permiso oportuno para que cualquiera lo ejecute lo tiene dado "el archivo".
3.abre un terminal en el directorio y pon "./archivo" o "sudo ./archivo"

Debe de funcionar.

Si lo quieres ejecutar en otra localización comprueba los permisos en ella.


En línea

ithory

Desconectado Desconectado

Mensajes: 14


Ver Perfil
Re: No funciona chmod +x para dar permisos
« Respuesta #2 en: 17 Noviembre 2012, 23:17 »

Muchas gracias! Funciona perfectamente!

Pero solo lo puedo ejecutar si lo pongo en la carpeta de usuario como bien dices.


Citar
si lo quieres ejecutar en otra localización comprueba los permisos en ella.

Puedes aclarar un poco más esto?
« Última modificación: 17 Noviembre 2012, 23:23 por ithory » En línea

tonigellida


Desconectado Desconectado

Mensajes: 530


Hardware & Software Developer


Ver Perfil WWW
Re: No funciona chmod +x para dar permisos
« Respuesta #3 en: 17 Noviembre 2012, 23:58 »

Sí. Debes ver qué permisos tienes en la unidad de montaje, es decir en el fstab.

Para modificarlos debes usar por ejemplo la utilidad "Discos" en lubuntu, desconozco si está en otras distros.

En en disco que tengo conectado tengo:

UUID=01CC9A2C539BCDE0 /media/640GB ntfs-3g defaults,nosuid,nodev,nofail,x-gvfs-show 0 0

en el archivo /etc/fstab

Y puedo "exec" scripts. Como ves uso ntfs-3g para poder escribir en ella sin problemas.
En línea

ithory

Desconectado Desconectado

Mensajes: 14


Ver Perfil
Re: No funciona chmod +x para dar permisos
« Respuesta #4 en: 18 Noviembre 2012, 01:04 »

Yo en /etc/fstab tengo lo siguiente:

Citar

  GNU nano 2.2.4                                           Fichero: fstab                                                                                              

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda6 during installation
UUID=d0c83f74-ea0f-4ea2-acfc-17728dae80bc /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda7 during installation
UUID=244004cd-fd83-4d86-896d-6dfd1e2f8ae6 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0


Pero ahí no aparece mi partición D (Datos que es nfts)
Solo la de debian sda6 y el swap sda7

¿Qué debo hacer con esto?

Con la utilidad de discos si que aparece todo, pero no sé qué hacer.

Saludos y gracias por las respuestas  :D

« Última modificación: 18 Noviembre 2012, 01:07 por ithory » En línea

tonigellida


Desconectado Desconectado

Mensajes: 530


Hardware & Software Developer


Ver Perfil WWW
Re: No funciona chmod +x para dar permisos
« Respuesta #5 en: 18 Noviembre 2012, 01:53 »

Pues poner que te lo monte, a mí me lo monta automáticamente si lo pongo así:



Tengo instalado ntfs-3g
En línea

ithory

Desconectado Desconectado

Mensajes: 14


Ver Perfil
Re: No funciona chmod +x para dar permisos
« Respuesta #6 en: 20 Noviembre 2012, 14:15 »

Conseguí montar la particion automáticamente sin la utilidad, simplemente añadiendo la siguiente línea al fichero /etc/fstab:

Citar
UUID=69E1EE8ABBB7D98F /media/DATOS ntfs-3g default 0 0



Saludos!
En línea

tonigellida


Desconectado Desconectado

Mensajes: 530


Hardware & Software Developer


Ver Perfil WWW
Re: No funciona chmod +x para dar permisos
« Respuesta #7 en: 20 Noviembre 2012, 15:57 »

Muy bien, asunto solucionado!!
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Urgente! PROBLEMAS CON PERMISOS CHMOD!
Desarrollo Web
Glober 1 408 Último mensaje 18 Mayo 2004, 18:22
por Glober
duda con mi web kambie los permisos chmod algo asy y ya no se me ve la web
Desarrollo Web
skamilo 3 550 Último mensaje 23 Mayo 2005, 01:13
por marioly
permisos chmod
Desarrollo Web
johnwmartinez 10 1,594 Último mensaje 13 Junio 2005, 00:45
por NelxoN
chmod 000
Desarrollo Web
_Bj0rD_ 1 823 Último mensaje 16 Noviembre 2007, 03:56
por Red Mx
chmod PHP no funciona
PHP
KateLibby 6 365 Último mensaje 10 Septiembre 2014, 00:04
por MinusFour
Powered by SMF 1.1.19 | SMF © 2006-2008, Simple Machines