elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web (Moderadores: дٳŦ٭, #!drvy)
| | |-+  solucion imposible error mysql #1045?¡?
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: solucion imposible error mysql #1045?¡?  (Leído 61,155 veces)
Xmen21

Desconectado Desconectado

Mensajes: 16



Ver Perfil
solucion imposible error mysql #1045?¡?
« en: 24 Enero 2005, 12:28 »


***--------es imposible?

en dias pasado comente un titular: "error mysql #1045"

he pasado pesadillas por culpa de este error

he hecho de todo y este problema no le encuentro solucion....

he hecho lo siguiente:

1. desinstale el programa borrando carpetas en el registro, reinicie, volvi a instalarlo y no paso nada siguiomostrando el mismo error.
2. desinstale con restaurar sistema a un punto anterior al de la instalacion, borrando registros volvi a instalarloo y no paso nada.
3. abri el archivo que menciona el error, una parte de el es:

$cfg['servers'][$i]['user']          = 'root';      // mysql user
$cfg['servers'][$i]['password']      = '';          // mysql password (only needed

donde se repite tres veces, y en medio de ('';) inserte la supuesta contraseña, guarde el archivo, reinicie el apache y volvi a intentar y no paso nada

4. repeti el anterior procedimiento combinando de muchas formas el user y password, en las 3 veces donde se repite el archivo  y no paso nada.

5. pregunte en este foro y en otros y hasta ahora no ha habido nadie que me de una ayuda acertada, la mayoria se refieren a abrir el archivo y modificarlo cosa que ya hice y no paso nada.


decian que para lo unico que no habia solucion era para la muerte, gracias a este error comprobe cuan falso es esto, pues la  muerte si tiene solucion lo que no la tiene es el error:

"phpmyadmin intentó conectarse con el servidor mysql, y el servidor rechazó esta conexión. deberá revisar el host, nombre de usuario y contraseña en config.inc.php y asegurarse que corresponden con la información dada por el administrador del servidor mysql.

error

mysql ha dicho:


#1045 - access denied for user: 'root@localhost' (using password: no)
[documentación] "

en conclusion:





el error cometido es el equivalente a echarle 3 candados a la puerta de una cas y luego botarle adentro las llaves por una ventana. pues la verdad ya me confundi de cual fue la contraseña que coloque cuando accedi a cambiarsela al "root" (cosa que nadie mas debe hacer en la vida)... lo unico

que queda por preguntarme es si:     
1.  aun despues de todo esto, considerando que se haya olvidado la contraseña existe esperanza??????????????

2.  realmente es imposible???????????????


3.  debo volver a instalar una version anterior o posterior?



finalmente si alguien cree que existe alguna solucion, agradeceria que me la hiciera llegar muy pronto, al email ya que este error es de total urgencia solucionarlo, y le acreditaria ante todos los foros donde he puesto este mensaje el derecho de ganador, ademas un espacio de publicidad, podria ser un banner standar, en el sitio web que pienso montar pronto, y sino pues vaya que si existen los imposibles.


En línea

Yo??? Aquí Contemplando, Con la Eternidad Por Delante, Y Siempre en el Mismo Lugar
el-brujo
ehn
***
Desconectado Desconectado

Mensajes: 18.610


La libertad no se suplica, se conquista


Ver Perfil WWW
Re: solucion imposible error mysql #1045?¡?
« Respuesta #1 en: 25 Enero 2005, 03:40 »

Citar
$cfg['servers'][$i]['user']          = 'root';      // mysql user
$cfg['servers'][$i]['password']      = '';          // mysql password (only needed

Esto es del phpMyAdmin.

Si estás instalando el MySQL en Windows, edita el archivo my.cnf y pon allí el password del root.

[client]
# The following password will be sent to all standard MySQL clients
password="my_password"


Citar
He perdido la contraseña del root

Si has perdido la contraseña que usas como root, es decir, para administrar MySQL, puedes establecer otra, usando el mismo ordenador donde físicamente está instalado el daemon:

   1. Apaga el servidor
   2. Inicia el servidor con la opción --skip-grant-tables.
   3. Conecta con el servidor usando mysql -u root mysql. Con eso no te pedira la password y accederas directamante a la base de datos MySQL que es la que guarda la informacion de usuarios.
   4. cambia la contraseña usando este comando SQL:

mysql> UPDATE user SET Password=PASSWORD('nuevacontraseña') WHERE User='root';

   5. Ejecuta un nuevo comando SQL:

mysql> FLUSH PRIVILEGES;

   6. Apaga y reinicia el servidor y ya podras usar la nueva password


En línea

Xmen21

Desconectado Desconectado

Mensajes: 16



Ver Perfil
Re: solucion imposible error mysql #1045?¡?
« Respuesta #2 en: 28 Enero 2005, 16:55 »

hola brujo

gracias por tu ayuda, he hecho lo siguiente:
edite el archivo guardado en windows My.ini y en el

introduje la contraseña luego lo he guardado en C con el

nombre de My.cnf

he podido por fin ingresar a la pagina inicio de las bases

de datos, pero, la ficha variables me sigue presentando el

mismo error, sin embargo te doy el credito de haberme

aproximado un 95% a la solucion de este problema, pero solo

falta arreglar este pequeño pero molesto inconveniente,

(claro que si tenes un manual para manejar este programa te

lo agradeceria tambien,) y explicarme que falta para que se

arregle la ficha variables, por que me sale el mismo error:
-------
phpMyAdmin intentó conectarse con el servidor MySQL, y el

servidor rechazó esta conexión. Deberá revisar el host,

nombre de usuario y contraseña en config.inc.php y

asegurarse que corresponden con la información dada por el

administrador del servidor MySQL.

Error

MySQL ha dicho:


#1045 - Access denied for user: 'root@localhost' (Using

password: NO)
[Documentación]
------
Cuando doy clic en la ficha variables ( las variables del

sistema MySQL,)

NOTA: EL ERROR TAMBIEN SE PRESENTA EN LA FICHA PRIVILEGIOS

CUANDO VOY A EDITAR LOS PRIVILEGIOS DE LA CUENTA DEL ROOT...

HE CREADO OTRA CUENTA NUEVA CON TODOS LOS PRIVILEGIOS Y

CUANDO LO VOY A EDITAR SI FUNCIONA PERO CON LA CUENTA ROOT,

NO, PUES ME MUESTRA EL MISMO ERROR DE SIEMPRE....

tambien me sale en la pagina de entrada en un letrero rojo

con lo siguiente:
Su archivo de configuración contiene parámetros (root sin

contraseña) que corresponden a la cuenta privilegiada

predeterminada de MySQL. Su servidor de MySQL está usando

estos valores, que constituyen una vulnerabilidad. Se le

recomienda corregir esta brecha de seguridad.
--------------------------

------

de verdad que gracias por tu ayuda.




En línea

Yo??? Aquí Contemplando, Con la Eternidad Por Delante, Y Siempre en el Mismo Lugar
el-brujo
ehn
***
Desconectado Desconectado

Mensajes: 18.610


La libertad no se suplica, se conquista


Ver Perfil WWW
Re: solucion imposible error mysql #1045?¡?
« Respuesta #3 en: 29 Enero 2005, 02:28 »

Citar
Su archivo de configuración contiene parámetros (root sin
contraseña) que corresponden a la cuenta privilegiada
predeterminada de MySQL. Su servidor de MySQL está usando
estos valores, que constituyen una vulnerabilidad. Se le
recomienda corregir esta brecha de seguridad.

Ponle contraseña a la cuenta del root.

Lo demás no he entendido nada, fíjate bien en lo que haces y ves paso a paso, creo que vas mirando manuales pero en realidad no entiendes lo que haces, y a la mínima que cambia algo ya te pierdes.
En línea

Xmen21

Desconectado Desconectado

Mensajes: 16



Ver Perfil
Re: solucion imposible error mysql #1045?¡?
« Respuesta #4 en: 30 Enero 2005, 18:33 »

Citar
Ponle contraseña a la cuenta del root


es que precisamente ya lo habia hecho y   por culpa de ello fue todo el problema que se me armo, pero ahora no me deja editar la cuenta del root osea entro ya a la bases de datos, puedo crear tablas pero la ficha variables no me la muestra pues me presenta el error de siempre y ademas....





¿porque  me pide contraseña para el root cuando ya se la habia puesto ????
En línea

Yo??? Aquí Contemplando, Con la Eternidad Por Delante, Y Siempre en el Mismo Lugar
jack23

Desconectado Desconectado

Mensajes: 1


Ver Perfil
Re: solucion imposible error mysql #1045?¡?
« Respuesta #5 en: 13 Febrero 2009, 19:54 »

Brother!!!  ya  encontre la solucion.. bueno porlomenos a mi me  funciono .. lo mas loco!!  es q  no tiene sentido logico.. :s mira es asi.

y lo peor es q ya  yo lo habia  hecho pero noc  por q me  funciona...

yo tambien dije  voy a desiintalar el server y  vuevo a instalarlo.. en mi caso uso  wamp server  en  win xp ..  bueno el  wamp es  muy  comodo y  tiene atagos por asi decirle   de  todas maneras te lo explico y depsues  tu  buscas el archivo.

yo vine desinstale el programa, elimine las carpetas, y  volvi a instalar.. cuando qria entrar a  la base de datos me decia el mismo error..  y q tenia q  confgurar  el  config.ini.php algo asi..  bueno .. leyendo  lo q mando el  brujo..  noc   quise probar pero el  detalle es q  no encontre ese  archivo y habia uno parecido y decidi probar...  ponerle la  clave q  habia puesto aunq eso  fuera encontra de la logica porq ya  habia desinstalado todo ,.. pero en momentos de desesperacion.. nada cuesta probar..  buena la cosa es asi .. pise  clic enel  wamp server...   y luego me pare sobre  mysql  y seleccione my.ini

lo explico asi  porciacaso alguien usa wamp server  y le puede servir de ayuda en el futuro..

bueno   se me habre  el archivo en un block de notas ... busco la parte que dice: #
The following options will be passed to all MySQL clients
[client]
#password   = your_password
port      = 3306
socket      = /tmp/mysql.sock

y dond dice ¡¡your_password!! coloco la clave q habia puesto  y  le doy en guardar .. me meto en phpmyadmin y  funciona!! =D si no te  funciona prueba  hacer esto.
pisa en el boton derecho en el  wamp server y dale salir, inicia otra ves el  wamp server  y intenta de nuevo meterte  al phpmyadmin.. de esta  forma te deve  funcionar! espero q  a alguien le  haya servido de ayuda..  de ser asi  hagamelo sabe.. =D  saludos.. :)
En línea

coquito_navideño

Desconectado Desconectado

Mensajes: 3


Ver Perfil
Re: solucion imposible error mysql #1045?¡?
« Respuesta #6 en: 14 Febrero 2009, 15:11 »

Siento mucho tardar en responder....

Lo que dice el Brujo esta bien, pero es una falla de seguridad poner la contrasena de root dentro del my.ini en caso de emergencia como te olvidaste de la clave ok, puedes hacer eso.... pero ya accesado a MySQL es cambiarle el password asap a root. Y quitar o comentar la linea password en el my.ini tambien, no hay necesidad de reiniciar MySQL al resetear la contrasena de root por eso se usa FLUSH PRIVILIGES para actualizar la metadata.

Jack23  seguro que esto :

[client]
#password   = your_password
port      = 3306
socket      = /tmp/mysql.sock

Esta correcto? que se sepa se crean sockets en MySQL en entornos Unix o Linux.... pero en el caso de Windows... a no ser que vayas a conectarte a traves de memoria compartida o por named pipes... que no creo que sea el caso. Esto sin contar que en entornos Windows /tmp no existe.... en Windows te conectas a MySQL a traves de TCP/IP siempre y cuando este asi especificado en my.ini o sea que este comentado :

skip-networking

Si esto esta descomentado, tendras que acceder a MySQL a traves de un Socket que deberas generar ya que Windows no lo hace por ti, esto lo generas iniciando MySQL con la opcion --enable-named-pipe

Su problema no es de conexión a la DB, su problema es que por alguna razon la contrasena de root no esta siendo enviada en algunas situaciones que lo requieren :

1045 - Access denied for user: 'root@localhost' (Using
password: NO)

Verifica el codigo fuente de donde anda ficha variables o similar y verifica que la variable que conecta a MySQL antes de enviar la peticion realmente tiene o indica que se envie el usuario y la contrasena... porque aparentemente hay pedazos donde no envia la contrasena de root y pues te rebota.
En línea

chemo75

Desconectado Desconectado

Mensajes: 1


Ver Perfil
Re: solucion imposible error mysql #1045?¡?..SOLUCION SENCILLA!!!!
« Respuesta #7 en: 19 Abril 2009, 20:21 »

HOLA  A TODOS VEO que MUCHOS  SUFREN CON ESTE PROBLEMA  AHI LES VA LA SOLUCION.. ES MUY  SENCILLA RAPIDA..

  acceder COMO ROOT EN WAMPSERVER PARA TENER MAS SEGURIDAN EN  NUESTRO SERVIDOR.

1..BUSCAMOS ESTA DIRECCION
C:\wamp\apps\phpmyadmin3.1.3.1

LUEGO EDITAMOS EL ARCHIVO config.inc.php CON WORPAD ES MAR ORDENADO...OK LISTO.


2.-CAMBIAREMOS EL ACCESO AL SERVIDOR.

MODIFICAMOS..

/* Servers configuration */
$i = 0;

/* Server: localhost [1] */
$i++;
$cfg['Servers'][$i]['verbose'] = 'localhost';
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['port'] = '';
$cfg['Servers'][$i]['socket'] = '';
$cfg['Servers'][$i]['connect_type'] = 'http';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['auth_type'] = 'http';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;


LAS LINEAS SUBRAYADAS REMPLARZEMOS TCP Y CONFIG POR "http".



Guardar cambios.. yyy  listo.. logearsen en el servidor..

________________________________________________________
Ing.En Sitemas computacionales.
comentario: chemo75_jejejey@hotmail.com

En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
[VB NET] Error sin solucion aparentemente[Solucionado!!!] « 1 2 3 »
.NET
ignorantev1.1 30 11,863 Último mensaje 12 Febrero 2011, 20:35
por Edu
[S/ Solucion] [SMF] [MySQL] Ver claves de usuarios
Desarrollo Web
Di~OsK 11 3,761 Último mensaje 15 Junio 2011, 20:36
por Di~OsK
Solución al error 0×80070646, error 646 y error 1606 al instalar actualizaciones
Noticias
wolfbcn 0 855 Último mensaje 11 Julio 2011, 20:39
por wolfbcn
Vídeo imposible de descargar ¿Alguna solución?
Dudas Generales
_Mickey_ 3 2,973 Último mensaje 14 Octubre 2011, 23:21
por _Mickey_
Error #1045 que no hay manera de resolver
Bases de Datos
Rykku 1 2,966 Último mensaje 2 Diciembre 2011, 23:23
por Rykku
Powered by SMF 1.1.19 | SMF © 2006-2008, Simple Machines