elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Guía rápida para descarga de herramientas gratuitas de seguridad y desinfección.


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación General
| | |-+  ASM (Moderador: Eternal Idol)
| | | |-+  AYUDA! Error al enlazar en assembler
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: AYUDA! Error al enlazar en assembler  (Leído 773 veces)
Suncar007

Desconectado Desconectado

Mensajes: 10


Ver Perfil
AYUDA! Error al enlazar en assembler
« en: 17 Julio 2016, 10:51 »

Estoy usando NASM en Windows 7 x86.

Y al compilar el codigo (Un sencillo hola  mundo), hasta ahi todo bien no me da errores,
el Problema es al intentar linkar el archivo que me da el siguiente error:

ld: Unrecognised emulation mode: elf_i386
Supported Emulations: elf_i386pe

NO se que pasa.


En línea

Eternal Idol
Moderador
***
Desconectado Desconectado

Mensajes: 5.504


La mano invisible del mercado me robo la billetera


Ver Perfil WWW
Re: AYUDA! Error al enlazar en assembler
« Respuesta #1 en: 18 Julio 2016, 09:35 »

Usa el PE (es el formato de ejecutable de Windows) que es lo que esta disponible y lo dice ahi mismo.


En línea

La economía nunca ha sido libre: o la controla el Estado en beneficio del Pueblo o lo hacen los grandes consorcios en perjuicio de éste.
Juan Domingo Perón
Suncar007

Desconectado Desconectado

Mensajes: 10


Ver Perfil
Re: AYUDA! Error al enlazar en assembler
« Respuesta #2 en: 18 Julio 2016, 13:32 »

ok
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines